Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Anyway to force resolution under 1024x768 in Battlefield Bad Company 2


Recommended Posts

My graphics card is s*it. I'm getting like 20fps on the lowest settings in BFBC2 however its at 1024x768. Anyway I can force it to 800x600 or even 640x480? I did this under America's Army 3 by forcing it in the config.

Edited by computerwizkid
Link to post
Share on other sites

  • 3 months later...

There are loads of other ways to make it run faster too such as running in DX9 mode, updating your GPU drivers (IMPORTANT YOU DO THIS!), disabling background tasks/services from running before you play etc.

Changing your sound type to headset in the in game menu can help give you an extra frame or two as well.

Here is a super fast config that I created (just copy it into the "settings" file overwriting the old text). Settings file is located in "My Documents\BFBC2" and is called "settings.ini". No settings in the "GameSettings.ini" file really affect performance.

[WindowSettings]

Width=640

Height=480

Fullscreen=true

RefreshRate=60

VSync=false

[sound]

Quality=low

VoipEnable=false

SpeakerCount=2

[Graphics]

Effects=low

Soldiers=low

Vehicles=low

Overgrowth=low

Undergrowth=low

StaticObjects=low

Terrain=low

Shadows=low

Bloom=false

HSAO=false

MSAA=0

Water=low

MainQuality=custom

Texture=low

DxVersion=9

Aniso=0

Detail=low

RenderAheadLimit=0

Fov=65

Edited by Zenskas
Link to post
Share on other sites
  • 2 weeks later...

There are loads of other ways to make it run faster too such as running in DX9 mode, updating your GPU drivers, making sure everything in the config is "off" or in the case of AA and AF set those to "0".

I think changing your sound type to headset in the in game menu can help to.

Here is a super fast config for you (just copy it into the "settings" file overwriting the old text):

[WindowSettings]

Width=640

Height=480

Fullscreen=true

RefreshRate=60

VSync=false

[sound]

Quality=low

VoipEnable=false

SpeakerCount=2

[Graphics]

Effects=low

Soldiers=low

Vehicles=low

Overgrowth=low

Undergrowth=low

StaticObjects=low

Terrain=low

Shadows=low

Bloom=false

HSAO=false

MSAA=0

Water=low

MainQuality=custom

Texture=low

DxVersion=9

Aniso=0

Detail=low

RenderAheadLimit=0

Fov=65

Unfortunately I don't have BC2. I only played the Beta, and I thought it was awful.

Link to post
Share on other sites
  • 2 weeks later...

Hmm could be something to do with playing it on the comp of yours?

I found upgrading from my 9600GT (already better than your current card if I'm not mistaken) to a GTX 260+ OC'ed card made the game so much better. That and fixing the connection issues my modem was having :whistle:

Beta was pretty decent and retail was better but it has had some serious updating since then and is now even better!

Like all BF games they get lots of fixes and new features over time with a heap of patching within the first 6 months :yes:

Even BF2 which is a pretty old game now got a very large update sometime earlier this year.

Link to post
Share on other sites
  • 2 weeks later...

There are loads of other ways to make it run faster too such as running in DX9 mode, updating your GPU drivers, making sure everything in the config is "off" or in the case of AA and AF set those to "0".

I think changing your sound type to headset in the in game menu can help to.

Here is a super fast config for you (just copy it into the "settings" file overwriting the old text):

[WindowSettings]

Width=640

Height=480

Fullscreen=true

RefreshRate=60

VSync=false

[sound]

Quality=low

VoipEnable=false

SpeakerCount=2

[Graphics]

Effects=low

Soldiers=low

Vehicles=low

Overgrowth=low

Undergrowth=low

StaticObjects=low

Terrain=low

Shadows=low

Bloom=false

HSAO=false

MSAA=0

Water=low

MainQuality=custom

Texture=low

DxVersion=9

Aniso=0

Detail=low

RenderAheadLimit=0

Fov=65

Please help! I am trying to get Bad Company 2 to run at 640x480 or 800x600. I copied and pasted the above into my settings folder and when I start the game, the resolution is 640x480 for about 10 seconds and then it automatically switches to the 1024x768 resolution :realmad: . My laptop is good for games as long as I'm able to run them at 800x600... It's very annoying that it won't stay on the resolution I set in the settings file. Can anybody explain how to make it stop changing automatically? Thank you!!! :lol:

-Anthony

Link to post
Share on other sites

True, try getting into a game and seeing if it runs at 640x480.

BTW what is the specs of your laptop?

CPU, RAM and GPU?

CPU = Dual T9300's @ 2.50GHz

RAM = 4GB

GPU = NVIDIA GeForce 8600M GT

Link to post
Share on other sites
  • 6 months later...

i have the same problem.

When te game came out, i changed the resolution to 640x480 and it stayed 640x480.

So i didnt play this game for 8-10months, and know when i change the reso to 640x480 and go IG, it changes automatticly to 1024x768

yalp:)

Link to post
Share on other sites
  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...