Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Ask your Seven xml ? here


Recommended Posts


Hi , could someone help me ? just tell me if my autounattended is right please :)

<?xml version="1.0" encoding="utf-8"?><unattend xmlns="urn:schemas-microsoft-com:unattend">    <servicing>        <package action="configure">            <assemblyIdentity name="Microsoft-Windows-LocalPack-CA-Package" version="6.1.7601.17514" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="" />            <selection name="LocalPack-CA" state="false" />        </package>    </servicing>    <settings pass="windowsPE">        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <SetupUILanguage>                <UILanguage>fr-FR</UILanguage>            </SetupUILanguage>            <InputLocale>fr-FR</InputLocale>            <UILanguage>fr-FR</UILanguage>            <UILanguageFallback>fr-FR</UILanguageFallback>            <UserLocale>fr-FR</UserLocale>            <LayeredDriver>1</LayeredDriver>            <SystemLocale>fr-FR</SystemLocale>        </component>        <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <ComplianceCheck>                <DisplayReport>OnError</DisplayReport>            </ComplianceCheck>            <DiskConfiguration>                <WillShowUI>OnError</WillShowUI>                <Disk wcm:action="remove">                    <CreatePartitions>                        <CreatePartition wcm:action="add">                            <Type>Primary</Type>                            <Order>1</Order>                            <Extend>true</Extend>                        </CreatePartition>                    </CreatePartitions>                    <ModifyPartitions>                        <ModifyPartition wcm:action="add">                            <Active>true</Active>                            <Format>NTFS</Format>                            <Label>SYSTEM</Label>                            <Order>1</Order>                            <PartitionID>1</PartitionID>                            <Letter>C</Letter>                        </ModifyPartition>                    </ModifyPartitions>                    <DiskID>0</DiskID>                    <WillWipeDisk>true</WillWipeDisk>                </Disk>            </DiskConfiguration>            <DynamicUpdate>                <Enable>true</Enable>            </DynamicUpdate>            <UserData>                <ProductKey>                    <WillShowUI>Never</WillShowUI>                </ProductKey>                <AcceptEula>true</AcceptEula>                <FullName>AFPA</FullName>                <Organization>AFPA</Organization>            </UserData>            <ImageInstall>                <OSImage>                    <InstallFrom>                        <MetaData wcm:action="add">                            <Key>/IMAGE/INDEX</Key>                            <Value>1</Value>                        </MetaData>                    </InstallFrom>                    <InstallTo>                        <DiskID>0</DiskID>                        <PartitionID>1</PartitionID>                    </InstallTo>                </OSImage>            </ImageInstall>        </component>    </settings>    <settings pass="specialize">        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <Themes>                <DefaultThemesOff>true</DefaultThemesOff>            </Themes>            <WindowsFeatures>                <ShowMediaCenter>false</ShowMediaCenter>            </WindowsFeatures>            <ComputerName>pc-00000-00</ComputerName>            <RegisteredOrganization>AFPA</RegisteredOrganization>            <RegisteredOwner>AFPA</RegisteredOwner>            <ShowWindowsLive>false</ShowWindowsLive>            <TimeZone>Central Europe Standard Time</TimeZone>        </component>        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <CompanyName>AFPA</CompanyName>            <DisableFirstRunWizard>true</DisableFirstRunWizard>            <Home_Page>http://www.afpa.fr</Home_Page>            <PlaySound>false</PlaySound>            <Window_Title_CN>l'AFPA</Window_Title_CN>            <FavoritesDelete>true</FavoritesDelete>        </component>        <component name="Microsoft-Windows-Fax-Service" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <Fax>                <ArchiveFaxes>false</ArchiveFaxes>                <IncomingFaxesArePublic>false</IncomingFaxesArePublic>            </Fax>            <FaxUnattend>                <ReceiveFaxes>false</ReceiveFaxes>            </FaxUnattend>        </component>    </settings>    <settings pass="oobeSystem">        <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <InputLocale>fr-FR</InputLocale>            <SystemLocale>fr-FR</SystemLocale>            <UILanguage>fr-FR</UILanguage>            <UILanguageFallback>fr-FR</UILanguageFallback>            <UserLocale>fr-FR</UserLocale>        </component>        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <AutoLogon>                <Password>                    <Value>UABhAHMAcwB3AG8AcgBkAA==</Value>                    <PlainText>false</PlainText>                </Password>                <Enabled>true</Enabled>                <LogonCount>999999999</LogonCount>                <Username>afpa</Username>            </AutoLogon>            <OOBE>                <HideEULAPage>true</HideEULAPage>                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>                <NetworkLocation>Work</NetworkLocation>                <ProtectYourPC>1</ProtectYourPC>            </OOBE>			<FirstLogonCommands>				<SynchronousCommand wcm:action="add">					<CommandLine>mkdir %systemdrive%\FLOGONok</CommandLine>					<Description>Make Directory</Description>					<Order>1</Order>					</SynchronousCommand>				<SynchronousCommand wcm:action="add">					<CommandLine>FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\AppsRoot.txt SETX AppsRoot %i: -m</CommandLine>					<Description>Root</Description>					<Order>2</Order>					</SynchronousCommand>				<SynchronousCommand wcm:action="add">					<CommandLine>start /wait /i %AppsRoot%\install\install.bat ALLUSERS=1 /qb! /norestart</CommandLine>					<Description>7zip</Description>					<Order>3</Order>					</SynchronousCommand>			</FirstLogonCommands>            <UserAccounts>                <AdministratorPassword>                    <Value>QABmAHAAYQBQAOkAZABhAGcAbwBBAGQAbQBpAG4AaQBzAHQAcgBhAHQAbwByAFAAYQBzAHwBvAHIAZAA=</Value>                    <PlainText>false</PlainText>                </AdministratorPassword>                <LocalAccounts>                    <LocalAccount wcm:action="add">                        <Password>                            <Value>UABhAHMAcwB3AG8AcgBkAA==</Value>                            <PlainText>false</PlainText>                        </Password>                        <Description>Stagiaire AFPA</Description>                        <DisplayName>Stagiaire AFPA</DisplayName>                        <Group>Administrators</Group>                        <Name>afpa</Name>                    </LocalAccount>                </LocalAccounts>            </UserAccounts>            <VisualEffects>                <FontSmoothing>ClearType</FontSmoothing>            </VisualEffects>            <WindowsFeatures>                <ShowMediaCenter>false</ShowMediaCenter>            </WindowsFeatures>            <TimeZone>Central Europe Standard Time</TimeZone>            <RegisteredOrganization>AFPA</RegisteredOrganization>            <RegisteredOwner>AFPA</RegisteredOwner>            <ShowWindowsLive>false</ShowWindowsLive>					</component>    </settings>    <cpi:offlineImage cpi:source="wim:f:/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" /></unattend>
Link to post
Share on other sites

I tried like this :

<?xml version="1.0" encoding="utf-8"?><unattend xmlns="urn:schemas-microsoft-com:unattend">    <servicing>        <package action="configure">            <assemblyIdentity name="Microsoft-Windows-LocalPack-CA-Package" version="6.1.7601.17514" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="" />            <selection name="LocalPack-CA" state="false" />        </package>    </servicing>    <settings pass="windowsPE">        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <SetupUILanguage>                <UILanguage>fr-FR</UILanguage>            </SetupUILanguage>            <InputLocale>fr-FR</InputLocale>            <UILanguage>fr-FR</UILanguage>            <UILanguageFallback>fr-FR</UILanguageFallback>            <UserLocale>fr-FR</UserLocale>            <LayeredDriver>1</LayeredDriver>            <SystemLocale>fr-FR</SystemLocale>        </component>        <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <ComplianceCheck>                <DisplayReport>OnError</DisplayReport>            </ComplianceCheck>            <DiskConfiguration>                <WillShowUI>OnError</WillShowUI>                <Disk wcm:action="remove">                    <CreatePartitions>                        <CreatePartition wcm:action="add">                            <Type>Primary</Type>                            <Order>1</Order>                            <Extend>true</Extend>                        </CreatePartition>                    </CreatePartitions>                    <ModifyPartitions>                        <ModifyPartition wcm:action="add">                            <Active>true</Active>                            <Format>NTFS</Format>                            <Label>SYSTEM</Label>                            <Order>1</Order>                            <PartitionID>1</PartitionID>                            <Letter>C</Letter>                        </ModifyPartition>                    </ModifyPartitions>                    <DiskID>0</DiskID>                    <WillWipeDisk>true</WillWipeDisk>                </Disk>            </DiskConfiguration>            <DynamicUpdate>                <Enable>true</Enable>            </DynamicUpdate>            <UserData>                <ProductKey>                    <WillShowUI>Never</WillShowUI>                </ProductKey>                <AcceptEula>true</AcceptEula>                <FullName>AFPA</FullName>                <Organization>AFPA</Organization>            </UserData>            <ImageInstall>                <OSImage>                    <InstallFrom>                        <MetaData wcm:action="add">                            <Key>/IMAGE/INDEX</Key>                            <Value>1</Value>                        </MetaData>                    </InstallFrom>                    <InstallTo>                        <DiskID>0</DiskID>                        <PartitionID>1</PartitionID>                    </InstallTo>                </OSImage>            </ImageInstall>        </component>    </settings>    <settings pass="specialize">        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <Themes>                <DefaultThemesOff>true</DefaultThemesOff>            </Themes>            <WindowsFeatures>                <ShowMediaCenter>false</ShowMediaCenter>            </WindowsFeatures>            <ComputerName>pc-00000-00</ComputerName>            <RegisteredOrganization>AFPA</RegisteredOrganization>            <RegisteredOwner>AFPA</RegisteredOwner>            <ShowWindowsLive>false</ShowWindowsLive>            <TimeZone>Central Europe Standard Time</TimeZone>        </component>        <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <CompanyName>AFPA</CompanyName>            <DisableFirstRunWizard>true</DisableFirstRunWizard>            <Home_Page>http://www.afpa.fr</Home_Page>            <PlaySound>false</PlaySound>            <Window_Title_CN>l'AFPA</Window_Title_CN>            <FavoritesDelete>true</FavoritesDelete>        </component>        <component name="Microsoft-Windows-Fax-Service" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <Fax>                <ArchiveFaxes>false</ArchiveFaxes>                <IncomingFaxesArePublic>false</IncomingFaxesArePublic>            </Fax>            <FaxUnattend>                <ReceiveFaxes>false</ReceiveFaxes>            </FaxUnattend>        </component>    </settings>    <settings pass="oobeSystem">        <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <InputLocale>fr-FR</InputLocale>            <SystemLocale>fr-FR</SystemLocale>            <UILanguage>fr-FR</UILanguage>            <UILanguageFallback>fr-FR</UILanguageFallback>            <UserLocale>fr-FR</UserLocale>        </component>        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <AutoLogon>                <Password>                    <Value>UABhAHMAcwB3AG8AcgBkAA==</Value>                    <PlainText>false</PlainText>                </Password>                <Enabled>true</Enabled>                <LogonCount>999999999</LogonCount>                <Username>afpa</Username>            </AutoLogon>            <FirstLogonCommands>				<SynchronousCommand wcm:action="add">					<CommandLine>cmd /C mkdir %systemdrive%\FLOGONok</CommandLine>					<Description>Make Directory</Description>					<Order>1</Order>					</SynchronousCommand>				<SynchronousCommand wcm:action="add">					<CommandLine>cmd /C FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\AppsRoot.txt SETX AppsRoot %i: -m</CommandLine>					<Description>Root</Description>					<Order>2</Order>					</SynchronousCommand>				<SynchronousCommand wcm:action="add">					<CommandLine>cmd /C start /wait /i %AppsRoot%\install\install.bat ALLUSERS=1 /qb! /norestart</CommandLine>					<Description>7zip</Description>					<Order>3</Order>					</SynchronousCommand>			</FirstLogonCommands>			<OOBE>                <HideEULAPage>true</HideEULAPage>                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>                <NetworkLocation>Work</NetworkLocation>                <ProtectYourPC>1</ProtectYourPC>            </OOBE>            <UserAccounts>                <AdministratorPassword>                    <Value>QABmAHAAYQBQAOkAZABhAGcAbwBBAGQAbQBpAG4AaQBzAHQAcgBhAHQAbwByAFAAYQBzAHMAdwBvAHIAZAA=</Value>                    <PlainText>false</PlainText>                </AdministratorPassword>                <LocalAccounts>                    <LocalAccount wcm:action="add">                        <Password>                            <Value>UABhAHMAcwB3AG8AcgBkAA==</Value>                            <PlainText>false</PlainText>                        </Password>                        <Description>Stagiaire AFPA</Description>                        <DisplayName>Stagiaire AFPA</DisplayName>                        <Group>Administrators</Group>                        <Name>afpa</Name>                    </LocalAccount>                </LocalAccounts>            </UserAccounts>            <VisualEffects>                <FontSmoothing>ClearType</FontSmoothing>            </VisualEffects>            <WindowsFeatures>                <ShowMediaCenter>false</ShowMediaCenter>            </WindowsFeatures>            <TimeZone>Central Europe Standard Time</TimeZone>            <RegisteredOrganization>AFPA</RegisteredOrganization>            <RegisteredOwner>AFPA</RegisteredOwner>            <ShowWindowsLive>false</ShowWindowsLive>		</component>    </settings>    <cpi:offlineImage cpi:source="wim:f:/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" /></unattend>

So it works with the MKDIR but it told me that my install.bat can't be find .

I think the path is ok , isn't it ?

Link to post
Share on other sites

Hi , thanks for your answer ! :)

What you don't understand is I have to do it only with Autounattend.xml . I mean , I already have an autounattend and I have to integrate my app in it only with autounattend.

Thanks !

Edited by Bobbymat26
Link to post
Share on other sites

To find out where the xml is failing look at the setuperr.log from C:\Windows\Panther folder.


Your cdrom variable with the marker file is not reading the drive letter of your usb So the install.bat will never work! I have Never seen a successful variable drive reading with a .xml file, only people reporting issues that it will not work, So other option is just to slipstream 7-zip to your image file with RT7 or use the setupcomplete.cmd to install it for you.

DP :whistle:

Link to post
Share on other sites

@Bobbymat26

Even if you Do get 7-zip to install it will require a system reboot to complete it's installation and show up in your programs and features list. So just add this

<SynchronousCommand wcm:action="add">-->              <Description>Reboot System to Complete Post Installs</Description>            <Order>3</Order>            <CommandLine>cmd /c %Windir%\system32\shutdown.exe /r /f /t 0</CommandLine></SynchronousCommand>
Link to post
Share on other sites

So it works with the MKDIR but it told me that my install.bat can't be find .

I think the path is ok , isn't it ?

Not for me. Does your image have a custom Environment Variable for %AppsRoot% ? It seems not a default setting at least in Windows 7.

Link to post
Share on other sites
<CommandLine>cmd /C start /wait /i %AppsRoot%\install\install.bat ALLUSERS=1 /qb! /norestart</CommandLine>

You have 2 issues with your commandline, you don't use a .msi switch with a .exe install and also you don't use a silent switch with a bat file

Link to post
Share on other sites

Not for me. Does your image have a custom Environment Variable for %AppsRoot% ? It seems not a default setting at least in Windows 7.

He appears to try and set it here:

...

<CommandLine>cmd /C FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\AppsRoot.txt SETX AppsRoot %i: -m</CommandLine>

...

Cheers and Regards

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...