Jump to content

7Customizer - a Windows 7 Customization and Deployment tool


 Share

Recommended Posts

On Twitter Blue wrote 2 weeks ago:

7customizer

Continuing development after being very busy in work. 11:35 PM May 25th via web

Who knows how long will Blue be busy and when will he come back ?

Link to comment
Share on other sites


Wait what ?.

So if i only have 7 Ultimate, 7C cant mount it beacuse its just one index ? ****..

In our Forum Win-Lite.de Users with only one Imgae in the Win 7 DVD had the same problem.

So we thinking the mistake is this one Image inside the Win 7 DVD.

beatmaster

Link to comment
Share on other sites

In our Forum Win-Lite.de Users with only one Imgae in the Win 7 DVD had the same problem.

So we thinking the mistake is this one Image inside the Win 7 DVD.

beatmaster

However you can read the post made by RickSteele 05 June 2010

I installed Enterprise x86 on my daughter's laptop-Dell Inspiron 1720 without issue using 7C along with two other apps; the Install.wim on Enterprise is Index 1 and that is the only install.wim index because there are no other versions included in the iso due to the fact that Enterprise is Ultimate, and only Ultimate.
Edited by myselfidem
Link to comment
Share on other sites

Wait what ?.

So if i only have 7 Ultimate, 7C cant mount it beacuse its just one index ? ****..

In our Forum Win-Lite.de Users with only one Imgae in the Win 7 DVD had the same problem.

So we thinking the mistake is this one Image inside the Win 7 DVD.

beatmaster

Aha, hm might be the problem i think.

In our Forum Win-Lite.de Users with only one Imgae in the Win 7 DVD had the same problem.

So we thinking the mistake is this one Image inside the Win 7 DVD.

beatmaster

However you can read the post made by RickSteele 05 June 2010

I installed Enterprise x86 on my daughter's laptop-Dell Inspiron 1720 without issue using 7C along with two other apps; the Install.wim on Enterprise is Index 1 and that is the only install.wim index because there are no other versions included in the iso due to the fact that Enterprise is Ultimate, and only Ultimate.

Hm... bit weird. i can tr it myself later.

Link to comment
Share on other sites

Tried out the 0.4.4

Got error with a '&' sign in filename in "Windows Install path".

Under the Drivers tab, you have to select sub-drives before you choose the multi"To integrate folder of drivers .....", otherwise it would not be included.

Regards

B115242

Link to comment
Share on other sites

Tried out the 0.4.4

Got error with a '&' sign in filename in "Windows Install path".

Under the Drivers tab, you have to select sub-drives before you choose the multi"To integrate folder of drivers .....", otherwise it would not be included.

Regards

B115242

Good info we already knew..

Not about the & though (maybe), is there a space in the path you know why its not working...

Link to comment
Share on other sites

Here are the Mistake of your enterprise Version of Win7:

<WIM>

<TOTALBYTES>2956137226</TOTALBYTES>

<IMAGE INDEX="1">

7Customizer can`t mount Win 7 Version with only one Image in the install.wim.

And your Enterprise Edition had only this one Install.wim Image.

beatmaster

Is there any solution for that problem?

Just for an test!

I've tried successfully to install "Windows 7 Enterprise x86" 90 days evaluate (en-us version) with 7Customizre_0.4.4! :whistle:

I've expand the iso file and put this on the target partition and give the name "WinE" for the folder for all the files. I skip the key with unattended answer file.

I've made with Windows XP SP3, as you can see (same architecture x86).

Here is the log file:

=== 7Customizer Started===

7Customizer verion: 0.4.4

7Customizer path: C:\7Customizer_0.4.4\7Customizer.exe

Current directory: C:\7Customizer_0.4.4

OS: Microsoft Windows NT 5.1.2600 Service Pack 3

OS architecture: x86

Work folder found: True

Mount folder found: True

Themes folder found: True

Languages folder found: True

Extract utility found: True

Configuration file found: True

bootorder.txt file found: True

Boot sector file found: True

Elevated: True

Loading Language: Begin

Loading Language: Done

Getting drive info

Free space: 23,5762405395508 GB

Getting drive info: Done

Saved Imagex path: C:\Program Files\Windows AIK\Tools\x86\imagex.exe

Saved DISM path: C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe

Saved odcdimg path: C:\Program Files\Windows AIK\Tools\x86\oscdimg.exe

Windows source path selected

Sources folder found

install.wim found

install.wim size: 1992 MB

Added: "C:\Program Files\Windows AIK\Tools\x86\imagex.exe">work\testimagex.txt

Testing imagex

Imagex result begin:

Imagex result file created.

ImageX Tool for Windows

Copyright © Microsoft Corp. All rights reserved.

Version: 6.1.7600.16385

Imagex result end.

Added: "C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe">work\testdism.txt

Testing dism

dism result begin:

Deployment Image Servicing and Management tool

Version: 6.1.7600.16385

dism result end.

added: "C:\Program Files\Windows AIK\Tools\x86\imagex.exe" /XML /info "C:\WinE\sources\install.wim">work\imagesinfo.xml

Starting imagex

Imagex created imagesinfo.xml Successfully

Reading images information from imagesinfo.xml

First 5 lines of imagesinfo.xml

<WIM>

<TOTALBYTES>2089538881</TOTALBYTES>

<IMAGE INDEX="1">

<DIRCOUNT>9362</DIRCOUNT>

<FILECOUNT>47381</FILECOUNT>

Number of Available Images: 1

Reading image indiceis

Reading image displaynames

Reading image names

Reading image architectures

Reading image edition IDs - using EDITIONID

Available Images: Begin

Windows 7 Enterprise

Available Images: End

Reading info finished

Start button pressed

added: "C:\Program Files\Windows AIK\Tools\x86\imagex.exe" /XML /info "C:\WinE\sources\install.wim" 1 >work\imagesinfo.xml

Starting ImageX

Imagex created imagesinfo.xml Successfully

Reading selected image information from imagesinfo.xml

First 5 lines of imagesinfo.xml

<IMAGE INDEX="1">

<DIRCOUNT>9362</DIRCOUNT>

<FILECOUNT>47381</FILECOUNT>

<TOTALBYTES>8315778934</TOTALBYTES>

<CREATIONTIME>

Installed Language: Begin

en-US

Installed Language: End

Image default language: en-US

Image Architecture: x86

Image Edition:Enterprise

Selected Image name: Windows 7 ENTERPRISE

Finished Reading selected image information

Tweaks Enabled

Preparing instructions for registry editing

added reg.exe load HKLM\7user "work\mount\Users\Default\NTUSER.DAT"

added reg.exe load HKLM\7soft "work\mount\Windows\System32\config\SOFTWARE"

added reg.exe load HKLM\7system "work\mount\Windows\System32\config\SYSTEM"

added reg.exe import "work\reg.reg"

added reg.exe unload HKLM\7user

added reg.exe unload HKLM\7soft

added reg.exe unload HKLM\7system

Finished preparing instructions for registry editing

Apply button pressed

Debug Mode: False

Creating Autounattend.xml

Finished Autounattend.xml

Prepearing instructions to execute

Added: "C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /mount-wim /wimfile:"C:\WinE\sources\install.wim" /index:1 /mountdir:"work\mount"

Added: "C:\Program Files\Windows AIK\Tools\x86\Servicing\Dism.exe" /unmount-wim /mountdir:"work\mount" /commit

Preparing tweaks file

Finished preparing tweaks file

Starting

Finished Execution

Done. Exiting 7Customizer

Edited by myselfidem
Link to comment
Share on other sites

Hi there!

First - big congrats for the developer! I used to use nlite, then vlite and when I've heard that there is no such tool for win7 I was highly disappointed. Then I found this tool and I'm very happy that someone took the hard of continuing the idea of easy customizing system installation CD.

The question I have now is about next release - when it's going to be? I'm going to install windows 7 x64 for the first time (I used to have only 32-bit systems before) and I want to customize it as much as possible and I've seen on the first post that components removal part in on the way. So I wonder if to wait couple of more days or to give a try to v 0.4.4 which was released quite long time ago.

And... I almost forgot. Is there a possibility in the customization process that my account will be Administrator account by default? I'm tired of r-click and "run as administrator" so I wonder if there is a way to always be the administrator :)

Regards!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...