Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Raoul90

Windows 7 AnswerFile

Recommended Posts

Hello,

I got a good working answerfile now. :P

autounattend.xml:

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>nl-NL</UILanguage>
<WillShowUI>OnError</WillShowUI>
</SetupUILanguage>
<InputLocale>en-US</InputLocale>
<SystemLocale>nl-NL</SystemLocale>
<UILanguage>nl-NL</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>nl-NL</UserLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ComplianceCheck>
<DisplayReport>OnError</DisplayReport>
</ComplianceCheck>
<DiskConfiguration>
<WillShowUI>Always</WillShowUI>
</DiskConfiguration>
<Display>
<ColorDepth>32</ColorDepth>
<HorizontalResolution>1024</HorizontalResolution>
<RefreshRate>60</RefreshRate>
<VerticalResolution>768</VerticalResolution>
</Display>
<DynamicUpdate>
<Enable>true</Enable>
</DynamicUpdate>
<UpgradeData>
<WillShowUI>Never</WillShowUI>
</UpgradeData>
<EnableFirewall>true</EnableFirewall>
<EnableNetwork>true</EnableNetwork>
<UserData>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass="offlineServicing">
<component name="Microsoft-Windows-LUA-Settings" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<EnableLUA>false</EnableLUA>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Identification>
<JoinWorkgroup>MSHOME</JoinWorkgroup>
</Identification>
</component>
<component name="Security-Malware-Windows-Defender" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DisableAntiSpyware>true</DisableAntiSpyware>
</component>
<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>en-US</InputLocale>
<SystemLocale>nl-NL</SystemLocale>
<UILanguage>nl-NL</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>nl-NL</UserLocale>
</component>
<component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SearchScopes>
<Scope wcm:action="add">
<ScopeUrl>http://www.google.nl/search?hl=en&q={searchTerms}&meta=</ScopeUrl>
<ScopeDefault>true</ScopeDefault>
<ScopeKey>SearchProvider1</ScopeKey>
<SuggestionsURL>http://clients5.google.com/complete/search?hl={language}&q={searchTerms}&client=ie8&inputencoding={inputEncoding}&outputencoding={outputEncoding}</SuggestionsURL>
<ScopeDisplayName>Google</ScopeDisplayName>
<FaviconURL>http://www.google.nl/favicon.ico</FaviconURL>
</Scope>
</SearchScopes>
<BlockPopups>yes</BlockPopups>
<DisableAccelerators>true</DisableAccelerators>
<DisableDataExecutionPrevention>true</DisableDataExecutionPrevention>
<DisableDevTools>false</DisableDevTools>
<DisableFirstRunWizard>true</DisableFirstRunWizard>
<DisableOOBAccelerators>true</DisableOOBAccelerators>
<FilterLevel>Low</FilterLevel>
<Help_Page>http://www.google.nl</Help_Page>
<Home_Page>http://www.nu.nl</Home_Page>
<NoDial>true</NoDial>
<PlaySound>true</PlaySound>
<ShowInformationBar>true</ShowInformationBar>
<SuggestedSitesEnabled>false</SuggestedSitesEnabled>
</component>
<component name="Microsoft-Windows-SQMApi" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<CEIPEnabled>0</CEIPEnabled>
</component>
<component name="Microsoft-Windows-SystemRestore-Main" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DisableSR>0</DisableSR>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Display>
<ColorDepth>32</ColorDepth>
<DPI>96</DPI>
<HorizontalResolution>1024</HorizontalResolution>
<RefreshRate>60</RefreshRate>
<VerticalResolution>768</VerticalResolution>
</Display>
<BluetoothTaskbarIconEnabled>false</BluetoothTaskbarIconEnabled>
<DoNotCleanTaskBar>true</DoNotCleanTaskBar>
<DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
<TimeZone>W. Europe Standard Time</TimeZone>
<ShowWindowsLive>true</ShowWindowsLive>
</component>
<component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipAutoActivation>true</SkipAutoActivation>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Display>
<ColorDepth>32</ColorDepth>
<DPI>96</DPI>
<HorizontalResolution>1024</HorizontalResolution>
<RefreshRate>60</RefreshRate>
<VerticalResolution>768</VerticalResolution>
</Display>
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<CommandLine>%SystemRoot%\Setup\Scripts\RunOnce.cmd</CommandLine>
<Description>RunOnce</Description>
<Order>1</Order>
<RequiresUserInput>false</RequiresUserInput>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<Order>2</Order>
<RequiresUserInput>false</RequiresUserInput>
<Description>Eset Smart Security 4</Description>
<CommandLine>%systemdrive%\Install\ESS-BE-NL-4.0.437-X86\Install.cmd</CommandLine>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<Order>3</Order>
<RequiresUserInput>false</RequiresUserInput>
<Description>Reboot and Cleaning Script</Description>
<CommandLine>%SystemRoot%\Setup\Scripts\Reboot.cmd</CommandLine>
</SynchronousCommand>
</FirstLogonCommands>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
<ProtectYourPC>1</ProtectYourPC>
<NetworkLocation>Home</NetworkLocation>
</OOBE>
<VisualEffects>
<FontSmoothing>Standard</FontSmoothing>
</VisualEffects>
<BluetoothTaskbarIconEnabled>false</BluetoothTaskbarIconEnabled>
<DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
<DoNotCleanTaskBar>true</DoNotCleanTaskBar>
<ShowWindowsLive>true</ShowWindowsLive>
<TimeZone>W. Europe Standard Time</TimeZone>
</component>
<component name="Microsoft-Windows-Sidebar" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Gadget1>%PROGRAMFILES%\Windows Sidebar\Gadgets\Weather.Gadget</Gadget1>
<Gadget2>%PROGRAMFILES%\Windows Sidebar\Gadgets\Clock.Gadget</Gadget2>
<Gadget3>%PROGRAMFILES%\Windows Sidebar\Gadgets\Calendar.Gadget</Gadget3>
<Gadget4>%PROGRAMFILES%\Windows Sidebar\Gadgets\Radio538.Gadget</Gadget4>
</component>
</settings>
<cpi:offlineImage cpi:source="wim:d:/windows%207%20unattended/win7-ua/sources/install.wim#Windows 7 ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

edit: Removed first post with crap, added my worknig answerfile. :D

Edited by Raoul90

Share this post


Link to post
Share on other sites

Its not that, mnlk2, I use that and its OK.

Try remove the " <RegisteredOwner /> " as the tags are not correct.

Also, use WSIM from the WAIK and click verify settings to ensure all of your syntax's are correct.

Share this post


Link to post
Share on other sites
Its not that, mnlk2, I use that and its OK.

Try remove the " <RegisteredOwner /> " as the tags are not correct.

Also, use WSIM from the WAIK and click verify settings to ensure all of your syntax's are correct.

Hmm, I didnt put in any RegisteredOwner or RegisteredOrganization..

2ljp92r.png

See, I dont want to create a user, So who is the AutoBVT guy? :P

edit: Oh if I let it like this, there is no entry of user/organization in answerfile.

And I am using WSIM allready to check the file.

But I am searching for an answerfile that works, So I compare it with mine that doesnt work. :P

edit:

We were now talking about the 2nd one, but I would like to know what part of the "Specialize" is wrong in the first. :)

Edited by Raoul90

Share this post


Link to post
Share on other sites

Could somebody maybe tell me where to paste that unattend.xml file?

I've tryed it to past it at the front but then i get a list what version i want to install (basic ,...., ultimated) and i only have the ultimated.

I'm trying it for the first time with my ultimated version, i already have the dutch language intregaded en a lot of program's sutch as office 2007 , winzip12, and many more, but now i want to windows 7 installation also automatic sutch as the first poster has.

Can anybody help me?

Sorry for my bad english i'm from holland.

Share this post


Link to post
Share on other sites

Rename the file to autounattend.xml and put it in the root of your working folder (so where you see boot, efi, sources etc etc).

Share this post


Link to post
Share on other sites

In the begin setup you have a screen where you can choose what version of windows 7 you want to start, is there a posibility to skip that because i only have winodws 7 ultimated, also the licence acception may also be left out?

Share this post


Link to post
Share on other sites
In the begin setup you have a screen where you can choose what version of windows 7 you want to start, is there a posibility to skip that because i only have winodws 7 ultimated, also the licence acception may also be left out?

In the first post you can see about Accept EULA.

For version Ultimate:

- Start WSIM.

- Create/Edit answerfile.

- Component name="Microsoft-Windows-Setup"

- Settings pass="windowsPE"

- ImageInstall -> OSImage -> InstallFrom -> MetaData "Add":

Key: /IMAGE/INDEX

Value: 1

But I am not sure.

Share this post


Link to post
Share on other sites

At this moment it works what you wrote.

Another litle question.

I see in your autounattend.xml that you refer to the next:

7 oobeSystem - x86_Microsoft-Windows-Sidebar_neutral 
Gadget4 - %PROGRAMFILES%\Windows Sidebar\Gadgets\Radio538.Gadget

How dit you manage to add this in your image?

Did you put that in the install.wim file, because its not a standard gadget in windows?

Also i get a error in the time as result that the installtion is shutdown.

I think its in the name

<TimeZone>W. Europe Standard Time</TimeZone>

Edited by yanki

Share this post


Link to post
Share on other sites

Just go to your source.

Go inside "sources" folder.

Create "$OEM$" folder.

Create "$Progs" folder inside $OEM$ folder.

Create "Windows Sidebar" folder in "$Progs$" folder.

Create "Gadgets" folder in "Windows Sidebar" folder.

Create "Radio538.Gadget" folder in "Gadgets" folder.

Download the Radio538 gadget here:

http://gallery.live.com/liveItemDetail.asp...p;bt=1&pl=1

Extract the .gadget file with WinRAR and extract all the files to Radio538.Gadget folder.

x5xmdu.png

Share this post


Link to post
Share on other sites

Thx , for the gadgets but still i have some problems in your script.

While windows is installing i get suddenly a error about the language file that's not been found in the offline file.

I will try to look further into it.

At this moment my dvd is almost ready , only the some little problems whith the autounattend.xml.

At this moment i have the dutch language intregrated, so windows works 100% dutch or 100% english if you make in the beginning the choice.

At the end of windows installation will install office 2007 with all updates, new winzip 12, new total commander and many more.

Just the autounattend.xml file and everything is for me 100% ready

Share this post


Link to post
Share on other sites
For version Ultimate:

- Start WSIM.

- Create/Edit answerfile.

- Component name="Microsoft-Windows-Setup"

- Settings pass="windowsPE"

- ImageInstall -> OSImage -> InstallFrom -> MetaData "Add":

Key: /IMAGE/INDEX

Value: 1

But I am not sure.

A little correction on this.

If you have the Ultimated version then the Value must be 5.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×