Jump to content

NVIDIA Forceware changed, integration fails (XP x64 Edition)


meowing
 Share

Recommended Posts

Ever since version 185.85 WHQL, we can no longer integrate the drivers from nVidia using nLite. The install stops with a Found New Hardware dialog, and it causes the nlite commands (thus entire installation of Windows) to not be executed properly any further.

I tried editing NV4_DISP.INF, but that makes the drivers no longer WHQL, no longer certified, so you're pretty much stuck.

I'm surprised there aren't many others posting about this, not even in the nVidia forums.

Sincerely hoping someone with a bit more knowledge knows how to best solve this.

Edited by meowing
Link to comment
Share on other sites


Yes I've seen many posts and threads about it, but not one true solution, which is why I posted this. Either you have to strip the pack clean of Physx and the controlpanel, or you end up changing inf files manually in ways that are obscure at best.

I'd rather have the entire install as is, as it used to be.

Edited by meowing
Link to comment
Share on other sites

  • 3 weeks later...

We must find a solution ... and i don't think nvidia will care about our demands.

Maybe it's worth the try.

Edited by xyu
Link to comment
Share on other sites

A member (beatmaster) of "German-Winlite" builds an addons, which installs the driver.

Two versions available: v1 installs by RunOnceEx, v2 installs at T-13

Link (german forum): http://www.german-winlite.de/wbb/index.php...25056#post25056

This is all for x86 (32 bit) XP. We're looking for the XP x64 version of the drivers, including control panel.
Link to comment
Share on other sites

We're looking for the XP x64 version of the drivers, including control panel.

You didn`t tell us - or maybe I just haven`t seen this?

Correct, I now see it isn't mentioned anywhere in this thread.

http://filehippo.com/download_nvidia_forceware_xp_64/

is the one I need for nlite.

I can of course check what was done in the addon and copy that for XP x64. I'll try and reverse engineer.

Link to comment
Share on other sites

I rebuild the RunOnce-Addon to x64-version.

I wasn`t able to test it (no XP_x64), but it should work.

DOWNLOAD

Thread @ German-WinLite (german): http://german-winlite.de/wbb/index.php?pag...29267#post29267

Great, what did you do to accomplish this for the x64 version? (Looking for one with 190.62) If you want, I can maintain the x64 version for you. (I can subscribe to the German forum as well..)
Link to comment
Share on other sites

Great, what did you do to accomplish this for the x64 version? (Looking for one with 190.62) If you want, I can maintain the x64 version for you. (I can subscribe to the German forum as well..)

As I mentioned, I got no XP_x64, so I don`t want to update this Addon,

because I can`t test it - I hope you don`t mind.

But if you unpack the Addon, you`ll see how to do it, just replace the files

and update filenames in "entries.ini".

Link to comment
Share on other sites

  • 2 weeks later...

Good, very good news, from German-WinLite.de !

In NV4_DISP.INF,

under [DestinationDirs],

just change that:

nv_controlpanel_copyfiles = 01

to that:

nv_controlpanel_copyfiles = 11

It's amazing but that's it. I've just tried it and it worked with the good old method of pointing the *.inf folder in the winnt.sif.

So many thanks for beatmaster and his post http://german-winlite.de/wbb/index.php?pag...29267#post29267

Happy unattending !

Edited by xyu
Link to comment
Share on other sites

  • 1 month later...
Good, very good news, from German-WinLite.de !

In NV4_DISP.INF,

under [DestinationDirs],

just change that:

nv_controlpanel_copyfiles = 01

to that:

nv_controlpanel_copyfiles = 11

It's amazing but that's it. I've just tried it and it worked with the good old method of pointing the *.inf folder in the winnt.sif.

So many thanks for beatmaster and his post http://german-winlite.de/wbb/index.php?pag...29267#post29267

What does this do? I mean, you say something is good news, but it's not clear what is. Does this work for XP x64 as well?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...