Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Martin H

VMware Workstation silent install.

Recommended Posts

The MSI installer supports a switch for disabling the installation of certain components, like the VMware authorization service, NAT and DHCP i.e. 'REMOVE=Authd,NAT,DHCP'.

However, when doing that, then because of not installing the VMware authorization service, then an error is shown whenever one is trying to access a VM, but oddly enough, if not using the 'REMOVE=' switch to remove the VMware authorization service, but instead just closing the service afterwards and disabling it from starting up automatically, then one can access VMs without any problems...

Also, I personally don't need either DHCP or NAT to access the network, so i also close and disable them from starting automatically, after the install has done...

Here's an INF which will install VMware Workstation silently and close the three default services and disable them from starting up automatically(remember to change the serial):

[Version]
Signature=$Windows NT$

[DefaultInstall]
RunPreSetupCommands=runpresetupcommands
RunPostSetupCommands=runpostsetupcommands:1
AddReg=addreg

[runpresetupcommands]
"msiexec /i ""VMware Workstation.msi"" SERIALNUMBER=XXXXX-XXXXX-XXXXX-XXXXX /qn"

[runpostsetupcommands]
net stop VMAuthdService
net stop VMnetDHCP
"net stop ""VMware NAT Service"""

[addreg]
HKLM,"SYSTEM\CurrentControlSet\Services\VMAuthdService","Start",0x10001,4
HKLM,"SYSTEM\CurrentControlSet\Services\VMnetDHCP","Start",0x10001,4
HKLM,"SYSTEM\CurrentControlSet\Services\VMware NAT Service","Start",0x10001,4

You cannot install this INF with "rightclick and install", as it's an Advanced INF, so use this command instead:

rundll32 advpack.dll,LaunchINFSection install.inf

Also, the above INF is for installing an admin install of VMware Workstation, which is done by running e.g.:

setup.exe /a /s /v"/qn TARGETDIR=D:\Temp\VMWare"

I personally use VMware Workstation v5.0, but this procedure also works fine with v6.x...

Edited by Martin H

Share this post


Link to post
Share on other sites

Yeah, atleast it did with v6.0.1 b55017(i used that as it was the latest lite version from RyanVMs forum).

I recall that there where another service added, which i also incorporated into the INF, but i'm affraid i don't have it anymore, as i've changed over to using VirtualBox now instead...

Anyway, you can easilly add it yourself i.e. just run 'WIN+R > services.msc', double-click on the other service and note the name at the top and then duplicate it to the addreg and runpostsetupcommands sections following the used syntax...

Share this post


Link to post
Share on other sites

Hi, this is what i do for the latest version

extract the package :

VMware-workstation-full-7.0.1.exe /extract "<Folder Name>"

Then install via MSI :

Msiexec /i "vmware workstation.msi" /qn REBOOT=REALLYSUPPRESS ADDLOCAL=ALL DESKTOPSHORTCUT=1 SERIALNUMBER=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×