Jump to content

Win Integrator Alpha


Intelmaster
 Share

Recommended Posts

@aviv

if you remove the languages file from e.g Media Center package and remove also the "real" media center Package you will get an DISM Exitcode..

it is the best to ignore languages files at the moment and only removed the packages under the ultimate-Package,, Then you will get no Error.

StefanRTR works on a version that works after an dism exitcode appears.

I hope Stefan could complete Alpha 4 in the next week

duno i saw the rest of the packages remove in the bottom of the app ?

i reopen the dvd folder again

the removed packages are not appear there

hmmm that's mysterious i think

Please ask Stefan RTR on friday. Here in Germany it is 22:40 and some peoples wants to sleep e.g stefanRTR ^^ :D :D :D

Link to comment
Share on other sites


im doing test now on win7 7600 32bit

more info soon:

edit:

i see that ms windows ultimate edition is appear [ on windows server 2008 r2 this wasnt appear just the lang packages was appear]

not only the lang pack

edit2:

BEFORE

Image Index: 5

-------------------

Name: Windows 7 ULTIMATE

Description: Windows 7 ULTIMATE

Flags: Ultimate

Files: 47447

Folders: 9384

Expanded Size: 8078 MB

AFTER Wi

Image Index: 5

-------------------

Name: Windows 7 ULTIMATE

Description: Windows 7 ULTIMATE

Flags: Ultimate

Files: 40691

Folders: 8785

Expanded Size: 6893 MB

edit3

AFTER VLITE

Image Index: 2

-------------------

Name: Windows 7 ULTIMATE

Description: Windows 7 ULTIMATE

Flags: Ultimate

Files: 33437

Folders: 7494

Expanded Size: 4098 MB

AFTER remove files with whereisit

Image Index: 3

-------------------

Name: Windows 7 ULTIMATE

Description: Windows 7 ULTIMATE

Flags: Ultimate

Files: 27772

Folders: 6502

Expanded Size: 2648 MB

/list

1. folders that have *.inf* in WinSxS folder [700MB]

2. System32\recovery [140MB]

3. users\public [n/a]

4. ati avm drivers System32\DriverStore\FileRepository\ [30MB]

5. winsxs\x86_microsoft-windows-

b..core-fonts-jpn-boot...

e..devices....

ehome-font...

music-samples...

o..c-style....

o...clamedia....

o..ediadisc...

o.iadisk...

opticalmediadisc-api...

s...boxgames..

sonic.server

video.sample

winscr....

xpsreachviewer.... [325MB]

win732bit.xml

good.ini

Edited by aviv00
Link to comment
Share on other sites

@ stefanRTR

i see that only win7 is support

i check server r2 bulid 7100 just the lang packages was appear

[edit: only on web edition the rest is fine]

and in server 2008 web remove tab is not exist

dism cant work on older then win7 ?

Edited by aviv00
Link to comment
Share on other sites

i got the error DISM Exitcode [ -2146498555 ]

many times not just web iis package randomly

i think its not relevt to the app

its internal bug in .NET

i saw it even i use dism alone with/o the app

i guess the best way to work with that is to bypass that package

save the image and continue removing the packages

which clear the memory and start over till the bug will appear again

btw in 32bit [ windows 7 ]

not error at all!

its must be internal bug

Edited by aviv00
Link to comment
Share on other sites

this app uses .net 4.0 for multithreading and parallelism.

Multi threading has been around since .NET 2.0 using the Background Worker object and Task Parallel Library is new to the .NET 4.0 framework but is something that doesn't have to be used but i could be wrong on this one. This program on the other hand is GREAT just having some issues with removing packages but the wim image rebuild and make a bootable ISO features work great. I have attached 2 logs of the exceptions that are being thrown and my preset as well. I am wondering what language this program is written in VB or C#? Hope these logs and preset help :) Will keep testing!!!

Edited by liquid0624
Link to comment
Share on other sites

Working gr8 on win7 32bit thx

i did lang integration and remove packets

just the time is long that's all

hope ms will improve net4

hm, each time i try to get rid of a package in 2008 r2 ent x64 im getting the dism error *8555.

doesnt matter if i i use winintegrator on a x86 or x64 install.

Link to comment
Share on other sites

nope i meant doing removing packages from 32bit os

64bit is the problem any os doing problem

the host is not matter

EDIT:

maybe with the Wim_install_Tweak.exe applied before running it will solve it ?

Edited by aviv00
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...