Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Octopuss

administrative shares

Recommended Posts

Anyone knows why I can't connect to this PC from a machine with XP using administrative shares, ie. \\<name>\d$ ?

It works in the other direction.... but impossible to connect here. I don't like to set up any extra sharing.

Share this post


Link to post
Share on other sites

check these in GPedit:

Computer Configuration->Administrative Templates->Default Shares->

Default Server Admin Shares Enabled

Default Workstation Admin Shares Enabled

there are registry keys too but i dont recall them

Share this post


Link to post
Share on other sites

so am I to understand this is intentionally disabled? What's weird, in computer management - shared folders I can clearly see C$ and D$.

Share this post


Link to post
Share on other sites
check these in GPedit:

Computer Configuration->Administrative Templates->Default Shares->

Default Server Admin Shares Enabled

Default Workstation Admin Shares Enabled

there are registry keys too but i dont recall them

Can't find that, seems like you missed one category after Administrative templates :)

edit: ahh it's actually in user configuration - but there are two options which don't look too much like what you described. unfortunately I have czech MUI installed so...

Edited by TheWalrus

Share this post


Link to post
Share on other sites

In my experience its inconsistent. its enalbed on some PCs and disabled on others. I have a GPo that enables them (and starts necessary services)

Computer Configuration->Windows Settings->Security Settings->System Services->

Net Logon (Startup Mode: Automatic)

Remote Registry (Startup Mode: Automatic)

Windows Firewall/Internet Connection Sharing (ICS) (Startup Mode: Disabled)

Computer Configuration->Administrative Templates->Default Shares->

Default Server Admin Shares Enabled

Default Workstation Admin Shares Enabled

edit: thata should be in the computer branch as well. (im just looking in my active directory GPo so it may be different on 7 )

Share this post


Link to post
Share on other sites

gonna try this:

Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

If the LocalAccountTokenFilterPolicy registry entry does not exist, follow these steps: On the Edit menu, point to New, and then click DWORD Value.

Type LocalAccountTokenFilterPolicy, and then press ENTER.

On the Edit menu, point to New, and then click DWORD Value.

Type LocalAccountTokenFilterPolicy, and then press ENTER.

Right-click LocalAccountTokenFilterPolicy, and then click Modify.

In the Value data box, type 1, and then click OK.

Share this post


Link to post
Share on other sites

ok this doesn't work

gah

and the GP settings are a mess :)

someone somewhere suggested disabling the homegroup, but I am not sure how to do that - as far as I can tell I didn't set it at all

Share this post


Link to post
Share on other sites

well try not disabling homegroups but change the advanced options to use user accounts and passwords to connect to other computers rather than allowing homegroups to manage connections.

that was the problem for me for shared folders (not admin shares); but that may work.

Share this post


Link to post
Share on other sites

I believe I got that. It's in advanced sharing options, right? I disabled password protected sharing, disabled something called sharing of public folder. And of course set it to use user accounts and passwords.

Share this post


Link to post
Share on other sites

so thats what those folders are, i always wondered. linux shows them but windows doesnt.

Share this post


Link to post
Share on other sites

An Antivirus program may block network. I used Avast but i had similar problem as You. Now I use NOD32 and network works properly.

Share this post


Link to post
Share on other sites

What i found fixed the network in Win 7 was makeing sure the eithernet card had a gateway and default dns, if not win7 auto sets the network to public and you wont get the shares.

Hammey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×