Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Rhor

Windows SIM and User Autologon

Recommended Posts

Greetings.

I'm learning how to use Windows System Image Manager to make and unattended installation routine with Windows 7 and so far I've made some progress.

I'm the only one using my PC, so my idea was to install Windows 7 unattended with my User Account already created on Windows SIM but with no password. Now when I test my current configuration, the screen attached appears almost at the end of the installation process (OOBE) telling me that I need to change the password, then another screen appears where Im supposed to write the new password, but I just press Next, and the third screen tells me that the password was succesfully changed and then OOBE continues as normal.

How can I get rid of those screens when I want to use my account without a password?.

Thank you in advance for any help.

post-90189-1245631417_thumb.jpg

Share this post


Link to post
Share on other sites

I'm sorry for that, I should've known that it was needed.

The manual says that I should select "Write Empty String" in the space left for "Value" on "Microsoft-Windows-Shell-Setup/User Accounts/Administrator Password", but everytime I try to use it on a test, the space gets filled with a random string like "QQBkAG0AaQBuAGkAcwB0AHIAYQB0AG8AcgBQAGEAcwBzAHcAbwByAGQA".

Thank you.

Autounattend.xml

Share this post


Link to post
Share on other sites

A few things...

Try:

- <UserAccounts>
- <LocalAccounts>
- <LocalAccount wcm:action="add">
<Description>Rhor's Account</Description>
<DisplayName>Jorge Rhor</DisplayName>
<Group>Administrators</Group>
<Name>Jorge Rhor</Name>
</LocalAccount>
</LocalAccounts>
- <AdministratorPassword>
<Value></Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>

Or try removing the AdministratorPassword section altogether.

Even though I believe the following are deprecated in W7, they currently work for me in shell setup (paste it under your own hideeulapage):

            <OOBE>
<SkipUserOOBE>true</SkipUserOOBE>
<SkipMachineOOBE>true</SkipMachineOOBE>
</OOBE>

There is also this:

- <UserAccounts>
- <LocalAccounts>
- <LocalAccount wcm:action="add">
<Description>Rhor's Account</Description>
<DisplayName>Jorge Rhor</DisplayName>
<Group>Administrators</Group>
<Name>Jorge Rhor</Name>
</LocalAccount>
</LocalAccounts>
- <AdministratorPassword>
<Value>password?</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
</UserAccounts>

<AutoLogon>
<Password>
<Value>password?</Value>
<PlainText>true</PlainText>
</Password>
<Enabled>true</Enabled>
<Username>Administrator</Username>
</AutoLogon>

AND FINALLY:

To configure a blank administrator password for Windows® 7, write an empty string in Windows® System Image Manager (Windows SIM), by right-clicking the Value setting, and then selecting Write Empty String. The built-in administrator account will be enabled with a blank password.

You may need to set the Autologon for this last part to work though.

Edited by razormoon

Share this post


Link to post
Share on other sites

Thank you very much, I will try the first three ideas you gave me, the last one I tried it already and thats when I dont get the empty string, but some random value.

I will let you know how it went, Im not good at editing XML.

Edited by Rhor

Share this post


Link to post
Share on other sites

It didnt work at all unfortunately.

As a last favor Mr. razormoon, if you are doing the same as me, and you can get your Autologon to work correctly without a password, would you send me your autounattend.xml file so I can use it as a template?

Thank you.

EDIT:

I probably misunderstood what that window asking me for a password really means.

I took that window as a request for me to provide a password for MY own personal account. But what it really meant is for me to provide a password for the BUILT IN Administrator account that comes disabled by default. So if I enter a password on WAIK, it probably will not nag me on the installation process later on, and my own account will remain password-free.

Testing right now.

EDIT 2:

Of course, my logic failed me once again. It didnt work.

Edited by Rhor

Share this post


Link to post
Share on other sites

Did you remove the AdministratorPassword section completely? Even though you are in Group Administrators...that doesn't mean that it is the built in administrator account.

According to your xml above:

Remove everything in AdministratorPassword including the section itself.

For Autologon, DO NOT USE THE USERNAME "ADMINISTRATOR" if you want to use autologon (you don't need to as the login counts down to zero and you have to login anyway after that, with or without password). Use the one you are using...Jorge Rhor for autologon. "ADMINISTRATOR" account requires password...no way around that one (that I'm aware of). However, password not required for all other accounts. As a matter of fact, I would probably remove autologon section also since this is useful only when installing 3rd party programs in unattended mode that need reboot.

As soon as you enter Username Administrator in Autologon, that tells Windows to activate the built-in administrator account.

Edited by razormoon

Share this post


Link to post
Share on other sites

Thank you for the response.

I finally was able to do it. I erased all the traces of administrator account and passwords and I added a white string on the password field on Local Accounts.

			<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Description>Rhor's Account</Description>
<DisplayName>Jorge Rhor</DisplayName>
<Group>Administrators</Group>
<Name>Jorge Rhor</Name>
<Password>
<Value>UABhAHMAcwB3AG8AcgBkAA==</Value> <--- Empty String
<PlainText>false</PlainText>
</Password>
</LocalAccount>
</LocalAccounts>
</UserAccounts>

Again, thank you for the help Mr. Razormoon.

Edited by Rhor

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...