Jump to content

Help Installing Applications from Network Share?


Recommended Posts

Does anyone have a working setup to install applications from a network share? I have a windows home server where I have my latest app installs and I was hoping to install them from the specialize or oobe step but haven't had much success. I'm running from a windows home server as a source (no guest account) so that may be the problem. I guess ultimately I would like to call a single script on the network share that I could update to call all of the installs I wanted to run.

I know that application install questions are a dime a dozen... does anyone have the energy (and know-how!) to put together a real guide to be stickied? Its still not clear to me if I should be trying to use sequential commands or put everything in a separate command file. I think this would really help a lot of us struggling to piece together this information.

Thanks for the help.

Link to comment
Share on other sites


Not sure if this is exactly what you want, but it's what I do. I don't have Home Server though, just running Windows Server 2003 on one of my computers. Has a bunch of network shares which is where I pull the programs from.

The following is in my Unattended.xml:

<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<CommandLine>%systemdrive%\final-x64.bat</CommandLine>
<Order>1</Order>
</SynchronousCommand>
</FirstLogonCommands>
</component>
</settings>

Now I mount my WIM, and copy that batch files to the root of the mount folder which is equivalent to the root of the system drive when installed. The batch file contains something like this:

NET USE W: \\Server\Folder Password /USER:Username

echo Installing Firefox
"W:\Firefox.exe"
CLS
echo Installing WinRAR
"W:\wrar.exe" -s

NET USE /DELETE W:

Obviously change the NET USE command accordingly to your network and account information.

In your case, you might want to make that batch file just point to a batch file on the server and run from there. I also have UAC disabled via vLite. It might interfere with things, though not sure since I never run UAC.

Hopefully that gives you a starting point. Maybe not the most efficient way, but it works fine for me.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...