Jump to content

Ashampoo Burning Studio 9


Recommended Posts


Just add pskill for default browser command or you will get the browser opening

so mine is like this so if I install Browser in a different order, they are covered:

ashampoo_burning_studio_8_804_sm.exe /VERYSILENT /SUPPRESSMSGBOXES /NORESTART /SP-
pskill firefox.exe
pskill IEXPLORE.EXE
pskill opera.exe
pskill ashampoo_burning_studio_8_804_sm.exe
pskill burningstudio.exe

Edited by steviewonder
Link to post
Share on other sites

Oh, does v9 still open a browser? If that's the case, you could also use Windows native taskkill command.

TASKKILL /F /IM firefox.exe

TASKKILL /F /IM iexplore.exe

etc. ;)

Link to post
Share on other sites
  • 3 months later...

Here is a Working Script for version 9.20. I just modified the one for version 8 to work for version 9.20.

; Serial number

$SN = "xxxxxx-xxxxxx-xxxxxx"

Please replace the "x"'s in the below script with your SN.

Tested: working in VM.

Opt("TrayIconDebug", 1)

; Executable file name
$EXECUTABLE = "ashampooburningstudio9.20sm.exe"
; Serial number
$SN = "xxxxxx-xxxxxx-xxxxxx"

$PreviousInstallation = RegRead("HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\Ashampoo Burning Studio 8_is1", "InstallLocation")
If FileExists($PreviousInstallation & "\burningstudio.exe") Then
MsgBox(0x40010, @ScriptName, "Please uninstall previous version of Ashampoo Burning Studio before using this script", 4)
Exit
EndIf

; Disable the default internet browser (to prevent Ashampoo Burning Studio to open it)
$DefBrowser = RegRead("HKCR\HTTP\shell\open\command\", "")
RegDelete("HKCR\HTTP\shell\open\command\", "")

; Run the installer
RunWait($EXECUTABLE & " /sp- /verysilent /norestart")

; Close Ashampoo Burning Studio process
ProcessWait("burningstudio9.exe")
$PID = ProcessExists("burningstudio9.exe")
If $PID Then
ProcessClose($PID)
EndIf

Sleep(1000)

; Kill Internet Explorer process if was started
$PID = ProcessExists("IEXPLORE.EXE")
If $PID Then
ProcessClose($PID)
EndIf

; Settings
RegWrite("HKLM\Software\Ashampoo\Ashampoo Burning Studio 9", "RegKey", "REG_SZ", $SN)
RegWrite("HKLM\Software\Ashampoo\Ashampoo Burning Studio 9", "InfoChannelsEnabled", "REG_DWORD", "0")
RegWrite("HKLM\Software\Ashampoo\Ashampoo Burning Studio 9\ash_inet", "Enabled", "REG_DWORD", "0")

; Restore the default internet browser
RegWrite("HKCR\HTTP\shell\open\command\", "", "REG_SZ", $DefBrowser)

Link to post
Share on other sites

@simpleman

Try this script:

#cs ----------------------------------------------------------------------------

AutoIt Version: 3.3.0.0
Author: myName

Ashampoo Burning Studio 9.20
Application site: http://www2.ashampoo.com/webcache/html/1/product_2_2210___USD.htm

Script Function:
Template AutoIt script.

#ce ----------------------------------------------------------------------------

; Script Start - Add your code below here

Opt("TrayIconDebug", 1)

; Installer file name
$Installer = "ashampoo_burning_studio_9_9.20_sm.exe"
; Serial number
$SN = "xxxxxx-xxxxxx-xxxxxx"

$PreviousInstallation = RegRead("HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\Ashampoo Burning Studio 9_is1", "InstallLocation")
If StringRight($PreviousInstallation, 1) = '\' Then
$PreviousInstallation = StringTrimRight($PreviousInstallation, 1)
EndIf
If FileExists($PreviousInstallation & "\burningstudio9.exe") Then
MsgBox(0x40010, @ScriptName, "Please uninstall previous version of Ashampoo Burning Studio before using this script", 4)
Exit
EndIf

; Save and disable the default internet browser (to prevent Ashampoo Burning Studio installer to open it at the end of installation)
$DefaultHttpBrowser = RegRead("HKCR\http\shell\open\command\", "")
$DefaultHttpsBrowser = RegRead("HKCR\https\shell\open\command\", "")
RegDelete("HKCR\http\shell\open\command\", "")
RegDelete("HKCR\https\shell\open\command\", "")

; Start checking
AdlibEnable('_Adlib')

; Run the installer
RunWait($Installer & " /sp- /verysilent /norestart")

Sleep(2000)

; Settings
RegWrite("HKLM\Software\Ashampoo\Ashampoo Burning Studio 9", "RegKey", "REG_SZ", $SN)
RegWrite("HKLM\Software\Ashampoo\Ashampoo Burning Studio 9", "InfoChannelsEnabled", "REG_DWORD", "0")
RegWrite("HKLM\Software\Ashampoo\Ashampoo Burning Studio 9\ash_inet", "Enabled", "REG_DWORD", "0")

; Restore the default internet browser
RegWrite("HKCR\http\shell\open\command\", "", "REG_SZ", $DefaultHttpBrowser)
RegWrite("HKCR\https\shell\open\command\", "", "REG_SZ", $DefaultHttpsBrowser)

; Delete page folder and Desktop icon
DirRemove(@AppDataCommonDir & "\page", 1)
FileDelete(@DesktopCommonDir & "\Go to WWW.THE-PAGE.COM.lnk")

; Stop checking
AdlibDisable()

Func _Adlib()
; Close MSN toolbar installation process
$PID = ProcessExists("toolbarsetup_SL1.0_ash_de-DE.exe")
If $PID Then
ProcessClose($PID)
EndIf

; Close Ashampoo Burning Studio process
$PID = ProcessExists("burningstudio9.exe")
If $PID Then
ProcessClose($PID)
EndIf

; Close Internet Explorer process if was started
$PID = ProcessExists("IEXPLORE.EXE")
If $PID Then
ProcessClose($PID)
EndIf
EndFunc

Func OnAutoItStart()
; One script instance only
If WinExists(@ScriptName & '_Interpreter') Then Exit
AutoItWinSetTitle(@ScriptName & '_Interpreter')
EndFunc

Edited by radix
Link to post
Share on other sites

I have extracted the installer using the latest version of innounp, and the only executable file I found, which can install a toolbar is {tmp}\toolbarsetup_SL1.0_ash_de-DE.exe

Link to post
Share on other sites
I have extracted the installer using the latest version of innounp, and the only executable file I found, which can install a toolbar is {tmp}\toolbarsetup_SL1.0_ash_de-DE.exe

Ok, well thats weird. :P

Link to post
Share on other sites
@Highspeedmac

thx for your script, works fine

only msn toolbar installation window pops up!!

Can you modify your script to kill this popup??

thx in advance

That's funny, I don't get any MSN popups or MSN installs with the script.. Guessing they must have updated the install...

I have since dropped this app, after finding it was burning more coasters then good CD/DVD's..

Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...