Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
EvanD

Firefox 3.0.x doesn't print

Recommended Posts

I installed KernelEx 4.5 Beta 1 and tried to print with Firefox 3.5.7. Lo and behold, both Print Preview and Print worked. Xeno86 deserves major kudos for fixing this problem. :thumbup

Share this post


Link to post
Share on other sites

I don't recall it to be fixed. If it prints, results are comparable to FF3.0 (bad).

Share this post


Link to post
Share on other sites
I don't recall it to be fixed. If it prints, results are comparable to FF3.0 (bad).

With Final 2, Firefox 3.5.x could not find the print driver. With 4.5 Beta, I see a good Print Preview on all pages I've looked at (~10). I printed one page of formatted text (no images) and it came out fine.

According to BenoitRen, the Win 9x Firefox 3.x.x print interface code was removed so I was surprised to see it work. I jumped to the conclusion that Xeno86 modified the 9x print interface but I could be very wrong. Nevertheless, I now get printing (albeit not well tested) and I did not have anything with Final 2.

I just looked at Firefox 3.6 Print Preview and it, too, looks good. Perhaps the printing will turn out to be less than perfect but I now have something rather than nothing. I cannot make any statement about what others have experienced or may experience with KernelEx 4.5. We shall see.

Correction: I cannot print with Firefox 3.6. When I try, Windows locks-up and no Printer Dialog appears. This did not seem to happen with 3.5.7. (I tried at least 4 times and I got a printer dialog with no lock-up.) So, you're right, the results are bad.

Edited by EvanD

Share this post


Link to post
Share on other sites

Well the situation with FF3 printing is complicated.

Whole printing algorithm was replaced when they moved onto Cairo graphical layer. It's very complicated now and uses a lot of NT GDI extensions as well as printing/postscript improvements. With the scaling emulation added into Final 2 FF3.0 was able to print, however, it was very hardware dependant since printing creates various undefined situations which some drivers don't handle, and one error stops whole printing. Plus, images can be incorrectly positioned. Plus, you can leak all your resources out while printing lot of pages. FF3.5 started using unicode print functions which weren't implemented until kex 4.5 (and they're far from perfect now).

So the situation isn't improved yet and i'm not sure if/when it will.

Share this post


Link to post
Share on other sites
<snip>

So the situation isn't improved yet and i'm not sure if/when it will.

Tihiy, thanks for your explanation of the FF 3.x printing situation. I hope it gets fixed but I understand that an expert programmer needs to feel it is a priority to him before a patch is attempted/implemented. Since printing in 9x is already intermittent and you experts understand the API requirements, I infer that a fix is possible. That's better than no hope.

Share this post


Link to post
Share on other sites

If you want to print with Firefox 3.6 should change the number that identifies the operating system 4.10.2222 with this 5.1.2600 in Regedit. There remains the problem in some cases for images

Share this post


Link to post
Share on other sites
If you want to print with Firefox 3.6, you should change the number that identifies the operating system 4.10.2222 with this 5.1.2600 in Regedit. There remains the problem in some cases for images

I changed from Version 4.10.2222 to 5.10.2600 in two places in the Registry and you're right: 98SE did not lock-up, the Print dialog appeared and printing was successful. Just changing it in "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion" wasn't sufficient but when I also changed it in "HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\Installed Components\{10303d00-16dc-11d4-a58a-00902766e933}," the print started working. (Just one test case so far.)

Now a question for Tihiy, Xeno or another guru: Is it OK to leave 98SE spoofed as XP perpetually? (In the past, Xeno has advised resetting version back to 4.10.2222. I inferred that spoofing could cause compatibility problems with other programs.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...