Jump to content

Firefox 3.0.x doesn't print

Recommended Posts

I have KernelEx 4 RC2 installed under Win 98SE and Firefox 3.0.11 works fine except that it only prints blank pages. (Same result with all earlier versions of Firefox 3.) Print Preview pages are correctly displayed. Margins are set correctly (0.2") and I've varied zoom and tried "shrink to fit." I also use Acrobat Reader 7.8 under KernelEx and it prints correctly. All older versions of Gecko browsers print fine as do all other installed programs. Anybody have any hints? TIA.

Edited by EvanD
Link to comment
Share on other sites

This problem was reported in the following thread back in January but there was practically no response to question posted and certainly no definite conclusions.


I had the exact same problem as EvanD, this, together with other display problems with FF3 is why I reverted to FF2 again.

After searching the FF forums and following the advice listed and reinstalling printer drivers I could not rectify the issue.

Has anyone got FF3 with KernelEx to print?

Link to comment
Share on other sites

  • 4 weeks later...

After upgrading to Firefox 3.5, the printing blank pages I experienced with 3.0.x is now worse. Print Preview can't find the printer and ctrl-P is now erratic. Sometimes the printer dialog appears and the print command still prints blank pages. Other times ctrl-P causes Firefox to crash with the following error:

FIREFOX caused an invalid page fault in

module KERNEL32.DLL at 0177:bff7a388.


EAX=007a000c CS=0177 EIP=bff7a388 EFLGS=00010212

EBX=00000014 SS=017f ESP=009cd4cc EBP=009cd4f0

ECX=00000033 DS=017f ESI=007b01a4 FS=6137

EDX=007a0000 ES=017f EDI=002e001c GS=0000

Since KERNEL32.DLL is involved, I'm hoping that KernelEx might be able to eventually solve the Firefox 3.x printing problem that some of us are experiencing. If it's a Firefox problem, I know there's no hope that anyone will look at it with Win 98SE being the O/S.

BTW, the browser image retention artifact I used to see in the Firefox 3.0.x window and the spill over onto the Desktop is now gone with Firefox 3.5.

Edited by EvanD
Link to comment
Share on other sites

Back when I inspected the large patch that removed Win9x support, I noted some removed lines that made sure that Win9x got a different parameter for the printer in a certain API call. KernelEX only provides missing APIs, so this problem would remain. I'll look for the relevant part of the patch if I have some time.

Link to comment
Share on other sites

  • 2 weeks later...

FF3.0.x is printing with KernelEx4 SVN due to improvements in APIs which Pango/Cairo use, but only [porn] pictures. That's due to heavy use of newer PostScript APIs and weird scaling it uses. It may be possible to improve printing in the future, but it requires a lot of work.

Link to comment
Share on other sites


Seems I was a bit hasty

Prints text files both using "open file" , and "print version" on BBC sites

Prints the outlines on the boxes for this page

For jpg's prints black mess

Does not want to print anything with graphics

Also seems I am on FF3.0.11...thought I had updated

Sorry about error but was excited as I had got nothing to print before

Was sure this was an improvement

Link to comment
Share on other sites

Firefox 3.5.1 with KernelEx 4.0 Final

Print Preview:

There was a problem printing. The printer could not be found.

Print with printer turned off:

Print dialog - clicked on cancel.

Print with printer turned on:

Windows/mouse slower, slower, slower, hard lock.

Printing in other apps works okay.

Link to comment
Share on other sites

FF3.51 is printing again with RC4 Final
Really? Who can confirm?

Me. I have print preview working and I have been able to print with acrobat distiller 5. Only tried once on a single local html page as I am not using Firefox normally.

Edit : I can't confirm anything actually as I just checked the Firefox version and it is 3.0.11 I have.

I have just tried 3.5 now and I have the same problem reported by RetroOS with Print Preview and if I try to print without preview it crashes in Kernel32.

Edited by eidenk
Link to comment
Share on other sites

After my plunder the other day tried FF3.51

When I tried printing or even opening the Print Dialogue box, FF and Explorer froze

3 fingered salute ended FF but system still frozen

Only recovery was the OFF switch

Reverted to FF3.12 and can now print text OK, graphics come out as black blob, but no lock up

Using SP3 982ME RP9 & Kernlex on Epson printer

For some unknown reason FF3.51 ONCE printed a perfect jpg but was unable to do it again

Correct me if I am wrong but does not 9X use spool32.exe and NT use spoolsv.dll

Anyway hope someone can fix this problem

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...