Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Tihiy

Revolutions Pack 9.7

Recommended Posts

Hey,

remember the 16bit-Icon-bug (some icons had black edges in 32bit-mode, but the regtweak did it's job...) ??!

I found a minor bug like this... some small icons, like the folder-icon of a windows title-bar still have those edges..

Could you or anyone tell me some places in the reg to look at please?!?

Bye

Flipp

Share this post


Link to post
Share on other sites

I found a minor bug like this... some small icons, like the folder-icon of a windows title-bar still have those edges..

Could you or anyone tell me some places in the reg to look at please?!?

You can't fix this. Unless you use some skin.

Share this post


Link to post
Share on other sites

After updating RP v9.7.1

I noticed some text in the connection state was missing

so i checked the (Don't replace default shell font with Tahoma) Box in RPConfig

after the Reboot the text was fine!

also the (My Computer Icon) in the Explorer window now has black borders

post-299688-0-31257900-1293691826_thumb.

Share this post


Link to post
Share on other sites

@ Darkstar: Sounds like this could help: (..if you use 32bit-icons...)

@Tihiy: Are you shure? I use "your" XP-icons and the icon-expansion pack with new sys-icons etc.. (where did I get this from...?!?) I would say it's the same thing as in the posts linked above. ..and there is no reg-entry like the one in the post just for smaller icons?!

I don't know, do you have a clue why I actually have to do these reg-tweaks anyways?!? (You said it shouldn't be necessary) ...there must be something wrong...

(btw. only to get this right: the RP9.7.1 should naturally sort the files even with "seperate processes", right?! - because it doesn't seem to over here...)

Share this post


Link to post
Share on other sites

Happy newyear, y'all!

The Q320798 update seems to be for SE systems
It's for FE too. And other (previous) fixes are there too ofc.

OK, I installed the Q320798 update. Everything works fine now.

I'd like to keep it as original as possible.
And you install RP9 huh.

Yes, but RP is irresistably cool (on multiple levels...)

Share this post


Link to post
Share on other sites

Happy new year MSFN!

I made another theme today. I call it 'Mobility'

Happy New Year to everyone ! :hello:

Nice work Svenne :thumbup

3 points I don't like personally:

  • the focused window has the clearest titlebar but the darkest taskbar button. I find it disturbing
  • the taskbar height is (slightly) too small
  • the 'X' close button is (slightly) too big, and too close to the right side when maximized (no edge).

BTW,

  • the reg file has to be completed with its 2 first lines ;)
    REGEDIT4
    [HKEY_USERS\.DEFAULT\Control Panel\Appearance\Schemes]
    and maybe a 2nd blank line at bottom.
  • there is a useless file BLUE_STARTBUTTON_BMP.pdn in the resources folder.

Cheers.

Charles.

EDIT:

one thing more, with Whistler (for instance ;) ) in a window with several choices,

the pre-selected (suggested) button is pointed out in some way.

post-200646-0-14641400-1293979671_thumb.

This is almost lacking with Mobility.

HTH

Charles

Edited by CharlesF

Share this post


Link to post
Share on other sites

Thx Svenne, I love it! :thumbup

The pattern is very close to the black bar with 'Sign in >>' at the top of MSFN Forums,

and I have always thought that it deserves to become a theme :lol:

I have for my own use modified the 'skin.ini' like this:


TaskBarSize=27
...
AeroButtonsMinRight=5
AeroButtonsTop=7
AeroButtonsTopMaxi=7

And the result:

post-200646-0-84650900-1294098842_thumb.

post-200646-0-77892300-1294098824_thumb. post-200646-0-18318000-1294098834_thumb.

Charles :)

Edit: BTW, how do you manage to post a new file with the very same link on Mediafire?

Edited by CharlesF

Share this post


Link to post
Share on other sites

I use the 'Update File' function.

EDIT: Added your changes to the skin.

Thx.

Beautiful skin B)

(maybe, if you find the time, you could do the same with the blue pattern of the main topic_title bar... :whistle: )

Edited by CharlesF

Share this post


Link to post
Share on other sites

@Tihiy: Are you shure? I use "your" XP-icons and the icon-expansion pack with new sys-icons etc.. (where did I get this from...?!?) I would say it's the same thing as in the posts linked above. ..and there is no reg-entry like the one in the post just for smaller icons?!

I don't know, do you have a clue why I actually have to do these reg-tweaks anyways?!? (You said it shouldn't be necessary) ...there must be something wrong...

You got the extended icon pack from me (http://www.baut.nl/downloads/RP9-Icons.zip).

The Shell Icon BPP - thing has been an issue for several times since the

development of UberSkin.

I made the "IconSkanner" application (included in my icon pack) to scan for

icon locations, and then show them in a list. If I want the icons to be

displayed correctly in every system, I create an imagelist like this:

ImageList_Create(IconX, IconY, ILC_COLORDDB + ILC_MASK, 1024, 1024)

ILC_COLORDDB is for using the Shell Icon BPP value. Setting this flag works

very well, also in XP and Vista. I think it was since RP 9.5.0 that I had to

force it to ILC_COLOR32 or the icons would not be displayed correctly.

In my latest version I set the ImageList_Create flag back to ILC_COLORDB. If

you re-download the pack and start IconSkan.exe, you can see the result.

Maybe Tihiy could look into this...

Share this post


Link to post
Share on other sites
ILC_COLORDDB is for using the Shell Icon BPP value.
Nope.
I think it was since RP 9.5.0 that I had to force it to ILC_COLOR32 or the icons would not be displayed correctly.
It was never supported.

Share this post


Link to post
Share on other sites
ILC_COLORDDB is for using the Shell Icon BPP value.
Nope.
I think it was since RP 9.5.0 that I had to force it to ILC_COLOR32 or the icons would not be displayed correctly.
It was never supported.

I checked it again, and it seems you're right. But the reason why I came up with it is because I'm working on an icon-port of Mac OSX (yes!).

The XP and Vista icons show proper, but somehow the Mac-icons don't (see first screen shot). If I downgrade to RP 9.5.0,

the Mac icons show right again (second screen shot), although the little folder icons in the Explorer tree still don't.

You can download the image resources I used from http://rp9.win98.nl/Test-OSX.zip

post-200195-0-01049300-1294315384_thumb.

post-200195-0-36474700-1294315408_thumb.

Share this post


Link to post
Share on other sites
The XP and Vista icons show proper, but somehow the Mac-icons don't (see first screen shot).
Too bad. I'll redo icon loader to ignore icon mask at all. Meanwhile you can try to fix your icons; unfortunately i'm not aware of automatic method to fix icon mask.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...