Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Tihiy

Revolutions Pack 9.7

Recommended Posts

Hi Tihiy,

congratulations for the remarkable version 9.7, you can view the menu properly GoogleEarth 5.1

Greetings and thanks for your superb work

anonimoo.th.jpg

Uploaded with ImageShack.us

Edited by paoloapaolo

Share this post


Link to post
Share on other sites

- New: natural shell file name sorting;

Very nice! Default sorting has always been so awkward...

By the way, I'm on it for the french translation.

Share this post


Link to post
Share on other sites

Hi Tihiy,

congratulations for the remarkable version 9.7, you can view the menu properly GoogleEarth 5.1

Greetings and thanks for your superb work

Btw. How did you actually install Earth???

The web-installer doesn't even start (KEX: min. w2000-mode) and the standalone versions 5.1 & 5.2 load (the installer?! even twice..) but then a message appears telling me that it couldn't access some win-installer-services and that this might happen if win runs in save-mode (..I don't).

I just unpacked the installer with 7-zip and found the program, but when I run it, it just crashes after a few seconds.. is there another way??

bye

Share this post


Link to post
Share on other sites

Thx, setting "-setDX" worked!!... (and after having done this, it even worked without it, but is slower, -why?!)

Is this a general bug with openGL? To me it seems that the 3d-graphics-window is just not refreshed when using openGL!!! (sometimes, when mini- & maximizing the program, or on right-clicks it is refreshed, that why I think so...). Another prog seems to behave just like this, called apophysis.. so is it my fault, or what to do?!

...but I get this after quitting Google Earth:

-----

GOOGLEEARTH verursachte einen Fehler durch eine ungültige Seite

in Modul KERNEL32.DLL bei 0177:bff9dc19.

Register:

EAX=c0030948 CS=0177 EIP=bff9dc19 EFLGS=00010216

EBX=02f9ffbc SS=017f ESP=02e9fefc EBP=02ea0198

ECX=00000000 DS=017f ESI=00000000 FS=6ec7

EDX=bff76855 ES=017f EDI=bff79050 GS=0000

Bytes bei CS:EIP:

53 8b 15 e4 dc fc bf 56 89 4d e4 57 89 4d dc 89

Stapelwerte:

-----

...why's that?

Share this post


Link to post
Share on other sites

We recommend using KernelEx 4.5 RC 4, use DirectX mode, my system is fluid in his movements, E5200 cpu 6800gt graphics card. The stability is not comparable to the 4.3 version but has made a big step forward. The version 5.2 does not work. Maybe it's an argument for Xeno86

Share this post


Link to post
Share on other sites

What is wrong in my computer that Windows Explorer still sorts the files in order (for example):

1.txt, 10.txt, 2.txt (and not: 1.txt, 2.txt, 10.txt) ?

MS Windows 98 SE + KernelEx 4.5RC5 + Revolutions Pack 9.7.0 (with unselected option: "Don't use natural file sorting")

Explorer.exe 4.72.3612.1710

Shell32.dll 4.72.3812.634

Kernel32.dll 4.10.2226

In Windows register:

in key [HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] - not exist value "NoStrCmpLogical"

in key [HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] - exist the value "NoStrCmpLogical"=dword:00000000

What else can have influence on file sorting in Windows Explorer?

Share this post


Link to post
Share on other sites

- Updating icons to XP/Vista-style, only "My Documents"-icon will be updated, but "My Computer" and "Network Area" icons will stay old. I guess this doesn't happen with English version of Win98. (I have Finnish-version.) (Of course they can be manually updated, but of course the program should update them all automatically after changing.)

Copy below text into a file and execute it. Then change themes to refresh.

REGEDIT4

; Alle computers in het netwerk weergeven

[HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID\{208D2C60-3AEA-1069-A2D7-08002B30309D}\DefaultIcon]

@="C:\\WINDOWS\\SYSTEM\\shell32.dll,17"

; De inhoud van uw computer weergeven

[HKEY_LOCAL_MACHINE\Software\CLASSES\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon]

@="explorer.exe,0"

Share this post


Link to post
Share on other sites

Copy below text into a file and execute it. Then change themes to refresh.

I forgot to say that the file has to have the extension ".reg".

Share this post


Link to post
Share on other sites

Tihiy, this is so minor I'm almost embarrassed to report it:

about0.jpg

Unfortunately, I have one of those cheap Intel 82810 graphic cards built-in to the motherboard. It's max setting is 24-bit, but I have to keep it at 16-bit or some problems occur with VLC (version 1.02) and some old DOS proggies. Under RPConfig I have icon-quality set at 16-bit. That's really the only "problem" I've noticed. Obviously, I've blacked out the name.

Share this post


Link to post
Share on other sites

Seems that natural sorting fails to work with SeparateProcess turned on. Thx for reporting.

Tihiy,

'Natural file sorting' doesn't seem to work here too:

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer -> don't have such key

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer -> don't have the value "NoStrCmpLogical"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced -> don't have the value "SeparateProcess"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer -> don't have the value "DesktopProcess"

Edited by CharlesF

Share this post


Link to post
Share on other sites

Thanks Tihiy for your excellent work and continued development of Revolutions Pack. It has been working very well on my Win98 SE systems with one persistent annoying bug starting with my initial installation of Revolutions Pack 9.6.5 and continuing in every updated version since. For some reason, the Recycle Bin icon no longer accurately shows its status (empty or full) especially within Windows Explorer. The Recycle Bin icon on the desktop seems to behave more normally most of the time (vs. the Windows Explorer Recycle Bin icon) but I don't think it's 100% accurate either. The Windows Explorer Recycle Bin icon is almost 100% inaccurate after the first filling/emptying of the Recycle Bin (i.e., shows it as empty when it is full and vice versa). I've Googled this problem and tried a host of possible solutions without any luck. It's not a showstopper but it is quite annoying, and it became immediately obvious after my initial installation of RP 9.6.5. Any help or possible solutions would be greatly appreciated!

Edited by Prozactive

Share this post


Link to post
Share on other sites

(...) For some reason, the Recycle Bin icon no longer accurately shows its status (empty or full) especially within Windows Explorer. The Recycle Bin icon on the desktop seems to behave more normally most of the time (vs. the Windows Explorer Recycle Bin icon) but I don't think it's 100% accurate either. The Windows Explorer Recycle Bin icon is almost 100% inaccurate after the first filling/emptying of the Recycle Bin (i.e., shows it as empty when it is full and vice versa). (...)

I know that is not a discussion thread about this, but I just ad vocem; see here:

Edited by egrabrych

Share this post


Link to post
Share on other sites

Seems that natural sorting fails to work with SeparateProcess turned on. Thx for reporting.

Tihiy,

'Natural file sorting' doesn't seem to work here too:

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer -> don't have such key

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer -> don't have the value "NoStrCmpLogical"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced -> don't have the value "SeparateProcess"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer -> don't have the value "DesktopProcess"

When writing my post, I thought that I am "guilty" of no "natural sorting" in RP 9.7. In truth, I expected the requirement of cooperation with the relevant Windows files in their respective versions, but I did not know with which files and in which versions.

"SeparateProcess" I really did had turned on, not even remembering about it - but disabling this option, and even complete removal from the Windows registry key, did not help at all.

Which is a injury, because it makes contents of the folder more readable (I know this from Windows XP). :(

Edited by egrabrych

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...