Jump to content

KernelEx 4.5.2


Recommended Posts

After thorough investigation, we concluded it's a bug in Win98' user subsystem. It's not KernelEx/RP9 related. You can use user.exe/user32.dll from WinMe to fix it.

That solved the RPConfig issue, but not the Code::Blocks issue. Although they appeared to be related i guess they are not related after all.

But still, thanks a lot.

Link to comment
Share on other sites

Google Picasa 3.6 does work with KernelEX 4.5 RC1 in general. But there are some problems. One of them is invisible Tools - Options - General tab.

- default compatibility mode - the language is forced to English, and it is not possible to change it since the Options - General tab is not visible. But, everything else seems to be working fine. While accessing Options an error message dialog appears with "Improper Access" message (the message is always in my local Polish language, I had to translate it from "Niewłaściwe dojście").

- Windows 2000 or newer compatibility mode - the language is automaticaly set to the local one. There are no error message when accessing Options dialog. The initial settings are not remembered. So, Picasa asks for them at every run. The file exploration does not work.

It seems the Picasa 3 is the only completely free application (all others are just free for noncommercial use), able to print large bitmaps (over 16MB in size) in Windows 98, with Polish language support. The only problem is I can not turn the Polish language on, without sacrificing other functions.

Edited by Sfor
Link to comment
Share on other sites


I can not install KernelIEx on 98se2m/xp .Error:

"Failed to opoen backup file C:\windows\kernelex\kernel32.back

Posible causes: previous version not uninstalled correctly or file

has been deleted.

Restore C:\windows\system\kernel32.dll manually from install media."

But in C:\windows\system I found kerne32.dll vesion

What I missing and what can I do ?

Please any idea ?

Thank you!


Link to comment
Share on other sites

For Advanced Member "Google Picasa 3.6"

1) during installation mode using XP sp2

2) first boot file Picasa.exe at XP SP2 page of language change is visible, if not see press "P" for Polish or "I" in Italian and 2 times sending and restart the program.

Further change of language

1) change in compatibility mode defaut Kernelex

2) restart Picasa - Back English

3) close Picasa

4) change in compatibility mode XP SP2 Kernelex

5) restart Picasa page and change the language press "P" for Polish or "I" in Italian and 2 times sending and restart the program.


Edited by paoloapaolo
Link to comment
Share on other sites

I've installed the Picasa 3.6 in the Windows XP SP2 compatibility mode. The first run in the same mode worked correctly with the proper (Polish) language.

But, then I tried to change the options. After that the Picasa returned to English, and the file exploration stopped working. I can change the language back to Polish, but exploration stopped working for good.

There is some problems with the configuration changes of the Picasa 3.6 in Windows XP compatibility mode. Just change Options once and the settings are getting messed up. Reinstallation is required, to make file exploration work again.

Link to comment
Share on other sites

Could you please add support for World of Warcraft (after patch 3.3.5a)
We'll try, but can you please explore all missed dependancies (with depends)? Because it'll take much time to download and patch by ourselves.
Link to comment
Share on other sites

Hi Xeno86 and/or Tihiy,

I tried to install MS viewers 2003 but without success - except Powerpoint viewer (this one installed and run OK). When I run the setup of Word or Excel viewer, I get the message:

The specified program requires a newer version of Windows.

When I set the compatibility for setup.exe, another message appears:

This program has performed an illegal operation

and will be shut down.

If the problem persists, contact the program


When I click the Details, one can see following data:

SETUP caused an exception c06d007fH in module

SETUP.EXE at 0167:30021e16.


EAX=0062ead8 CS=0167 EIP=30021e16 EFLGS=00000246

EBX=00000000 SS=016f ESP=0062ea80 EBP=0062ead0

ECX=c14ded70 DS=016f ESI=300221b4 FS=23ff

EDX=81826ce8 ES=016f EDI=bfe80000 GS=0000

Bytes at CS:EIP:

8b 5d d8 8b 45 0c 89 18 a1 b0 c1 07 30 85 c0 74

Stack dump:

00000000 00500728 0062eb44 00000024 300221b4

30024078 30022240 00000001 300225c0 bfe80000

00000000 0000007f 00000000 00000000 3007bd54


Please could you give me a hint for successful instalation/runing of the viewers?

I have Win98SE (fresh installed) and KEx 4.5 RC1.

Link to comment
Share on other sites

A month ago I wrote:

After installing KernelEx 4.5 RC1 each time I run Windows 98 Second Edition (Polish version) I get the message: "Błąd przy uruchamianiu programu Uruchomienie pliku KEXBASEN.DLL jest niemożliwe. Sprawdź plik, aby rozpoznać problem." ("The kexbasen.dll cannot start. Check the file to determine the problem.")

As it turned out later, I had understood the words of the error message: "The kexbasen.dll cannot start. Check the file to determine the problem." completely inversely to their actual meaning, wrongly seeing in them information about problem with launching KernelEx. That message had been really informing about inability to use KernelEx to open one of the programs launched in the autostart mode during starting the Windows system, and the KernelEx itself was fuctioning properly then.

It ist highly possible that the identical incident occured to fortcollis (posted 23 june 2010); in my opinion (Xeno86 please correct me if necessary) the discussed error emerges from the attempt to use KernelEx before it is even fully opened - in practice it applies surely to one (or more - if the message appears many times) of the programs launched in autostart. This program, due to appearance of the error, rather won't start.

In my case it was enough to use "Disable KernelEx extensions" in properties (in "Compatibility" lap) of the program to which error applies to: I think that it will be just like that in other people's cases.

Edited by egrabrych
Link to comment
Share on other sites

support for World of Warcraft (after patch 3.3.5a)
Unfortunately support for WoW battle.net.dll is complicated because of its heavy use of code obfuscation. This is the target for future KernelEx version.
Link to comment
Share on other sites


I just dropped in because I've recently had some problems with some programs...

To be more precise,

its a 3d-surface-generator, "k3dsurf" ( k3dsurf.sourceforge.net ) , is someone willing to try it, plz??

for me it works best with the win2000-config. but not always... after a restart I sometimes get graphical problems, and it seems I am missing some fonts, can someone confirm that??

other things are

Inkscape and Synfig ,two drawing-progs..

they work best in win2000-mode as well.

in XP-mode I get errors causing a crash. For example just try a right-click in Inkscape..

Its a Gtk+ error, thats all I can say. Might there be a solution?? Or what is this telling me, since I'm not a programer..

Btw. whats you guys favourite drawing-program (2d-, 3d, CAD-)??

Greets Flipp

Link to comment
Share on other sites

K3DSurf is a buggy application who never worked too properly AFAIK, I am not sure it can be fixed with KernelEx tbh, version 0.6 which I have installed is sort of workable though.

Edited by loblo
Link to comment
Share on other sites

KernelEx v4.5 RC 2

Release announcement

Okay, so here comes a new release. This time it mainly fixes reported bugs.

Hope you enjoy this release.

In case you didn't know yet... KernelEx has now a real webpage instead of the ugly default one.


What's new:

  • Implemented SysLink common control class

Apps fixed / now working:

  • Fixed: Google Picasa options dialog (empty tabs)
  • Fixed: Adobe Flash Player crashes (reported by mailcat via sf.net forum)
  • Fixed: Adobe Flash Player 10.1 volume control
  • Fixed: Wizard101 game crash (bug #3041092)
  • Fixed: Maxthon browser (freezing)
  • Now working: Maxthon 1.6.7
  • Now working: VLC 1.1.2 (without RP9)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...