Jump to content

Silent .NET Maker synthesized 20100118 - W2K/XP/2K3 x86


Recommended Posts

I want to create a AIO of Dutch dotNET.

.NET 2.0 SP2 package for 2K/XP/2K3 installers/add-ons (eventhough the donwload page states 2K is not supported).

.NET 2.0 SP2 langpacks for 2K/XP/2K3 installers/add-ons (eventhough the donwload page states 2K is not supported)

I dont need the above 2 files? Since they are inside the "full redistributable" also.. ?

Link to post
Share on other sites

MSXML is included in the 3.0 block because is a prerequisite for it to work. It just need to be installed previously to 3.0, as 2.0.

Link to post
Share on other sites

i have read the first 2 pages and am totally lost all i want is an addon that has (heres where im lost) all the net framework versions but im confused as do u need all or only 3.5 sp 1 or does 1.1 need to be installed first then 3.5 sp1 or does 2.0 need to be in there aswell?

Link to post
Share on other sites

.NET 3.5 SP1 includes .NET 3.5 SP1, 3.0 SP2 and 2.0 SP2

so you need :

- .NET 3.5 SP1 installer

- hotfixes (NDP20SP2-KB958481, NDP30SP2-KB958483 and NDP35SP1-KB958484)

- MSXML6 update (KB954459)

- .NET 1.1 installer

- SP1 for .NET 1.1 (KB867460)

- hotfixes for .NET 1.1 (KB928366 and KB947742)

quite simple isn't it? lol

Link to post
Share on other sites

First all the info you need is in post #1, in pages 1 and 2 you'll find outdated info.

The process to build the add-ons and the installing are different things.

To build an updated AIO add-on you'd need 1.1 and its hotfixes and 3.5 SP1 redist and its hotfixes (including 2.0 SP2, 3.0 SP2 and 3.5 SP1) in your work folder, depending on your target win version (not host).

After you get the AIO add-on, you don't have to worry about the installing order priorities because the merged installers respects it, only if you build individual add-ons for each FX version, you have to keep the priorities described when inserting the add-ons in nLite.

Link to post
Share on other sites
What about KB867460?
I mentioned it, it is SP1 for .NET 1.1 ;)
KB947742 is for Win2k only?
you're right, I hadn't noticed... would it break install on XP if this hotfix is included? Edited by OuTmAn
Link to post
Share on other sites

It would generate an error while building installers with XP as target.

EDIT: But its installing is not restricted to 2K so it will not break install.

Edited by strel
Link to post
Share on other sites
It would generate an error while building installers on XP and not choosing an alternate target win version in the .ini file. But if you build installers for 2K as target with KB947742 and try to install them on XP, it would break the install, generating an error, as if you were trying to install KB947742 on XP directly.

I've installed the 2K version on XP without error.

Link to post
Share on other sites
First all the info you need is in post #1, in pages 1 and 2 you'll find outdated info.

The process to build the add-ons and the installing are different things.

To build an updated AIO add-on you'd need 1.1 and its hotfixes and 3.5 SP1 redist and its hotfixes (including 2.0 SP2, 3.0 SP2 and 3.5 SP1) in your work folder, depending on your target win version (not host).

After you get the AIO add-on, you don't have to worry about the installing order priorities because the merged installers respects it, only if you build individual add-ons for each FX version, you have to keep the priorities described when inserting the add-ons in nLite.

ok... is there an aio?? addon up to date or do i have to learn the rocket science degree of understanding all this first lol

Link to post
Share on other sites

2 b-man

AIO english updated add-on for XP , isn't it?

Download 1.1 + NDP1.1sp1-KB867460-X86.exe + NDP1.1sp1-KB928366-X86.exe

+ 3.5 SP1 redist + NDP20SP2-KB958481-x86.exe + NDP30SP2-KB958483-x86.exe + NDP35SP1-KB958484-x86.exe

+MSXML6 updated version + (optionally the restricted hotfixes for these versions above, not needed for WU silence)

In _SNMsynth.ini set OUTPUT=ADDON and MERGE_FRAMEWORKS=YES, and if you want silent add-ons instead of passive set VERBOSITY=SILENT.

If your host OS is XP run the process, otherwise add WINXP=YES in the .ini file before run.

Clear enough?

2 Kurt_Aust

You're right, though not needed as stated by ms its installing is not restricted to 2K. Thx.

Link to post
Share on other sites
2 b-man

AIO english updated add-on for XP , isn't it?

Download 1.1 + NDP1.1sp1-KB867460-X86.exe + NDP1.1sp1-KB928366-X86.exe

+ 3.5 SP1 redist + NDP20SP2-KB958481-x86.exe + NDP30SP2-KB958483-x86.exe + NDP35SP1-KB958484-x86.exe

+MSXML6 updated version + (optionally the restricted hotfixes for these versions above, not needed for WU silence)

In _SNMsynth.ini set OUTPUT=ADDON and MERGE_FRAMEWORKS=YES, and if you want silent add-ons instead of passive set VERBOSITY=SILENT.

If your host OS is XP run the process, otherwise add WINXP=YES in the .ini file before run.

Clear enough?

2 Kurt_Aust

You're right, though not needed as stated by ms its installing is not restricted to 2K. Thx.

very clear now sorry i was pretty tired last nite just didnt have my head switched on

i appreciate all the work u have done here and for being able to put up with me lol

Edited by b-man
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...