Jump to content

Windows7 Pre-BETA (Build: 6801) and how to get your drivers up and run


Recommended Posts

I installed Windows7 Pre-BETA (6801) on my Lenovo ThinkPad SL-300..

And the operative system itself seems to be incredibly stable for a Pre-BETA (aka Alpha) version!

Only downside is I've got some huge problems with getting all my drivers installed :(

Is not that the drivers don't work, as we all know 95% of the current Vista drivers should actually work perfectly with Windows7, the main issue it how to get the in there?!

My Webcam, GeForce, Realtek LAN NIC and some other drivers installs without any issues!

But the Intel chipset, Intel Wireless NIC, Intel Matrix and some Lenovo system drivers refuse to install on Windows7?!

It's not the drivers being the problem, it's just the install that has be created in a way so it wont install on anything other than Vista 64bit :(

It wasn't that hard to get the wireless running though, first of all there was a default driver loaded, second all I had to do was doing the "Device Manager - Update Driver" thing, which worked for both the Intel SATA and Wireless driver..

The chipset driver on the other hand isn't going so well, as the Intel chipset driver isn't "downloadable", you just have this tool that identifies your chipset and then get you the drivers from Intel, and this utility refuse to run on Windows7 so I don't get those bloody *.inf files at all? :(

Same problem with some of the Lenovo drivers, I made some of the work with that "Device Manager - Update driver" thing, but not all of them worked as some of their drivers are located within som data.cab files, and the extraction of those only stars during the installation, which of course wont start on Windows7! The ATK0110 won't install either..

It's not always that easy to do "Device Manager - Update Driver" either, as some of the hardware listed in Device Manager just says "Unknown Device", which isn't telling me a lot..

Anyone got some tips / workarounds on how to get the Intel Chipset (I'm running GM45 / PM45), Lenovo ATK0110 and the Lenovo system drivers installed? Would be much appreciated :)

Link to comment
Share on other sites


I had the same problem in my laptop.. problems with intel´s drivers... buy finally the drivers was installed...

In the installer (setup.exe) you should use "Run this program in compatibility mode for: Windows Vista RTM... y the installer should works..


P.D. Sorry for my bad english... i speak spanish

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...