Jump to content

windows 7 beta and vlite


aviv00
 Share

Recommended Posts

anyone having any problems trying to remove packages with DISM? i always get access errors or cannot find the file specified...

more info pls

as an example, i mounted install.wim to folder c:\s2 using imagex & then ran this command: dism.exe /image:C:\s2 /remove-package /packagename:Microsoft-Windows-IIS-WebServer-AddOn-2-Package~31bf3856ad364e35~x86~~6.1.7127.0

i get package error: 0x80070005

error: 5

access is denied.

Link to comment
Share on other sites


How did you mount the Image? Please post your commandline

i actually used imagex to mount, using the gimagex GUI with r/w checked? for some reason, i cant mount with dism? the mount-wim command is unknown?

Edited by dead0
Link to comment
Share on other sites

anyone having any problems trying to remove packages with DISM? i always get access errors or cannot find the file specified...

more info pls

as an example, i mounted install.wim to folder c:\s2 using imagex & then ran this command: dism.exe /image:C:\s2 /remove-package /packagename:Microsoft-Windows-IIS-WebServer-AddOn-2-Package~31bf3856ad364e35~x86~~6.1.7127.0

i get package error: 0x80070005

error: 5

access is denied.

did u use the wim tweak with /m switch ?

Link to comment
Share on other sites

anyone having any problems trying to remove packages with DISM? i always get access errors or cannot find the file specified...

more info pls

as an example, i mounted install.wim to folder c:\s2 using imagex & then ran this command: dism.exe /image:C:\s2 /remove-package /packagename:Microsoft-Windows-IIS-WebServer-AddOn-2-Package~31bf3856ad364e35~x86~~6.1.7127.0

i get package error: 0x80070005

error: 5

access is denied.

did u use the wim tweak with /m switch ?

should i have done?

Link to comment
Share on other sites

on win7 u should use /m like

install_tweak.exe /m /p c:\work\wimmount

/m delete the owners keys from another location in the hive

that why u cant delete it cos only the owner could do that

Link to comment
Share on other sites

on win7 u should use /m like

install_tweak.exe /m /p c:\work\wimmount

/m delete the owners keys from another location in the hive

that why u cant delete it cos only the owner could do that

that seemed to have worked! :thumbup

Link to comment
Share on other sites

a quick update, i have finally made an almost stable vlite'd copy of windows 7. its a mixture of dism & vlite with the install size coming to just under 3gb. the only major problem is that most of the mmc snapins dont work such as gpedit or local security policy?

ps regarding the install size, i could be wrong? it seems to vary when checking the properties of C drive?

Edited by dead0
Link to comment
Share on other sites

a quick update, i have finally made an almost stable vlite'd copy of windows 7. its a mixture of dism & vlite with the install size coming to just under 3gb. the only major problem is that most of the mmc snapins dont work such as gpedit or local security policy?

ps regarding the install size, i could be wrong? it seems to vary when checking the properties of C drive?

check Topic [Guide] Win server 2008 topic for safe packages that could be removed

Link to comment
Share on other sites

  • 3 months later...
A few days ago i did a very basic vlite to remove extra drivers, tablet pc, media center and languages to install on an Aspire One netbook with a 160GB HD (box said 120 but hey :) )

It works extremely well, RAM usage is about double of the pre-installed XP, it's normally hovering just below 500MB. I can confirm that it's definately as quick as XP on the Atom processor, and now when I switch to XP (dualbooting them) it feels like I've booted into the stone age. Kind of like the feeling when you first got aquainted with XP after living with Win9x.

Anyway, I've had an error when it comes to activation. slui.exe fails due to SCARDDLG.dll is missing. unfortunately I've already deleted my .iso and the vlite settings, but I'm fairly certain I didn't remove anything else other than mentioned above.

Wether this information is useful or not to anyone I don't know - after all I may have removed something else and I've simply forgotten - but I thought it was worth mentioning in case it is.

So for now it's back to the default install, I didn't notice any performance differences between this and a regular install, i just tried it to free up a bit of space :)

this ini works best:

; vLite preset file

;

;#Environment:

; vLite v1.2

; Framework 2.0.50727.3521

; Microsoft Windows NT 6.1.7000.0 32-bit

;

;#Target:

; Windows 7 ULTIMATE 32-bit

; Version 6.1 English (United States)

; vLited with v1.2 (08/01/2009 23:36:03)

;

[Compatibility]

ACDSee / XnView

KMPlayer

Zoom Player

Recommended

Aero Glass

Scanners and Cameras

Internet Explorer

Windows Update

Aero Glass

Internet Explorer

[CustomHide]

[Components]

;# Accessories #

Accessibility

Disk Cleanup

Games-Inbox Games

Games-Premium Inbox Games

Mobility Center

Speech Support

System Information

Welcome Center

;# Drivers #

Diva Server

Modems

Printers-Generic printer

QLogic Fibre Channel Adapter

Scanners

Storage controllers-Adaptec

Storage controllers-Elxstor

Storage controllers-IBM ServeRAID

Storage controllers-ICP vortex

Storage controllers-Intel (Matrix)

Storage controllers-nVidia

Storage controllers-SiS

Storage controllers-Via

TV Tuners-ADS Technologies

TV Tuners-ASUSTeK Computer Inc.

TV Tuners-AVerMedia Technologies, Inc.

TV Tuners-Compro Technology Inc.

TV Tuners-Creatix

TV Tuners-Hauppauge

TV Tuners-KNC ONE GmbH

TV Tuners-KWorld

TV Tuners-Lumanate, Inc.

TV Tuners-Philips Semiconductors

TV Tuners-Pinnacle Systems

TV Tuners-TerraTec Electronic GmbH

TV Tuners-VidzMedia Pte Ltd.

;# Hardware Support #

Dynamic Volume Manager

Fax Support

Firewire (1394)

Floppy Disk Support

Infrared Support

Internet Small Computer System Interface (iSCSI)

Microsoft Multi-Path Bus

Modem Support

Printer Support

Smartcards

TV Tuner support

Windows HotStart

XBOX 360 Controller

;# Languages #

Arabic

Brazillian

Bulgarian

Croatian

Czech

Danish

Dutch

Estonian

Finnish

French

German

Greek

Hebrew

Hungarian

Italian

Korean

Latvian

Lithuanian

Norwegian

Polish

Portuguese

Romanian

Russian

Serbian

Simplified Chinese

Slovak

Slovenian

Spanish

Swedish

Thai

Turkish

Ukrainian

;# Multimedia #

Intel Indeo

Media Center

Music and Video samples

Sample Pictures

Screensavers

SideShow

Sound Recorder

Wallpapers

;# Network #

Connect to a Network Projector

Distributed File System (DFS)

File and printer sharing (Server)

Internet Information Services (IIS)

Simple Network Management Protocol (SNMP)

Simple TCPIP services

TFTP Client

Windows Mail

;# System #

Beep

BitLocker Drive Encryption

Disk Quota

Help

IMAPIv2 Burning Support

Jet Database Engine

Microsoft Client For NFS

Microsoft Message Queue (MSMQ)

Natural Language

Parental Controls

Performance Counters

Reliability and Performance Monitor

Remote Differential Compression

Run a legacy CPL elevated

Subsystem for UNIX-based Applications (SUA)

Sync Center

Tablet PC

User Account Control (UAC)

Windows Easy Transfer

Windows SAT (Performance Index)

Zip Folder

[Options]

DEP (Data Execution Prevention) = Default

User Account Control (UAC) = Disabled

AntiSpyware Realtime Protection = Default

Memory requirement = 256MB

AutoPlay = Enabled

Paging Executive = Disabled

Power scheme = High performance

Power button = Default

Sleep button = Default

Control Panel - Classic View = Default

Show hidden files and folders = Yes

Show protected operating system files = Yes

Show extensions for known file types = Yes

IE Phishing Filter = Enabled

IE Phishing Verification Ballon Tips = Default

[services]

[Protection]

[Drivers]

[unattended]

[Hotfixes]

[LanguagePacks]

---

with UAC disabled I can still use sidebar with this config. But make sure you do not re-enable UAC to full or else it won't run properly (explorer crashes, no control panel even if you are in admin group, etc)

if you DID happen to do so, just boot in safe mode and disable UAC again.

Sorry for the dumb question, but does this work for Windows 7 RTM (build 7600)? It worked for my beta but I have RTM now and would like a simple preset for vLite to slim it down. Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...