Jump to content

XP64 Pro Disk Problems


saturndude
 Share

Recommended Posts

Hi everyone,

I'm having trouble installing XPPro 64 OEM on a new system (old Athlon 2900 system [32-bit] died). After files are copied, I am instructed to remove floppies from the floppy drive. If I leave the CD in, the first stage will be repeated forever, so I remove the CD too.

Now Windows complains about a missing or corrupt ntoskrnl.exe. After the recovery console (expand to replace ntoskrnl.exe, fixboot, fixmbr) the problem remains. Why? Chkdsk complains "there is no disk in drive or the file system is not supported". Tried reformatting from the recovery console and a fresh install from scratch, the problem still remains. (EDIT: To avoid dual-boot issues, the whole drive is one big NTFS partition. For now at least.)

The disk is a fresh Western Dig 160 GB EIDE, manufactured 21 Oct. 2004. I left the autodetect in the BIOS set to "auto" where it treats the drive as having 16 heads (not LBA mode).

Why can't the Windows install routine format and see a satisfactory first-stage install? This is going to be necessary to "break out" of this loop where I repeat the first stage forever.

Since booting is very low-level, motherboard drivers will not have been loaded yet. Windows can see that there are no SATA drives. The disk is set for "cable select" and it is plugged in to the "master" plug on the cable. So it *_should_* work.

Why can't the Windows install routine format and see the results of the first stage and proceed? Any help is greatly appreciated.

Edited by saturndude
Link to comment
Share on other sites


Okay, I played with BOOTCFG. I now have two choices:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP 64-bit Professional"

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional x64 Edition" /noexecute=optin /fastdetect

A linux file editor let me push the timeout to 15 seconds instead of 1.

Now, both choices result in the message to reinstall ntoskrnl.exe. I did. Didn't help.

The screen where I choose OS exists on my 32-bit XP, and I never saw it before on my 64-bit. So the 64-bit is now one step closer to working. Any ideas? Thanks in advance.

Edited by saturndude
Link to comment
Share on other sites

Fixed (kind of).

Tried a different disk. XP Pro 64-Bit had no problem installing on a blank 120 GB Seagate Barracuda (7200 RPM). Don't know why.

Both disks appear to have 255 heads, 63 sectors/track, and 16065 * 512 = 8225280 bytes/cylinder. Not sure why there were 16 heads in a previous post. Strange. Anyway, all partitions on both disks end on cylinder boundaries on the 64-bit "target" machine, so there *_should_* not be a problem with either disk.

I ahve no idea why one drive boots and one doesn't. Maybe I'll move the XP 64-bit partition onto the Western Dig later. Maybe I'll reinstall Windows and activate it later, after I get some other stuff finalized.

So I guess you could say it works.

Edited by saturndude
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...