Jump to content

SpyBot Search & Destroy 1.52 Completly Silent Install


cardguy1000
 Share

Recommended Posts

;Install program and update (Should be in same directory as script and named as used below)
RunWait(@ScriptDir & '\spybotsd152.exe /verysilent /components="" /tasks="" /norestart')
RunWait(@ScriptDir & '\spybotsd_includes.exe /S')

;Configure spybot to not show the wizard, legal notice, or update reminder
RegWrite('HKEY_CURRENT_USER\Software\Safer Networking Limited\SpybotSnD', 'WizardRun', 'REG_DWORD', 1)
IniWrite(@AppDataCommonDir & '\Spybot - Search & Destroy\Configuration.ini','Main', 'Legals', 1)
IniWrite(@AppDataCommonDir & '\Spybot - Search & Destroy\Configuration.ini', 'Automation\WebUpdate','RemindUpdate', 0)

;Setup a scheduled task
$adminUsername = 'Administrator'
$adminPassword = 'password'

If _isLaptop() Then
$scanTime = '16:00:00';HH:MM:SS
Else
$scanTime = '04:00:00';HH:MM:SS
EndIf

Run(@ComSpec & " /c " & 'schtasks /create /tn "Spybot Daily Scan" /tr "' & FileGetShortName(@ProgramFilesDir & '\Spybot - Search & Destroy\SpybotSD.exe') & ' /AUTOCHECK /AUTOFIX /AUTOCLOSE" /sc daily /st ' & $scanTime & ' /ru ' & @ComputerName & '\' & $adminUsername &' /rp ' & $adminPassword)

;If there is an internet connection autoupdate and immunize, otherwise just immunize
If Ping('www.google.com') Then
Run(@ProgramFilesDir & '\Spybot - Search & Destroy\SpybotSD.exe /autoimmunize /autoupdate /autoclose')
TrayTip('Updating Definitions', 'Please while the latest Spybot definitions are downloaded', 10)
If WinWait('Information', 'OK',120) Then
ControlClick('Information', 'OK','TButton1')
WinWait('Spybot - Search & Destroy', '&Check for problems')
WinClose('Spybot - Search & Destroy', '&Check for problems')
EndIf
Else
Run(@ProgramFilesDir & '\Spybot - Search & Destroy\SpybotSD.exe /autoimmunize /autoclose')
TrayTip('Error Downloading Updates', 'It appears you are not connected to the internet, skipping detection updates...',5)
Sleep(5000)
EndIf

Func _isLaptop()
$objWMIService = ObjGet("winmgmts:\\" & @ComputerName & "\root\cimv2")
$colChassis = $objWMIService.ExecQuery("Select * from Win32_SystemEnclosure")

For $objChassis In $colChassis
For $ChassisType In $objChassis.ChassisTypes
Switch $ChassisType
Case 8 to 14
Return True
Case Else
Return False
EndSwitch
Next
Next
EndFunc

Edited by cardguy1000
Link to comment
Share on other sites


Why not just use a /silent or /verysilent switch? Both of those work with spybot 1.52. There are some config changes that I personally made so after it installs I just copy a custom made .ini file to the program directory. Can't verify that the code in the OP works but if someone is reading this and needs an alternative to the script, this is always an option.

(for those wondering, it's "Default configuration.ini" and it just goes in the main program file directory for spybot:

[Main]
EasyMode=1
Legals=0
ShowDetails=1
AutoSave=1
CreateBackups=1
CreateTrackBackups=1
CreateSystemBackups=1
CreateSystemRestorePointSpyware=0
CreateSystemRestorePointInternals=0
IgnoreIncludeFileError=1
Confirmation=1
Compability=1
Priority=Normal
RecoveryAged=1

[Main\AlertSounds]
AlertSpyFound=0
AlertNothingFound=0

[Automation\ProgramStart]
AutoCheck=1
AutoFix=1
RerunAfterFix=0
AutoImmunize=0
DontAsk=1
WaitStart=0
WaitPrograms=0
WaitMore=0

[Automation]
SystemStart=NoAutomation

[Automation\SystemStart]
AutoCheck=1
AutoFix=1
WaitStart=0
WaitPrograms=0
WaitMore=0
AutoClose=0

[Automation\WebUpdate]
AutoCheck=0
AutoDownload=1
RemindUpdate=0
CheckBetas=0
CheckAllLanguages=0
CheckSkins=0
CheckSignatures=0
UseProxy=0

[Logfile]
WriteCheckLog=1
WriteFixLog=1
IncludeLogDetails=1
OverwriteLog=0

[Look]
BlindUser=0
DisplayHeader=1
InfoPanelHighlight=0

[BugReport]
UseDefaultMailer=1
IncludeSysInfo=1
IncludeResults=1
IncludeActiveX=1
IncludeBHO=1
IncludeBrowserPages=1
IncludeProcessList=1
IncludeStartup=1
IncludeWinsockLSPs=1
IncludeClipboardText=0
IncludeClipboardImage=0
IncludeSpyFiles=0
CarbonCopy=1

[Expert]
ShredTracks=1
ShredRecovery=1
ShowResultsButtons=0
ShowRecoveryButtons=0

[Expert\Viewer]
HelperUseFiles=0
HelperUseFolders=0
HelperUseRegistry=0

[Filesets]
Spybot - Search & Destroy=1
Security.sbi=1
Malware.sbi=1
QA Tests.sbi=1
Trojans.sbi=1
Hijackers.sbi=1
Keyloggers.sbi=1
Cookies.sbi=1
LSP.sbi=1
Dialer.sbi=1
Temporary.sbi=1
Spybots.sbi=1
Revision.sbi=1

[Durations]
Spybot - Search & Destroy=0
Security.sbi=0
Malware.sbi=0
QA Tests.sbi=0
Trojans.sbi=0
Hijackers.sbi=0
Keyloggers.sbi=0
Cookies.sbi=0
LSP.sbi=0
Dialer.sbi=0
Temporary.sbi=0
Spybots.sbi=0
Revision.sbi=0
Gebrauchsspuren=0
Tracks.uti=0

[Tools.Visibility]
aToolsHosts=0
aOnlineOptOut=0
aToolsViewReport=1
aOnlineBugReport=0
aToolsShredder=1
aToolsResident=1
aToolsActiveX=0
aToolsBHOs=0
aToolsBrowserPages=0
aToolsIETweaks=1
aToolsProcessList=0
aToolsSystemInternals=1
aToolsRun=1
aToolsWinsock=1

Link to comment
Share on other sites

Why not just use a /silent or /verysilent switch? Both of those work with spybot 1.52. There are some config changes that I personally made so after it installs I just copy a custom made .ini file to the program directory. Can't verify that the code in the OP works but if someone is reading this and needs an alternative to the script, this is always an option.

(for those wondering, it's "Default configuration.ini" and it just goes in the main program file directory for spybot:

[Main]
EasyMode=1
Legals=0
ShowDetails=1
AutoSave=1
CreateBackups=1
CreateTrackBackups=1
CreateSystemBackups=1
CreateSystemRestorePointSpyware=0
CreateSystemRestorePointInternals=0
IgnoreIncludeFileError=1
Confirmation=1
Compability=1
Priority=Normal
RecoveryAged=1

[Main\AlertSounds]
AlertSpyFound=0
AlertNothingFound=0

[Automation\ProgramStart]
AutoCheck=1
AutoFix=1
RerunAfterFix=0
AutoImmunize=0
DontAsk=1
WaitStart=0
WaitPrograms=0
WaitMore=0

[Automation]
SystemStart=NoAutomation

[Automation\SystemStart]
AutoCheck=1
AutoFix=1
WaitStart=0
WaitPrograms=0
WaitMore=0
AutoClose=0

[Automation\WebUpdate]
AutoCheck=0
AutoDownload=1
RemindUpdate=0
CheckBetas=0
CheckAllLanguages=0
CheckSkins=0
CheckSignatures=0
UseProxy=0

[Logfile]
WriteCheckLog=1
WriteFixLog=1
IncludeLogDetails=1
OverwriteLog=0

[Look]
BlindUser=0
DisplayHeader=1
InfoPanelHighlight=0

[BugReport]
UseDefaultMailer=1
IncludeSysInfo=1
IncludeResults=1
IncludeActiveX=1
IncludeBHO=1
IncludeBrowserPages=1
IncludeProcessList=1
IncludeStartup=1
IncludeWinsockLSPs=1
IncludeClipboardText=0
IncludeClipboardImage=0
IncludeSpyFiles=0
CarbonCopy=1

[Expert]
ShredTracks=1
ShredRecovery=1
ShowResultsButtons=0
ShowRecoveryButtons=0

[Expert\Viewer]
HelperUseFiles=0
HelperUseFolders=0
HelperUseRegistry=0

[Filesets]
Spybot - Search & Destroy=1
Security.sbi=1
Malware.sbi=1
QA Tests.sbi=1
Trojans.sbi=1
Hijackers.sbi=1
Keyloggers.sbi=1
Cookies.sbi=1
LSP.sbi=1
Dialer.sbi=1
Temporary.sbi=1
Spybots.sbi=1
Revision.sbi=1

[Durations]
Spybot - Search & Destroy=0
Security.sbi=0
Malware.sbi=0
QA Tests.sbi=0
Trojans.sbi=0
Hijackers.sbi=0
Keyloggers.sbi=0
Cookies.sbi=0
LSP.sbi=0
Dialer.sbi=0
Temporary.sbi=0
Spybots.sbi=0
Revision.sbi=0
Gebrauchsspuren=0
Tracks.uti=0

[Tools.Visibility]
aToolsHosts=0
aOnlineOptOut=0
aToolsViewReport=1
aOnlineBugReport=0
aToolsShredder=1
aToolsResident=1
aToolsActiveX=0
aToolsBHOs=0
aToolsBrowserPages=0
aToolsIETweaks=1
aToolsProcessList=0
aToolsSystemInternals=1
aToolsRun=1
aToolsWinsock=1

just liek the idea of the auto immunize

only problem i have is the downlaod part isnt silent

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...