Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


TheRedFox

File Associations in Windows 98SE

Recommended Posts

There's probably already a topic like this, but i searched and didn't find it. So, does anyone happen to know how to change the default program for files of a specific extension to be opened to? In Windows XP, all I have to do is go into properties, but i can't seem to find any similar properties entry in my Windows 98SE. I hope that you can help me. Thank you.

Share this post


Link to post
Share on other sites

You should look at the View - Folder Options - File Types in the Windows Explorer window.

I had to translate the function names from the Polish language. So, the real English names could be different, I'm afraid.

Share this post


Link to post
Share on other sites

I'm finding that many non-music file extensions which are nothing to do with music are being described by my machine as Real Media files.

Edited by celtish

Share this post


Link to post
Share on other sites

I'm running as my default file manager great Total Commander (I've boughted it long time ago). It's easy because under files menu you have function - Associate with.

Edited by rainyd

Share this post


Link to post
Share on other sites

thanks for your help. Total commander looks interesting, but idk if i want to make that drastic a change. as far as the file types go, I can find the menu and it tells which extension opens with which program, but i can't figure out how to change that. any helP?

Share this post


Link to post
Share on other sites

I think the easiest way is to delete the current file extension entry. Then o open a file of the deleted type. Explorer will ask what application you want to open the file with. Choose the right application and enable the checkbox for the explorer to remember the selection.

Share this post


Link to post
Share on other sites
I think the easiest way is to delete the current file extension entry. Then o open a file of the deleted type. Explorer will ask what application you want to open the file with. Choose the right application and enable the checkbox for the explorer to remember the selection.

Not easy enough :) There's no need to delete the file association first. You can right-click on the file while holding the shift key, this will bring up "Open With" in the menu. Make sure that "always use this program to open this type of file" is checked and you have your new file association.

Personally I prefer the method that you mentioned before, filetypes in folder options. Besides managing file-associations you can also edit or create shell extensions and customize icons.

Share this post


Link to post
Share on other sites

Indeed it does work. But, if the cursor is moved after holding down the shift key, right click brings wrong options. So, it is necesary to point hold the shift down, then right click. If by an accident mouse moves by a point, wrong context menu will be displayed.

Edited by Sfor

Share this post


Link to post
Share on other sites

Right click trick part two, improved: :) Select target file first with left click. Now press shift and rightclick and you'll never miss again because your mouse pointer doesn't need to be hovering over your file anymore.

Share this post


Link to post
Share on other sites

It happened to me to move the mouse by a point during the right button clicking.

So, the safest would be to press the shift, then the context menu key (right click) on the keyboard.

Share this post


Link to post
Share on other sites

I knew about the right clicking trick in order to get the open with, but I never before noticed the "change to default" option. lol. unobservant, I guess. I learned the shift trick from windows 95, cause I had a 95 laptop for a bit. I also knew that clicking it first, then holding shift and right clicking was a better idea. thanks for the help. I'm sure many people have learned something useful from this thread.

Share this post


Link to post
Share on other sites

When one uses the "Open With" method to re-associate default file actions a unique entry is made into the registry, but the original entry remains.

original situation

[HKEY_CLASSES_ROOT\.txt]

@="txtfile"

gets paired with:

[HKEY_CLASSES_ROOT\txtfile\shell\open\command]

@="C:\\WINDOWS\\NOTEPAD.EXE %1"

because the default (@) line's entry matches exactly the text after the first backslash in the second group's name.

@="txtfile"

[HKEY_CLASSES_ROOT\txtfile\

txtfile is what the match is made on.

After re-association with Open With app it looks like this:

[HKEY_CLASSES_ROOT\.txt]

@="txt_auto_file"

which then gets paired with:

[HKEY_CLASSES_ROOT\txt_auto_file\shell\open\command]

@="C:\\WINDOWS\\NOTEPAD.EXE %1"

but this entry is not changed and remains in the registry:

[HKEY_CLASSES_ROOT\txtfile\shell\open\command]

@="C:\\WINDOWS\\NOTEPAD.EXE %1"

I'm assuming "txt_auto_file" gets read and acted upon before "txtfile" does and thus the Open With file re-association method works gangbusters.

When you see an entry with _auto_ in it's text you know it was put there by the Open With do hicky. AcDsee does a similar thing with image extentions to the extreme such that I've seen several complaints of broken file associations. Only an install of Irfanview is reported to be able to fix the situation also.

A side note is that the Open With list of programs is generated on the fly by reading of the executables in entries such as this one:

[HKEY_CLASSES_ROOT\txtfile\shell\open\command]

@="C:\\WINDOWS\\NOTEPAD.EXE %1"

only the shell\open\command string is used to create an entry, the path given MUST be in a short file name path with no spaces allowed or the first spaced folder name is used instead of the executable's name. e.g.

@="c:\\proGram files\\myfile.exe %1"

becomes

proGram

entry in Open With list

where

@="c:\\progra~1\\Myfile.exe %1"

becomes

Myfile

entry in Open With list, the period and executable's file extension is dropped.

Note that punctuation is exactly replicated in the list if that's of any real use. Now you know how that PROGRAM entry gets in there. Ever had Windows ask you for the location of PROGRAM? Now you know how it came to be so. For some strange reason it doesn't matter if the path to the default icon is in long file name form or not - that seems to work no matter what. There doesn't have to be a corresponding file extension "chain" for a custom executable to show up in the list, something like this would work all by itself:

[HKEY_CLASSES_ROOT\Myfile_is_the_Bestest\DefaultIcon]

@="c:\\progra~1\\Myfile.exe,0"

[HKEY_CLASSES_ROOT\Myfile_is_the_Bestest\shell\open\command]

@="c:\\progra~1\\Myfile.exe %1"

The Open With list will now include a Myfile executable listing with the proper icon showing.

Share this post


Link to post
Share on other sites
only the shell\open\command string is used to create an entry, the path given MUST be in a short file name path with no spaces allowed or the first spaced folder name is used instead of the executable's name. e.g.

@="c:\\proGram files\\myfile.exe %1"

becomes

proGram

entry in Open With list

You must use double quotes around the path. Then it works fine. Some older programs don't do this, which causes the problem you mention.

Share this post


Link to post
Share on other sites
only the shell\open\command string is used to create an entry, the path given MUST be in a short file name path with no spaces allowed or the first spaced folder name is used instead of the executable's name. e.g.

@="c:\\proGram files\\myfile.exe %1"

becomes

proGram

entry in Open With list

You must use double quotes around the path. Then it works fine. Some older programs don't do this, which causes the problem you mention.

Nope, since double, triple, and even quad quoted strings will still get cut at the space character - I'm thinking it must be the space character that is causing the problem.

Another note of point is when you add double (or more) quotes then that breaks the passed parameter that functions as "%1". No amount of creative quoting will get it working again either. It looks pretty straight forward, but it is NOT. It must be single quoted and there can not be any space characters in the path or you get a folder name in the list and not the executable as I first posted. As best as I can guess it, the dohicky that is reading the path to the executable is somehow 16bit and not able to function with long file names. How or why that could be is beyond my knowledge. Another note, the dohicky is inside the shell32.dll file via dialog box number 1063 and 1070 as seen with ResHacker.

New programs foul up here because this is NOT common enough knowledge, something I was hoping to alleviate to some degree by posting the info here and in the same detail at annoyances.org.

There are not a lot of software writers over there though and only a few here come to think of it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...