Jump to content

WinNT 4.0 & 500GB HDD - does UniATA work?


Recommended Posts


I have installed NT 4.0 on my PC for long years and works fine but I run into trouble with last update of MB and HDD.

Now I have mobo with ICH7 (using IDE mode) and new 500GB SATA HDD. I moved partitions from old HDD and all

my OSes can boot except NT 4.0. For Win98SE I had to update esdi.pdr to have LBA48 support and works fine too.

NT 4.0 just displays a BSOD saying unacessible boot device.

But I found if I move them (and edit boot.ini of course) on slave HDD which is less 128GB they can boot.

So I tried to install UniATA driver. It was installed successfully but when moved back to 500GB disk it still didn't boot :(

I also tried to replace original NT .sys driver by uniata.sys but it hangs during boot.

Anybody was successfull with >128G HDD?

Link to comment
Share on other sites

When I look into control panel/SCSI adapters I can see driver is not running but runs standard ATAPI.SYS. But when i go to control panel/devices and seek for uniata it is set to run on startup and when I tried to startup manually it says driver allready running, so what is true? Probably is not running, fallback to atapi.sys. I tried contact author but no reply.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...