Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
dgames

nLite 1.4.1 - Swapped My Mouse Buttons

Recommended Posts

I used nLite 1.4.1 to build an ISO to install Windows 2003 Server Standard SP@ with integrated hotfixes and not my mouse butons are swapped by default. This occurs during install of the ISO and is the default setting for each user that logs in after install.

I have also tried to build without hotfixes with the same result.

Why did this happen and how can I fix it.

Thanks

Dax

Edited by dgames

Share this post


Link to post
Share on other sites

I found it.

Had "Swap Left and Right Mouse Buttons" checkbox checked under "Visual Effects". Any chance of moving settings like this to a Control Panel sub catagory. It is a bit confusing.

Dax

Share this post


Link to post
Share on other sites

Come on, man, can't you take reponsability for your own blatant mistake and have little laugh at yourself ? "CONFUSING" ? :huh:

Share this post


Link to post
Share on other sites

Is everyone here as friendly as you are? You are correct it was a mistake on my part. :blushing: I did not blame anyone for it, I just asked a question in my first post and made a usability suggestion in the second post.

This is a forum dedicated to nLite isn't it?

The way I see it, I did take resposibility, I did fix it myself, and without any help from anyone here. :thumbup I posted that I fixed it within 15 minutes of my original post so no one would waste time looking at it or responding to my post.

Not bad for someone who just found nLite today has already built several ISOs with it and thinks it is pretty freaking awesome! Pretty freaking Awesome can always be better and products are generally improved by developers listening to and implementing user suggestions.

The reason it took me a while to find it is because it IS confusing to have mouse settings to swap primary and secondary buttons down under visual effects.

If it were under sub category Control Panel->Mouse I would have found it in about two seconds and not posted. Instead I had to expand each and every Tweaks level and look at each and evry checkbox/radio button until I finally got to the one that mattered under visual effects.

Share this post


Link to post
Share on other sites

@dgames

Good you found your solution! Infact many of us get stuck in the endless registry tweaks and get crazy. I think best part is you found the solution otherwise till someone answered it you might have made many other installs.

Welcome ot msfn!

Share this post


Link to post
Share on other sites

.. it IS confusing to have mouse settings to swap primary and secondary buttons down under visual effects.

If it were under sub category Control Panel->Mouse I would have found it in about two seconds and not posted...

I agree this mouse button control is in an awkward place.

I also had the issue with the switched buttons today.

Problem: I want to switch off every visual effect, but keep mouse buttons normal.

In one session I made the mistake to select 'all visual effects off'.

This resulted of course in switched buttons.

To correct the button settings, what should I set the controls to, in the next session?

Selecting all but 'mouse button' did not work.

Or should I start all over?

Thanks for an answer

kind regards

Eveline

Share this post


Link to post
Share on other sites

I agree this mouse button control is in an awkward place.

I also had the issue with the switched buttons today.

Problem: I want to switch off every visual effect, but keep mouse buttons normal.

In one session I made the mistake to select 'all visual effects off'.

This resulted of course in switched buttons.

To correct the button settings, what should I set the controls to, in the next session?

Selecting all but 'mouse button' did not work.

Or should I start all over?

Thanks for an answer

kind regards

Eveline

ebernard, without your Last Session.ini we would only be guessing. So, please attach it as requested in BOLD RED letters above. Enjoy, John.

Share this post


Link to post
Share on other sites
ebernard, without your Last Session.ini we would only be guessing. So, please attach it as requested in BOLD RED letters above. Enjoy, John.

Thanks for your answer.

I'm sorry. Of course.

See attached Zip.

The first *.INI file contains:

Vormgeving Uitschakelen-Swap left and right mouse buttons

The buttons were swapped.

The second Nlite session was executed on the result of the first session.

The *.INI file contains:

Vormgeving Uitschakelen-Active window tracking-Uitschakelen
Vormgeving Uitschakelen-Animate windows when minimizing and maximizing-Uitschakelen
Vormgeving Uitschakelen-Combo box animation-Uitschakelen
Vormgeving Uitschakelen-Cursor shadow-Uitschakelen
Vormgeving Uitschakelen-Display mouse pointer trails-Uitschakelen
Vormgeving Uitschakelen-Fade out selection-Uitschakelen
Vormgeving Uitschakelen-Gradient captions in windows-Uitschakelen
Vormgeving Uitschakelen-Keyboard shortcut underline-Uitschakelen
Vormgeving Uitschakelen-Menu animation-Uitschakelen
Vormgeving Uitschakelen-Menu shadows-Uitschakelen
Vormgeving Uitschakelen-Menu style-Normaal
Vormgeving Uitschakelen-Show translucent selection rectangle-Uitschakelen
Vormgeving Uitschakelen-Show window contents while dragging-Uitschakelen
Vormgeving Uitschakelen-Slide taskbar buttons-Uitschakelen
Vormgeving Uitschakelen-Smooth edges of screen fonts-Uitgeschakeld
Vormgeving Uitschakelen-Smooth-scroll list boxes-Uitschakelen
Vormgeving Uitschakelen-Tooltip animation-Uitschakelen
Vormgeving Uitschakelen-Use a background image for each folder type-Uitschakelen
Vormgeving Uitschakelen-Use drop shadows for icon labels on the desktop-Uitschakelen

The result still had the buttons swapped.

Obviously, I misunderstood the program's controls.

Thanks for your effort

kind regards

LastSessions_MouseButtonProblem.zip

Share this post


Link to post
Share on other sites

Thanks for your answer.

I'm sorry. Of course.

See attached Zip.

The first *.INI file contains:

Vormgeving Uitschakelen-Swap left and right mouse buttons

The buttons were swapped.

The second Nlite session was executed on the result of the first session.

ebernard, thanks for the Last Session.ini and thanks much for the translation. In general, we do not need to see the _U.ini, but I see you have removed the key and other private data, so OK. Did you start with a fresh copy of your CD files/folders on your second run. If not you were asking for unpredictable results. Always start with a fresh copy of your CD files/folders and run nLite only one time doing all your work. I also see you are running nLite under W2000. I don't suspect that this is a problem but it is a problem running nLite under Vista (or W7) and integrating a Service Pact. I do not think nLite should have swapped your mouse buttons if not told to do so. Unfortunately nuhi (nLite owner/author) has not participated here in over a year, so any problems found (very few) must be worked around. Please let us know about your starting point and we'll go from there. Enjoy, john.

Share this post


Link to post
Share on other sites

Thank you, John,

ebernard, thanks for the Last Session.ini and thanks much for the translation. In general, we do not need to see the _U.ini, but I see you have removed the key and other private data, so OK. Did you start with a fresh copy of your CD files/folders on your second run. If not you were asking for unpredictable results. Always start with a fresh copy of your CD files/folders and run nLite only one time doing all your work. I also see you are running nLite under W2000. I don't suspect that this is a problem but it is a problem running nLite under Vista (or W7) and integrating a Service Pact. I do not think nLite should have swapped your mouse buttons if not told to do so. Unfortunately nuhi (nLite owner/author) has not participated here in over a year, so any problems found (very few) must be worked around. Please let us know about your starting point and we'll go from there. Enjoy, john.

Thanks for making my mistake clear. I used the result of the first session as the source for the second session.

The first session contained:

Vormgeving Uitschakelen-Swap left and right mouse buttons

while the second session contained all but "Swap left and right mouse buttons" from that same section.

Not using a "clean" source must be the cause of the unexpected result: the mouse buttons remained swapped.

The problem was gone once I used a "clean" source.

Thanks for your effort and patience

kind regards

Eveline

Share this post


Link to post
Share on other sites

Thank you, John,

Not using a "clean" source must be the cause of the unexpected result: the mouse buttons remained swapped.

The problem was gone once I used a "clean" source.

Thanks for your effort and patience

kind regards

Eveline

ebernard, great. Glad I could help. Unfortunately this is a common problem in nLite. Enjoy, John.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...