Jump to content

Buffer overflow when loading slipstreamed SP1

Grope For Luna

Recommended Posts

When loading the files for the slipstreamed Vista SP1 release (just after selecting the OS type) , it freezes and won't quit unless I reboot. I opened Process monitor to see what was going on and I noticed a humungous number of buffer overflow errors (PM was freezing, using 1.5Gb memory) like the following:

Sequence: 112999

Date & Time: 2/10/2008 6:28:47 PM

Event Class: File System

Operation: QueryNameInformationFile


Path: C:\Temp\\Temp\vsTemp19\Windows\System32\config\SOFTWARE{00000001-8c96-0009-0000-000000000000}.TMContainer00000000000000000001.regtrans-ms

TID: 4012

Duration: 0.0000047


The problem seems to be with that file. I tried it in my other 2008 Server installation with v1.1 and 1.1.1 and got the same result.

Link to comment
Share on other sites

I'm only using Windows Advanced Firewall which doesn't have process protection and Antivir. I turned off most everything I could (services and drivers) but still got the same result.

This is not the first time I've had freezing at this stage of the process. Most, if not all, previous vlite versions have frozen when loading the OS for the first time (which is why I was looking for a way to terminate it in the other thread). After rebooting, however, it would load and work fine. This time, it won't work at all and continues to freeze.

Link to comment
Share on other sites

I just tried it on my x64 installation and it works, so it's probably a problem with running on 2008 Server or something peculiar to my install.

The file selection dialog (for choosing a directory) doesn't show up though, so I had to manually enter the path.


Link to comment
Share on other sites

Your OS is somehow broken, that browse windows looking like that means that some of your classes in the registry and/or dlls could be of wrong version or missing.

But I will check if maybe some option is doing that. How did you set your Server, any tight policies, what Role is it?

Edited by nuhi
Link to comment
Share on other sites

I rarely use the x64 installation but I haven't noticed any problems previously. I just installed DotNET today so maybe it didn't install properly.

Server (RC1) settings are basically default. The only installed role is File Services (Windows Search and File Server).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...