Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Error: could not locate INF file


zedox
 Share

Recommended Posts

I will test that out and let you know what happens. In the mean time though I made a change to the host OS detection code so that it properly recognizes Windows XP x64 as Windows XP instead of unrecognized. This should make HFSLIP completely compatible with Windows XP Pro x64 edition as a host OS. I have made several boot disks from my x64 host computer and it works properly other than this inf issue which is probably related to my source files as they were modified by Dell. Here is the new host OS detection code, check it out and let me know if you are going to include it in a future release :)

:: Find host OS - based on code posted by Yzöwl on MSFN.org

SET HostOS=Unknown

FOR /F "DELIMS=" %%I IN ('NET CONFIG WORK^|FIND /I " Windows "') DO (

ECHO %%I|FIND "2000">NUL 2>&1&&(SET HostOS=2000&GOTO :HOSD)

ECHO %%I|FIND "2002">NUL 2>&1&&(SET HostOS=XP&GOTO :HOSD)

ECHO %%I|FIND "XP">NUL 2>&1&&(SET HostOS=XP&GOTO :HOSD)

ECHO %%I|FIND "2003">NUL 2>&1&&(SET HostOS=2003&GOTO :HOSD)

ECHO %%I|FIND /I "Vista">NUL 2>&1&&(SET HostOS=Vista&GOTO :HOSD)

)

It is this line of code that detects Windows XP x64

ECHO %%I|FIND "XP">NUL 2>&1&&(SET HostOS=XP&GOTO :HOSD)

When you run NET CONFIG WORK from an XP x86 system it returns Windows 2002

When you run it from an XP x64 system it returns Microsoft Windows XP

Here is the log file showing that my OS detection modification code worked properly. This was run on my Windows XP x64 system, and the host OS now shows XP instead of unrecognized.

HFSLIP.zip

Edited by mserbin
Link to comment
Share on other sites


Thanks for the lines of code. I'll roll that into the next beta. :thumbup

Just remove the svcpack.in_. Leave the svcpack.dl_ alone. Also, open txtsetup.sif and look for svcpack.inf. Put as ; [semicolon] before that line. Rerun the script. Remember, these are test cases and you'll need to recopy the source folder once again if this doesn't work out well. IIRC, I've seen a few dell cd's that put some KB (i.e. hotfixes) into the i386 folder. You can probably delete them too, along with the apprioriate entry in txtsetup.sif.

Link to comment
Share on other sites

I found the problem. It is not with the svcpack.in_ file it is with the txtsetup.sif file.

Dell defines a custom folder in this line

999 = pchealth\helpctr\batch

And those inf files are being copied there instead of c:\windows\hfslip which is supposed to be referenced by folder number 999 in this line

HFSLP151.INF = 1,,,,,,,999,0,0

Therefore, I will edit this line:

[WinntDirectories]

998 = HFSLIP

Then just update all the inf entries to be like:

HFSLP151.INF = 1,,,,,,,998,0,0

HFSLP152.INF = 1,,,,,,,998,0,0

etc....

I will test this out and let you know if it works. This is finally the answer though for the guy that started this forum a long time ago :)

Edited by mserbin
Link to comment
Share on other sites

And actually, if we modify the hfslip.cmd so that it uses folder number 998 instead of 999 it will avoid the Dell disk conflict entirely. This is too many lines of code to give you to update here, but if you do a search for the number 999 in the hfslip.cmd file and replace them with 998 it should do the trick. This could also be included in the next beta. Here is the edited cmd file that contain both of my fixes.

hfslip_1.7.9_beta_t.zip

Edited by mserbin
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...