Jump to content

Fatal Error at T-39


Recommended Posts


I am getting the following error during T-39, about 15 seconds into it before any devices or network is installed:


SXS.DLL: Syntax error in manifest or policy file "D:\i386\asms\10\MSFT\WINDOWS\GDIPLUS\GDIPLUS.MAN" on line 4.

Any idea what this means? It stops the install in its tracks, reboots, and does it again. Here is the contents of GDIPLUS.MAN:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
<assemblyIdentity type="win32" name="Microsoft.Windows.GdiPlus" version="1.0.2600.2180" processorArchitecture="x86" publicKeyToken="6595b64144ccf1df"/>
<file name="GdiPlus.dll" hash="7c911766c2ebe993a520bbd53395d9cd5b115271" hashalg="SHA1"/>

The install works perfectly on Virtual Machine, but this error keeps popping up on a live test. I also can't find sxs.dll on the install CD. Does it extract into system32 or something?

Here is my winnt.sif:








Profiles = WindowsFirewall.TurnOffFirewall

Mode = 0


I am frustrated at this point, I havn't gotten anything like this in the few unattendeds that I've run.



Link to comment
Share on other sites

Thanks for the reponse Iceman,

The VM was not using a network connection. The only difference between the two is hardware. I read that this is quite a popular problem even with brand new retail XP discs. Is it possible for a corrupt file to halt a machine but go unnoticed in a VM? I really don't want to re-slipstream all my updates again :(

Link to comment
Share on other sites

The only issues I personally have ever run into is that as by design the VM does not install the actual physical hardware drivers of the host machine.

You might try it without the network and see what happens.

Link to comment
Share on other sites

Post what you are using to create your disks. I've run into this, I'm trying to remember what the deal was. All I can think of at the moment is Bad Disk. But I'm still trying to be sure of that. I'm not having that problem anymore.

Link to comment
Share on other sites

I just reviewed my IM history of the conversation I had with my cousin about this who is the Dev. for RVM Integrator & the PowerPacker.

We were bouncing ideas off each other trying to figure it out until I finally decided to hand it over to the company we buy computers from, since I don't have the extra hardware at work to swap out parts usually. I was focusing my attention mainly on software and testing hardware, but none of the hardware tests complained of the CPU.

I'll add that this computer was experiencing errors in Windows beforehand about running low on virtual memory.

It turned out to be the CPU was just bad enough that the computer was sometimes usable. When I tried reloading Windows I would get different errors at different times, but it started with the T-39 error repetitively. Once the processor was changed out Windows loaded with no further problems. Keep in mind that I had loaded Windows XP on this computer twice previously, the first was when we received the computer and the second was after the user was complaining of the low virtual memory errors and I couldn't figure out for the life of me what was causing it (I have experience in fixing these errors otherwise). The computer vendor we use had a very tough time with it also, it took a few days for them to decide to swap out the processor (Intel Core 2 DUO running on an Intel Desktop board)

Check your memory first to make sure you're not having memory problems.

SXS.DLL is used to verify the Manifest of the system files to make sure what is copied over to the hard disk is copied correctly. A bad CD/DVD drive I suppose could also cause these errors, but you'd probably run into problem just booting up to the disk in that case.

Edited by VCC
Link to comment
Share on other sites

I'm using CDIMAGE to compile, and a CD-RW to record via Nero (disk-at-once). The CD-RW "may" be the cause since I heard you're only supposed to use CDR. But I recompiled and burned it a second time at 4x and slow-formatted the drive and got the same error - a little too consistant for a bad disk. I successfully loaded a fresh XP disk onto the computer a couple weeks ago, so I hope it's not a hardware issue; but that would explain it working on a VM.

I'll test out the memory and perhaps try on a second test computer and see what happens. (I disabled networking with no success).

Thanks for all the info! I'll let you know what I find out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...