Jump to content

Creative Zen Sleek connecting problem?


BigB42078
 Share

Recommended Posts

I have tried everything to get my dad's Creative Labs Zen Sleek to connect to the pc and I can't get it to. It will only come up as unkown device under the universal usb controllers. I have tried uninstalling windows media player and reinstalling it, nothing. Tried opening the permissions to the everyone user profile in the registry, nothing. Any suggestions would be greatly be appreciated. I have read through the creative forums and have not been able to find a resolution. They say Creative mostly blames Microsoft for the problem when you call. And they also charge like $13 for a half hour to basically tell you that. :realmad:

I am really considering never buying another Creative Labs product, this is ridiculous.

Windows XP Home

Asus P4B

ATI 9800 xt

512 MB ram

Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...