Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
chon_

Create a User and set it to autologon

Recommended Posts

I need to create a new user named Propietario with WSIM that is a member of the Administrators group and set it to autologon (in order to hide te Adminstrator account) after I installed my apps in Pass 6 Audit User.

I've been messing around with it but I can`t get it to work :(

What can I do??? :blink:

The way I did it in XP was running the following CMD file:

net user Propietario /add
net localgroup Administradores Propietario /add
net accounts /maxpwage:unlimited
reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v "DefaultUserName" /d "Propietario" /f
reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v "DefaultPassword" /d "" /f
rem reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v "AutoAdminLogon" /d "1" /f

This worked OK in XP, but seems like it doesn't work in vista (I've been running this cmd file in Pass 6 too).

Thanks in advance

Share this post


Link to post
Share on other sites

have you tried running your command file in a working install of windows to see if it works correctly at all under vista?

Otherwise, this is something you would need to do in your autounattend file.

Share this post


Link to post
Share on other sites

add the user information in the unattended file...

it is not valid for pass 6.. only pass 5 and 7

e.g

<settings pass="auditSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<UserAccounts>

<LocalAccounts>

<LocalAccount wcm:action="add">

<Password>

<Value>UABhAHMAcwB3AG8AcgBkAFAAYQBzAHMAdwBvAHIAZAA=</Value>

<PlainText>false</PlainText>

</Password>

<Name>Username</Name>

<Group>Administrators</Group>

<DisplayName>Username</DisplayName>

<Description>Description</Description>

</LocalAccount>

</LocalAccounts>

</UserAccounts>

</component>

</settings>

Share this post


Link to post
Share on other sites

@Atheros

Trying it now, in pass 7...

I'll let you know

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...