Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


galahs

Compatible Hardware with Windows 9x

Recommended Posts

Let's try to keep the discussion here on topic and relevant to Windows 9x. This is not the place to be discussing anything and everything from XP to Windows 10, especially things which will never remotely be compatible or useful to a 9x system. These newer operating systems have their own forums. I realize many users (including myself) create multi-boot systems, but discussion of the other OS'es should go in their respective forums.

Share this post


Link to post
Share on other sites

Anyone know about compatible ATI GPUs or drivers under Windows 95? i know in 98/98SE/ME, anything up to X800/X850 can be made to work, but i'm not sure about 95 and can't find much about ATI Radeon support in 95

Share this post


Link to post
Share on other sites
1 hour ago, Carlos S. M. said:

Anyone know about compatible ATI GPUs or drivers under Windows 95? i know in 98/98SE/ME, anything up to X800/X850 can be made to work, but i'm not sure about 95 and can't find much about ATI Radeon support in 95

The ATi Radeon 8500 works in Windows 95 according to @LoneCrusader, and apparently the same applies for the Radeon 9200. I'd like to say that 7xxx/8xxx/9000/9200/9500/9700 Radeons work, since they are listed as compatible with supposedly 95-compatible drivers from 2002.

But my Mobility Radeon 7500 just boots to a blank screen with any 95-compatible driver installed.

Share this post


Link to post
Share on other sites
2 hours ago, win32 said:

The ATi Radeon 8500 works in Windows 95 according to @LoneCrusader, and apparently the same applies for the Radeon 9200. I'd like to say that 7xxx/8xxx/9000/9200/9500/9700 Radeons work, since they are listed as compatible with supposedly 95-compatible drivers from 2002.

But my Mobility Radeon 7500 just boots to a blank screen with any 95-compatible driver installed.

Maybe i didnt find the right driver but my radeon 9250 never worked on my win95C machine. drivers couldnt start or didnt install.

Share this post


Link to post
Share on other sites
23 minutes ago, i430VX said:

Maybe i didnt find the right driver but my radeon 9250 never worked on my win95C machine. drivers couldnt start or didnt install.

These were the drivers I was thinking of:

http://web.archive.org/web/20030312015545/http://link-empire.servebeer.com/files/omega/Ati/rad_w9x_omega_2576.exe

Released December 2002, so they reference the earlier R200 cards like the Radeon 9000. But your card was released in July 2004. Maybe there were minor changes that could have made the older drivers unusable?

Yet, since it boots to a blank screen instead of producing a blue screen or just not starting with one of the user-mode components complaining about the lack of EnumDisplayMonitors, I thought that somehow that one would work better with Windows 95 than drivers from 2003 or 4.

Share this post


Link to post
Share on other sites
27 minutes ago, win32 said:

These were the drivers I was thinking of:

http://web.archive.org/web/20030312015545/http://link-empire.servebeer.com/files/omega/Ati/rad_w9x_omega_2576.exe

Released December 2002, so they reference the earlier R200 cards like the Radeon 9000. But your card was released in July 2004. Maybe there were minor changes that could have made the older drivers unusable?

Yet, since it boots to a blank screen instead of producing a blue screen or just not starting with one of the user-mode components complaining about the lack of EnumDisplayMonitors, I thought that somehow that one would work better with Windows 95 than drivers from 2003 or 4.

I cannot specifically remember versions i tried. Sometime I'll throw the card back in a win95 box and get back to you on if it works or not with that one.

Share this post


Link to post
Share on other sites
On 5/26/2020 at 6:25 PM, win32 said:

The ATi Radeon 8500 works in Windows 95 according to @LoneCrusader, and apparently the same applies for the Radeon 9200. I'd like to say that 7xxx/8xxx/9000/9200/9500/9700 Radeons work, since they are listed as compatible with supposedly 95-compatible drivers from 2002.

But my Mobility Radeon 7500 just boots to a blank screen with any 95-compatible driver installed.

which driver version did you use for your mobility radeon 7500? also do you know the full hardware id or partial? for "PCI\VEN_1002&DEV_4C57&SUBSYS_B730156D", you can use driver version 4.13.9009. i don't remember the full hardware id of the gpu i used, but i did get the mobility radeon 7500 working on windows 95 using version 4.13.9009. it might be also possible to get the mobility radeon m6 gpu working (  PCI\VEN_1002&DEV_4C59 ) if you were to install it with the 4.13.9009 driver that's for the mobility radeon 7500. reason why is because for some reason, on 98SE, the hardware id identifies as  PCI\VEN_1002&DEV_4C57, but on windows 95, it's  PCI\VEN_1002&DEV_4C59.

Share this post


Link to post
Share on other sites
On 5/26/2020 at 8:21 PM, Carlos S. M. said:

Anyone know about compatible ATI GPUs or drivers under Windows 95? i know in 98/98SE/ME, anything up to X800/X850 can be made to work, but i'm not sure about 95 and can't find much about ATI Radeon support in 95

It's been a long time since I worked with ATI cards and Windows 95, other than some experiments with an XP-era laptop (Mobility Radeon) which produced very weird results and I never solved the issues.

As someone else pointed out above, I know for a fact that the Radeon 8500 does work fine under 95; I have the drivers CDROM that came with one and have used it. IIRC, the 9250 had a working package as well.

Since the last 98 driver is of course still a VXD, then theoretically it should work under 95 as well, and thus theoretically all the same cards working under 98 should work under 95. There may be other incompatibilities or dependencies though. The Control Panels/SysTray shortcuts and such will definitely not work under 95.

Share this post


Link to post
Share on other sites

AMD 785g, Onboard LAN working, in windows ME.  USB2.0 ports, PS/2 ports, pci and pcie slots.  onboard SATA kinda works (in IDE mode it runs in msdos compatibility mode as a generic storage controller) fix with promise ATA133 pci card and PATA IDE ATA133 SSD.  onboard video is sufficient for setup (16 color 640x480) (Fix with X300 series pcie or PCi 7000)  onboard audio is hdac97, so fix with soundblaster pci.

(DO NOT connect cdrom to the ATA133 PCI card, except during initial install. it slows the card terribly and will horribly bottleneck the SSD.)
Complete the install then disconnect cdrom, connect a wireless AC to gigabit ethernet bridge to the LAN port with a length of cat6, and install all updates and hotfixes, then install a usb DVD drive to have a working optical drive. 

Disable onboard gpu and AC97 hdaudio in bios to free up IRQ's, make sure boot mode is set to legacy BIOS only, and install only a single 1gb stick (or 512m if anyone makes one) of ddr3.  use an OPTERON CPU.  A FX series chip might work but have not tested that. I only tested this with an Opteron 3380 as I have water cooling and it is a real pain to take it all off and unmount the mb just to swap cpu's.   Limit memory with setup switches as usual, then edit system INI appropriately once install is complete.  make sure all usb controllers are set to legacy usb support, and 2,0 mode with 1.1 compatibility fallback enabled.  use a DVI converter to get HDMI out from the card's DVI port.  (video only no audio) and connect external speakers to the soundblaster PCI card. 

what doesnt work: USB3.0, HDac97 audio, onboard Radeon HD8xxx graphics (except basic 16 color mode) R9 390x (replaced it with PCIe x300 series)  SATAIII (set to IDE mode it sort of works, generic IDE controller in msdos compatibility mode).  Cool and Quiet.  (Use K8 powernow driver to get it working). and of course, only one core is used.

  • Like 2

Share this post


Link to post
Share on other sites

Hello all,

just want to report getting an Edimax EW-7728ln wireless card to work on windows 98se using the rt26809x.sys driver. I have not gotten 802.11n working, and I haven't been able to get speeds higher than 3Mbps, though, which is very frustrating. hope someone else has advice or experience

cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...