Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Legolash2o

Installing Vista Service Pack?

Recommended Posts

i've updated the error codes in the first post, that specific one is just click try again (also try restarting if that doesn't work)

Share this post


Link to post
Share on other sites

Has anyone tried the MS beta Vista with SP1 integrated and then vlited that? I just did and it seems to be working fine! In fact its much faster than my nlited xp so far? Any suggestions on this method ?

Share this post


Link to post
Share on other sites

Yep Vista x64 Ultimate SP1 Beta with all x64 updates.. Works like a dream much better than without SP1 Beta. what you mean by 'Any Suggestions on this method?' do you mean a suggestion of how to integrate it, how to use vlite on it, etc...?

Edited by legolash2o

Share this post


Link to post
Share on other sites
Yep Vista x64 Ultimate SP1 Beta with all x64 updates.. Works like a dream much better than without SP1 Beta. what you mean by 'Any Suggestions on this method?' do you mean a suggestion of how to integrate it, how to use vlite on it, etc...?

Well I guess what I am asking is if someone can get vista with the sp1 integrated, and use vlite then they wont have alll these post sp1 issues or other integration issues talked about in this post. I guess like Nuhi says once the newer Vista cds ship, they should have SP1 integrated so vlite should work fine at that point!!

Share this post


Link to post
Share on other sites
Has anyone tried the MS beta Vista with SP1 integrated and then vlited that?

Yes. I just obtained a copy of Visa (32 bit) with the SP1 beta v658 integrated. I ran vLite on it and it installed fine.

Share this post


Link to post
Share on other sites

Offline Files mustn't be removed because the SP1 installer requires it (I have monitored the installer with Process Monitor and he hang up on searching related cscapi.dll)....error code 0x80070002 in standalone mode (trhough windows update, the error code is different).

ehm...can someone with full Vista send cscapi.dll from System32 for trying again?

Share this post


Link to post
Share on other sites

Dokugogagoji, vLite doesn't remove that, it's just a file of a control which failed because it expected some file.

Share this post


Link to post
Share on other sites

it's quite strange... I have taken cscapi.dll from a non-vlited Business Vista (i don't have original DVD because my version is licensed MSDN-AA so the data files are in my university site...and I have to download Windows AIK) and in the Details, it says Offline Files Win32 API. I have removed with vLite Offline Files feature and in my installation, there isn't it. at first, I have tried to create a dummy cscapi.dll in windows\system32 folder and I started again the installation. it said the cscapi.dll is invalid...so it's looking for it.

Probably, I have select too many option, lol... However I have add the file but the installation doesn't complete because it seems to require Terminal Service by looking in Event Register. I'll try to integrate this service manually and I'll try again the installation.

Share this post


Link to post
Share on other sites

Oh pardon me, I mixed up cbscore.dll with cscapi.dll, thought that they are both belonging to the same offline package integration engine, while this which you mentioned is a part Offline Files component as you stated.

Anyway you will only find that SP wants more and more kept so that eventually you keep all components for it to work. Install on full or do that capture thing and you have fully working preintegrated SP which can be trimmed. Or wait for MS to integrate it. I am sorry that it can't be installed on a lite version but it's not really a surprise since it's a giant hotfix for the whole Vista.

Share this post


Link to post
Share on other sites
After the SP1 update, some of my registry software (registry snap, registry search & replace) cannot work properly (they read Wow6432Node in an infinite loop) due these lines added by SP1 in the registry :
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Wow6432Node]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Wow6432Node\Microsoft]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Wow6432Node\Microsoft\Rpc]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Wow6432Node\Microsoft\Rpc\SecurityService]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Wow6432Node\Microsoft\Windows]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Wow6432Node\Microsoft\Windows\CurrentVersion]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths\IEXPLORE.EXE]

If i delete them all my registry software work well again, and Vista work like a charm without these lines !!

Can anyone confirm that deleting these does no harm? It seems that all registry cleaners end up in strange loops with those entries. Pretty pathetic from Microsoft, to have a bug like that in a full-blown OS like Vista.

Yet another reason why vista sucks.

Share this post


Link to post
Share on other sites
Can anyone confirm that deleting these does no harm? It seems that all registry cleaners end up in strange loops with those entries. Pretty pathetic from Microsoft, to have a bug like that in a full-blown OS like Vista.

Yet another reason why vista sucks.

I can confirm it will not harm. Read here: http://www.msfn.org/board/registry-Wow6432Node-after-sp1-t121898.html , in short line: HKLM -> SOFTWARE -> wow6432node -> wow6432node (-> microsoft..windows.. etc ..iexplore.exe)just delete the last wow6432node...

It's true that even Windows Live OneCare safety scanner have a huge loop because of this, i'm agree with you that this is pathetic, and untill now i wasn't found what is the cause of this bad entries and how to avoid this, but now i know how to fix this. I can not say vista sucks because of this...it's not perfect, but is much better than xp, xp give me much more headache. My only complaint is the size and inability to remove unused features, this was fixed thanks to Nuhi.After one year with vista ultimate 64 without any blue screen or any major problemm i say: i will never go back to xp, but you are free to make the change if you feel like this. I really can't understand all the negative advertising against vista, at the beginning i was influenced by this, but i say to give a try and i don't regrete this any second. After few tests with vlite i finaly make vista how i wish.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...