Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


mannyo

Strange SATA Hard disk behaviour

Recommended Posts

This is a strange one,

I have vista installed with all the updates installed, including todays updates.

Brief hardware list.

The PC has 3 hard drives installed, say C:, D: and E:

The O/S is installed on C:, the paging file is on E:, D: and E: have my data shared between them.

The drives are all Hitachi Deskstars.

The motherboard is based on the intel 965 chipset and the SATA controllers show in device manager as ICH8 based.

I have 2GB ram and an intel quad core Q6600 CPU. There is also an Nvidia Geforce 8 series PCIex graphics card.

And the problem, I cant work around.

I am having problems with power management. The Bios is set so that the powerdown is disabled, and in Vista power management I am running the High performance profile, with the hard drive setting configured to powerdown afer 20 mins. The problem is they dont stay powered up that long. The drives all run fine as long as data is being accessed, but as soon as I say stop playing an MP3 file the drive spins down about 15 seconds after the data flow stops. This applies to D: and E:, C: seems unaffected.

I have downloaded the acoustic management software from Hitachis website and run that, and everything is disabled with regard to power management on the drive itself. I didnt think it would be that beause the same drives under XP had no problems. I also tried the inf update from intels website, but the problem remains.

Are there any more upto date drivers for the ICH8 controller, other than the microsoft ones that ship with Vista. The inf update changed something as the drivers are now shown as intel, but the files themselves are still all MS provided.

So to sum up, my vista experience is a bit slow and clunky at the moment because I keep having to wait for the drives to spin up.

Edited by mannyo

Share this post


Link to post
Share on other sites

Replying to my own post,

I still have the problem, as do many but at least with hitachi drives there seems to be a workaround of sorts.

I loaded the acoustic management software cd and enabled the power management settings, and set it to "Low power idle". What this seems o do, is when vista tells the drive to spin down, it doesnt, instead it switches to what seems to be a lower RPM so now when the drive wakes up I dont have to wait so long for the system to respond. Just need MS to fix vista now.

Share this post


Link to post
Share on other sites

Why not just set it to not shut the HDDs off for say, 400 minutes? I do that, used to have this silly spinning up and down as well.

Share this post


Link to post
Share on other sites

Read the thread I already linked to, people are having this problem who have completely disabled the "Turn off hard disks after" option in Power Options.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...