Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Leaderboard


Popular Content

Showing content with the highest reputation since 09/24/2020 in all areas

  1. 5 points
    New build of Serpent/UXP for XP! Test binary: Win32 https://o.rths.ml/basilisk/basilisk52-g4.6.win32-git-20200926-ef27fbe-uxp-e0bda2246-xpmod.7z Win64 https://o.rths.ml/basilisk/basilisk52-g4.6.win64-git-20200926-ef27fbe-uxp-e0bda2246-xpmod.7z source code that is comparable to my current working tree is available here: https://github.com/roytam1/UXP/commits/custom IA32 Win32 https://o.rths.ml/basilisk/basilisk52-g4.6.win32-git-20200926-ef27fbe-uxp-e0bda2246-xpmod-ia32.7z source code that is comparable to my current working tree is available here: https://github.com/roytam1/UXP/commits/ia32 NM28XP build: Win32 https://o.rths.ml/palemoon/palemoon-28.10.2a1.win32-git-20200926-9f56811e0-uxp-e0bda2246-xpmod.7z Win64 https://o.rths.ml/palemoon/palemoon-28.10.2a1.win64-git-20200926-9f56811e0-uxp-e0bda2246-xpmod.7z Official UXP changes since my last build: - Isse #1224 - revert change to unbust debug builds. (5ad0a15f6) - [no issue] Fix whitespace (no code change) (04ccc4b12) - [SVG] Only fire the SVG onload when scripting is enabled and allowed (4d999e03a) - [dom/media] Use an atomic for mInputDeviceID to avoid potential race (aecdb2830) - [webaudio] Keep track of whether the HRTF database has already been loaded. (f5e5b5c32) - Issue #1655: Update MediaQueryList to the current draft spec. (388b9c802) - Output webidl filenames as they are processed, for real this time. (c14e7d70f) - Issue #1656 - Part 1: Nuke most vim config lines in the tree. (a680bdc63) - Issue #1656 - Part 2: Unmangle some unfortunate UTF-8 victims. (7572f3718) - Issue #1656 - Part 2b: Unmangle one more lost little UTF-8 victim. (5d97621bb) - Issue #1656 - Part 3: Nuke more vim config lines in the tree. (528b88d70) - Issue #1656 - Part 4: Tackle *.idl, *.css, *.ipdlh, *.webidl, *.cc (18ea98f7a) - Issue #1656 - Part 4: Manual cleanup (7523b9ea0) - Issue #1656 - Part 6: Clean up the build files (d5a2c45aa) - Issue #1656 - Part 7: Nuke vim config lines in JS (0c3bd2b10) - Issue #1656 - Part 8: Devtools and misc. (4a42352e6) - Issue #1656 - Part 9: Single-line-comment style. (6b9f2095a) - Issue #1656 - Part 10: Manual cleanup. (e0bda2246) Official Basilisk changes since my last build: - [downloads] Stop using referrers as sources (ef27fbe) Official Pale-Moon changes since my last build: - Back-end branch pointer update (unstable 2020-09-18) (b4943fc3c) - Issue #1744 - Add pref to ask for master password on application start. (04cd94da7) - [no issue] Whitespace fixes. No code change. (19f9cd83c) - [downloads] Stop using referrers as sources. (9f56811e0)
  2. 4 points
    All ~1810 functions in Vista's ntdll are exported from ntext and then forwarded to ntdll. Then I added a large code section to house RtlQueryPerformanceCounter and future functions. Only applications that call RtlQueryPerformanceCounter need to use this wrapper ATM. You can go into CFF Explorer -> Import Directory and change the entry for ntdll.dll under the "Module Name" column to ntext.dll. That can also be done with a hex editor, as the only likely reference to ntdll in the application would be in the import/delay load import tables. I just decided to compile it with the SSE2 switch. the best that VC++ offers (though it may not do much for a wrapper DLL, admittedly). Since most Windows 7+ applications probably need SSE2 to begin with, I don't see much harm in this decision.
  3. 3 points
    Get rvkroots.exe (Google), extract updroots.exe from it and put it in some folder. Get Curl: https://rwijnsma.home.xs4all.nl/files/curl/curl-7.69.1-mbedtls-zlib-win32-static-xpmod-sse.7z and unpack in the same folder. Then you just run the following batch file: ----------------------------------------------------------------------------------------------------------------------------------------- curl -O http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authroots.sst curl -O http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/delroots.sst curl -O http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/disallowedcert.sst curl -O http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/roots.sst curl -O http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/updroots.sst updroots authroots.sst updroots updroots.sst updroots -l roots.sst updroots -d delroots.sst updroots -l -u disallowedcert.sst cls ----------------------------------------------------------------------------------------------------------------------------------------- Done, takes 20 seconds to update, no complicated nonsense like they do in the XP forum.
  4. 3 points
    So far, the following x64 DLLs have been extended: kernel32.dll dwmapi.dll ntdll.dll (wrapper, named ntext.dll) ole32.dll shell32.dll user32.dll uxtheme.dll As a result, Windows Media Foundation from Windows 7 Platform Update was successfully transplanted. The same could be done for Windows 7's crypto binaries. Based on something I did for Windows 2000, you will have take into account the associated binaries like crypt32 and secur32, and possibly dssenh.dll.
  5. 3 points
    Yes, I did implement it. And it should be one of the few stable functions, as it doesn't call outdated ntdll functions that others do (banking on ntext x86 to fix that though!). Though you don't have to replace your main kernel32.dll in this case. The addition of a string to the registry and a .local file in the Windows Defender folder along with my kernel32 should suffice.
  6. 3 points
    @dencorso: You probably missed reading ... and the 3 following posts (exchange between me and @Vistapocalypse ), especially this: Historical progression of facts: 1. WD/MSE on Vista stopped being update-able directly from Windows Update (or via their integrated [manually] "Check for Updates" feature [which also evokes WU]) in the start of July 2019, when Microsoft changed the WU delivery infra to employ only SHA-2 endpoints (the SHA-1 ones were still on-line at the time...) 2. WD/MSE users on Vista had to turn to manually fetching files (for 32-bit OSes) mpas-fe.exe/mpam-fe.exe and running those to get the definitions of their M$ antispyware/antimalware "solution" up-to-date; these standalone files (links of which can be found on http://www.microsoft.com/en-us/wdsi/defenderupdates ) were, at the time, still dual-signed (i.e. both SHA-1+SHA-2 code signatures), so running them and installing updated defs was working.... 3. Towards the middle of October 2019, M$ stopped dual-signing those files (as well as their "ingredient" files), updated versions came as only SHA-2 signed; while running an SHA-2 only signed file is not necessarily a problem on Vista SP2 patched fully until its EOS (April 2017), it is in this case because the security app/OS has to verify the integrity of both the engine and updated definitions, before installing/integrating them... Without SHA-2 support in the OS, definitions for both WD/MSE would stay at their last dual-signed version and become stale in a few days... For posterity, the last dual-signed version of the off-line updaters was v1.303.1946.0, sharing the same mpengine.dll v1.1.16400.2 ... 4. To overcome [3], Vista SP2 users had to manually download and apply some KBs, targeting Vista's Server counterpart, WS2008, which bring SHA-2 support to the Vista OS; with that implemented, mpas-fe.exe/mpam-fe.exe [SHA-2 only] could properly update off-line their respective M$ security apps... NB: While the finer details were not very clear then, installing those SHA-2 enabling M$ updates on Vista has the following shortcomings: 4.1. Vista's Windows Update Agent (wuaueng.dll) is not being updated to its SHA-2 compatible version (M$ made it sure, via checks, that only the supported WS2008 SKUs got that privileged treatment, not poor EoS'ed Vista , despite them both sharing NT 6.0) , so connection to the new SHA-2 only Windows Update endpoints was/is not feasible; hence, WD/MSE could not connect to WU and be updated, again, via that route (as in the era before July 2019) ... 4.2. Vista's build number is changed to 6.0.6003 (SP2 = 6.0.6002) and that fact by itself made the WU SHA-1 endpoints give it the cold shoulder (this is OT in this discussion, but if available dual-signed Vista updates were not installed prior to the migration to SHA-2 support, these would no longer be offered via WU[SHA-1] 5. On the first week of August 2020, M$, as announced, shut down permanently their WU SHA-1 endpoints, cutting off completely Vista SP2 (with/without SHA-2 enabled support) and, I'm sure you know already, WinXP This had, of course, no bearing on either WD/MSE on Vista, but is at least related to this thread's title... 6. Closing in on recent times, v1.321.xxxx.0 was/is the last Vista compatible series of offline security updates (i.e. files mpas-fe.exe for WD & mpam-fe.exe for MSE); that series introduced engine file (common for both installers) mpengine.dll v1.1.17300.4; the last version in that series was 1.321.2290.0, released on Aug 28th 2020: Next series of off-line installers,1.323.xxxx.0, introduced new engine version 1.1.17300.5, but that one is no longer compatible with Vista/NT6.0: So Vista SP2 (with SHA-2 support installed) users of either WD/MSE can't manually update their definitions past v1.321.2290.0 (close to a month stale as it is...) M$ continue to advertise on their "Security Intelligence" () portal that they offer off-line updaters for "Windows Defender in Windows 7 and Windows Vista", and in fact I have sent them feedback informing them of the current predicament Vista users find themselves in, but they have yet to respond to my report... BTW, next series v1.325.xxxx.0 is closing in... PS1: There have been reservations expressed by members here, notably @Vistapocalypse, about the efficacy of running Vista's native WD or a considerably old, nag-free, version of MSE on Vista, and probably with good justification ... But this is NOT the gist of this post; so please refrain from such remarks here... PS2: As of this writing, I have employed a "hack" to keep updating my WD with defs past Aug 28th, which essentially boils down to keep using the last compatible engine, v1.1.17300.4, with definitions (files *.vdm) prepared for the non-compatible engine 1.1.17300.5; for now, it seems to just work; but the two engine versions are close enough/similar; I bet when a future engine version is released, say 1.1.19xxx.0, the new definition files it will come with won't be backwards compatible with v1.1.17300.4 - it'll then be GAME OVER! PS3: I haven't yet jumped into @win32's Extended Kernel, especially since I'm on a physical machine (so not on a VM I can experiment with), but also because I am on 32-bit, which presents special challenges towards the ExtKernel goal... If @win32 has already implemented TryAcquireSRWLockExclusive in his kernel32.dll wrapper, then that would be the ultimate solution for Vista users wanting to keep their WD/MSE installation updated with current definitions/engine! PS4: A new project has come to light (first mentioned here by @burd ) that restores WU[SHA-2] support to Vista SP2 past last August's breakage; the legality of that project is still unclear; also unclear is whether WU connection is being restored to either WD/MSE, so that the apps could (again) download updated definitions directly from WU (Vista Extended Kernel would be required for successful installation...). I guess that's it!
  7. 3 points
    I compiled the NTEXT wrappers. SSE2 required. Note: the linkout.pl script makes an assumption that VC++ adds an extra underscore to functions that start with one. That is not true with VC++ 9, so such functions had one too many underscore for me. Though VC++ 6-8 may be different... The wrappers can be imported in place of ntdll.dll. New releases of kernel32.dll will refer to ntext instead of ntdll. The x64 ntext.dll has a modified RtlQueryPerformanceCounter, and it works good with Firefox 80. But there is a significant issue with the function in its unmodified form; it appears that any call to ntdll functions causes a "privileged instruction" error. So instead of calling the export-forwarded ZwQueryPerformanceCounter, I placed it directly in my dll as a subroutine and that fixed it. The x86 wrapper will need a little extra work since x86 ntdll is much farther behind W7 than the x64 ones.
  8. 2 points
    To prevent user confusion, I strongly recommend disregarding the tutorials and contacting me directly instead about the extended kernel. The original post appears below for prudency.
  9. 2 points
    I will work on modding 372.70 usermode components. I just looked at nvd3dumx.dll (D3D usermode driver for x64 components) and I found this suspect code: .text:00000001806B94AF mov cs:VersionInformation.dwOSVersionInfoSize, 11Ch .text:00000001806B94B9 mov cs:VersionInformation.dwMajorVersion, 6 .text:00000001806B94C3 mov cs:VersionInformation.dwMinorVersion, 1 .text:00000001806B94CD mov cs:VersionInformation.wServicePackMajor, r15w .text:00000001806B94D5 call cs:VerifyVersionInfoW So it is actively checking for NT 6.1. No doubt these changes will have to be done for later usermode components. UPDATE: and so does 365.19. So I'll have to check other files.
  10. 2 points
    Moonchild's stance is now "if the mountain won't come to Muhammad, then Muhammad must go to the mountain", as expressed (along with "name calling") below: https://forum.palemoon.org/viewtopic.php?p=200402#p200402 and further down in that thread:
  11. 2 points
    Out Pale Moon 28.14.0. Release Notes: https://www.palemoon.org/releasenotes.shtml ***** = https://www.palemoon.org/redist.shtml
  12. 2 points
    So I was checking out this other bank and their procedure to log onto their online services is even more convoluted. And looking at other banks' offerings...the more, I look, the less I'm sure where to go from here. I forgot to mention, there is some extra glitch with Magisk on my device; Magisk normally checks the ro.build.tags prop and sets it to release-keys if it was set dev-keys or test-keys, custom ROMs have it set to one of the latter two. It's written in /system/build.prop file that is generated during build process, which may be modified with rw access to /system. The glitch is when Magisk modifies it during runtime, getprop utility returns the updated value, but a programmatic check through Java still returns the old value unless you modify build.prop file directly. I don't know whether that app checked build tags first or the presence of busybox binary, which, BTW, is actually present on certain official ROMs! I just identified the relevant blocks of code by taking its APK file apart with APKTool. It looks like root checks span across both Java code and one of the bundled native libraries. So the things that I identified are successfully hidden on my phone, at least undetectable by Native Root Checker and RootBeer Sample apps. I also tried registering with the previous version of the banking app, which, in logcat, specifically mentions "negative root check", but no luck, log indicates their server returned some error code. Of course, they could be blocking older versions. Back to the current version, I also tried changing my device's fingerprint, didn't help neither. The thing about blocking my phone's serial number is pure speculation on my part, but this could be it as part of its code does read it. I figured the serial number is passed to the Linux kernel via androidboot.serialno=xxx paramater by device's bootloader. There's also possibility that some hole still exists through which root may be detected. One such hole is known, but can be avoided by using Magisk fork with modules functionality stripped, which I ended up installing, though I haven't found that it's actually used by the app. I guess they could also block the numeric ID they give to their customers to activate the app, but then even using different phone wouldn't make a difference... I also messed around with various versions of Android-x86 on my laptop. It has its own quirks. Good to know ART cache (Dalvik cache in older versions, but still residing in /data/dalvik-cache in newer versions) wasting a lot of space is the problem of Android 7.x in general. I haven't been able to pass SafetyNet test on it, not even the basic one, so there goes the idea of using PC port of Android for that stupid app. Not much positive is written about passing SafetyNet on Android-x86 AFAIK, just some guy hinting using his Magisk module safetypatcher supposedly helps, which just changes phone's fingerprint in a different way during runtime. But since changing the fingerprint directly in build.prop isn't evidently a problem, since I could do it on my phone and still pass the check and the author of MagiskHide Props module, which also changes the fingerprint, says it won't help if one is unable to pass even the basic check, that's just another dead end. Finally, removing Magisk on my phone = SafetyNet check not passing due to custom ROM Downgrading to latest official ROM (Android 4.4.4) = inability to run the banking app at all since Android 5+ is required
  13. 2 points
    Thanks for building this time with the " --disable-accessibility" flag... I had commented: Upon testing, it appears that the latest Serpent 52.9.0 (32-bit) (BuildID=20200925161000) remains unaffected by that bug, which is, hence, only manifested in latest New Moon 28.10.2a1 (32-bit) (BuildID=20200925153118); but my initial assessment was correct - upstream commit https://github.com/MoonchildProductions/Pale-Moon/commit/9f56811e04ef4703aec82ba6a7c712e50c7667c0 was indeed the one that broke the native downloads manager... Moonchild became aware and later authored: [downloads] Correct and simplify host handling. https://github.com/MoonchildProductions/Pale-Moon/commit/fd30b23a0dfa2373539b348519aa9864976b46dd ... but, alas, it came too late for "us" , that one was not included in https://github.com/roytam1/UXP/commits/custom when latest NM28 was compiled... I have confirmed that the "fix" works as intended, restoring the functionality of the native NM28 Downloads Manager, as well as the functionality of the (legacy) Downloads Window extension several users (including yours truly ) have installed... I understand, your spare time allowing , that the fix will be included in next Saturday's released builds, in the interim I have taken the liberty of modifying and uploading a patched omni.ja file latest NM28 users could download to regain lost functionality: omni.ja https://www119.zippyshare.com/v/lAv8DFrY/file.html It should be placed inside "./palemoon/browser/" overwriting original omni.ja file (or you could rename/back-it-up first, e.g. as omni.ja.BAD) ; hope I've helped!
  14. 2 points
    Isn't the default in Android called "Browser"? As for skipping commits, ask the Linux and BSD folks (people who know what they are doing) about the subject,rather than Tobin and that bunch. Basically, under open source licenses you're not obligated to integrate commits or anything else you don't want in your work as long as you are in compliance with the license.
  15. 2 points
    It's perfectly usable. To use it, just do something like this: The next kernel32 update will call ntext instead of ntdll as well.
  16. 2 points
    https://addons.palemoon.org/addon/adblock-latitude/
  17. 2 points
    This is why a blank Windows 7 started to find updates again. I didn't understand why. Here is the answer. And I confirm that it works also on XP EDIT : Windows 2000 is ok too
  18. 2 points
    As of today (26 september 2020), the windows update for xp and vista (and maybe 2000?) is working. Grab them while you can Note: the wsusscn2.cab is still only sha2 signed
  19. 2 points
    That hack is essentially the same we used on XP: by keeping Engine Version 1.1.15800.1, we were able to continue updating up to the *.vdm v. 1.293.2807.0... then the next *.vdm files required a newer engine version and game over it was. But, from that period just before game over, @heinoganda had cobbled up an automated updater that download the the new definitions, replaced the engine by the last one working and put all files in their proper place, therefore helping more people to keep their MSE up-to-date up to game over, and I bet he sure might be able to modify that tool for the Vista community to enjoy the last leg of their MSE/WD more confortably. In case he doesn't ping this theread soon, do send him a PM. I'm sure he'll be delighted to be of help. Ceterum censeo Decimum delendum esse!
  20. 2 points
    New NewMoon 27 Build! 32bit https://o.rths.ml/palemoon/palemoon-27.9.7.win32-git-20200926-a291744c7-xpmod.7z 32bit SSE https://o.rths.ml/palemoon/palemoon-27.9.7.win32-git-20200926-a291744c7-xpmod-sse.7z 32bit noSSE https://o.rths.ml/palemoon/palemoon-27.9.7.win32-git-20200926-a291744c7-xpmod-ia32.7z 64bit https://o.rths.ml/palemoon/palemoon-27.9.7.win64-git-20200926-a291744c7-xpmod.7z source repo: https://github.com/roytam1/palemoon27 repo changes since my last build: - import changes from `dev' branch of rmottola/Arctic-Fox, and fix --enable-shared-js: - Bug 1164338 - Move styles markers to be generated in DoProcessRestyles rather than when the Flush_Style queue is flushed. r=smaug,heycam (b8f62d25a) - pointer style (c8d305ae5) - Bug 1150783 - Use a special JitFrame to record when LazyLink stubs are on the stack. r=h4writer (999a5d8dd) - Bug 1050500: Add SpiderMonkey API for reporting JavaScript entry points. r=shu (86b990918) - Bug 1050500 followup: Annotate js.cpp "Exit()" method as "override". rs=ehsan (023d67749) - Bug 1050500 - Add callee information to Javascript timeline markers. r=smaug (a5c078bc0) - Bug 1050500 - add fields to ProfileTimelineStackFrame; r=smaug (7852af842) - Bug 944164 - Move a bunch of file-related stuff onto an os.file object, creating aliases from the old names, r=jorendorff (a746506c0) - Bug 1167860 - Make sure unboxed expandos are traced during minor GCs if the original unboxed object is converted to a native, r=terrence. (40552cef4) - Bug 1168667 - Immediately convert unboxed objects to natives in PreventExtensions, and convert unboxed arrays as well as unboxed plain objects when required, r=jandem. (34e1c1267) - Bug 1172150 - Remove bogus assert. (r=bz) (1138519fa) - Bug 1165794 - Correctly handle getter/setters like methods everywhere. r=efaust (69a5cef61) - Bug 1164778 - Make |super.prop| work inside heavyweight arrow functions. (r=shu) (2eaffe30d) - Bug 1168750 - SharedStubs: (part2) Rename registers used by baseline stubs for use with shared stubs, r=jandem (db8080b41) - pointer style (ae0ef8c24) - fix spaces (0b5a0f55d) - Bug 1168864 - Use mayResolve hook for addprop stubs. r=bhackett (14f89c938) - Bug 1166678 - Optimize Array.prototype.slice in Ion, r=jandem. (978215128) - Bug 1169611 - Rewrite IonBuilder::getPropTryConstant to not require a singleton result. r=bhackett (22c6137ea) - Bug 1169611 part 2 - Unbox getprop/getelem inputs based on Baseline feedback. r=bhackett (dd3d50088) - Bug 1148009; [webvr] Move gfx vr code to gfx/vr; r=jrmuizel (d3e0a12c7) - Bug 1148009; [webvr] Split out gfxVROculus from gfxVR, refactor VRHMDManager; r=jrmuizel (393030b10) - Bug 1148009; [webvr] Add Quaternion class to Moz2D; r=jrmuizel (85165c87c) - Bug 1144674; Implement HAL support for ROTATION_VECTOR and GAME_ROTATION_VECTOR sensors; r=snorp (482211f00) - Bug 1148009; Add support for Cardboard (and other rotation-sensor based VR) in Firefox for Android; r=jrmuizel (d3f78e657) - Bug 1157835: Remove the MSVC_ENABLE_PGO flag from the build system. r=glandium (a5cc2bb8f) - Bug 1170534 - Remove Visual Event Tracer. r=dougt (720c1bbc3) - Bug 1169967 - Add a forward declare for MIRGenerator. r=nbp (81c6d0492) - Bug 1154435 - [nsDumpUtil] Refine nsDumpUtils::OpenTempFile to make this function more flexible. r=dhylands (ca1e07244) - Bug 1154435 - [nsGZFileWriter] Add one more mode for writing a GZFile (Create/Append). r=froydnj (d0cc62270) - Bug 1165456 - Start converting name-resolution code to act upon kinds, not arities. r=shu (1162554f4) - fix let (3ad7122ea) - Bug 1165456 - Handle a bunch of simple known-arity kinds, by kind, when resolving nested function names. r=shu (82da03c43) - Bug 1165456 - Perform name resolution on more nodes by kind, not arity. r=shu (214062efa) - Bug 1165456 - Perform name resolution on additional nodes by kind. r=shu (c13147c9e) - Bug 1165456 - More name-resolution conversion for arrays and (tagged) template literals. r=shu (f0cd596e8) - Bug 1165456 - Extra bits of name-resolution conversion. r=shu (51d1045d7) - Bug 1165456 - Final bits of name-resolution by kind. r=shu (57fca554e) - Bug 1165456 - Remove dead code performing name resolution by arity. r=shu (b03db072a) - pointer style (ab86d2ca7) - Bug 1149510 - Initialize the MachineState with safe-bad pointers. r=jandem (7d35b51c9) - Bug 1149510 - Don't try to read the result object when doing in-place debug mode bailout in a for-of loop. (r=jandem) (40c1e23a7) - Bug 1156115 - Apply Bug 1135629 changes to the non-ion jit. r=nbp (332a21041) - pointer style (fab908ba9) - Bug 1155468 - Fix Register::GetName typedef issue with clang. r=jandem (5c7758d85) - Bug 1176633 - Add more Operand constructors to the none backend. r=nbp (1557fe119) - Bug 1160672 - Part 1/2 - Import VIXL 1.5-1.6. r=jbramley (c84218fec) - Bug 1160672 - Part 2/2 - Add Mozilla VIXL modifications. r=dougc (1fd1c7443) - Bug 1160672 - Follow-up - Add missing </p> tag. no_r=me (f783f0793) - Bug 1160672 - Follow-up - Comment out unlanded header on a CLOSED TREE. no_r=me (f65a68eed) - Bug 1166037 - Import ARM64 Baseline changes. r=djvj (5ddb53015) - Bug 1166527 - Import ARM64 Architecture and Assembler. r=nbp (999380926) - Bug 1077014 - MacroAssembler API. r=h4writer (78f470fa5) - Bug 1077014 - ARM assembler support for for-effect atomics. r=mjrosenb (a78d1f786) - Bug 1077014 - MacroAssembler API, for MIPS. r=rankov (d22cb063c) - Bug 1077014 - optimize atomics for effect. r=h4writer (5a0bf089c) - Bug 1170758 - Make non-debug GraphSpewer constructor explicit. r=nbp (2b7c1a90b) - Bug 1176631 - Predeclare TempAllocator for non-ion platforms. r=nbp (73cd914a7) (a291744c7)
  21. 2 points
    Hi I've adapted the "open with-6.8.6" add-on. get it from the Seamonkey add-on site to work with iceape-UXP . It is an add-on that allows you to open another browser or video player to view youtube videos externally to iceape-uxp. This allows you to open the videos on any other video hosting websites referenced in the "youtube.dl..." list. with mpv for xp . VLC also opens in iceape-UPX for youtube only with "open with 6.8.6", so you can avoid commercial ads and some youtube restrictions (age, etc.). I remind you of the instruction manual thread... https://msfn.org/board/topic/180462-my-browser-builds-part-2/?do=findComment&comment=1178761 open_with-6.8.6-iceape+tb.xpi
  22. 2 points
    Yah, there's been a few times before where it took Big Muscle a while to update Aeroglass to support a new version of Win10. I think this might be the first one that it gets lapped. IE the October update will come out before BigMuscle had a chance to make it work with the spring update I ended up uninstalling Aeroglass as I'd deferred months and months of security updates to keep it working. If Aeroglass ever gets caught up again, I'll gladly reinstall it. For now I'm setting with a dark theme and accent.
  23. 2 points
    @max-h this installs 7.6.7600.256 for XP and Vista http://download.windowsupdate.com/windowsupdate/redist/standalone/7.6.7600.320/WindowsUpdateAgent-7.6-x64.exe http://download.windowsupdate.com/windowsupdate/redist/standalone/7.6.7600.320/WindowsUpdateAgent-7.6-x86.exe
  24. 1 point
    Windows Vista UI all the way... Microsoft never came out with such another diamond design as they did on Vista... It caugh your eyes at first sight. Windows Spaghetti 10 is so damn boring, flat and theres no consistency at all, some menus and icons looks like this, some other like that and even another one different from the previous two.
  25. 1 point
    Works as not advertised. No bearing of KB4474419 and KB4490628 on the August 2020 SHA-1 endpoint retirement, and no bearing of the August 2020 SHA-1 endpoint retirement on Windows 7 SP1.
  26. 1 point
    ...because Dell is Dell, they simply have their own ways to do things AND mis-documenting the *whatever* they do, not necessarily worse (nor better) than any other OEM/laptop manufacturer, only *somehow* different. jaclaz
  27. 1 point
    Yes and no, Dell is Dell, it is very possible (actually probable) that your touchpad is actually an Elan one and I thought wrongly that it was a Synaptics one. jaclaz
  28. 1 point
    Could you explain what this means? Is this a v28-only build preference Please read below: that's the accessibility libraries, official builds and my old builds used to have --disable-accessibility specified. I lost the build config and then it turns on that on compilation. ... and will go if I remember to do this. As to: I'm not currently using NM27, but do you now (i.e. in latest builds) see extraneous accessibility files inside its main directory? FWIW, one can always consult built-in pages like "about:buildconfig" to read build-time configuration flags...
  29. 1 point
    It didnt start with your files the drivers are just broken on vista , your files dont fix those errors , there are many instances where i get this error , IE9 64bit , Steam games , sometimes in windows score assessment (winsat i think) , All of them 64bit , 32bit dxdiag works fine , while 64bit crashes https://imgur.com/a/fnYuj2c one thing to note is that , the steam games would just crash without your modified files , but with it , it would probably run with proper drivers since it crashes on the nvidia D3D10 dll now.
  30. 1 point
    @VistaLover. thanks for the download manager fix. as to testing Mypal vs New Moon. it is not my intention to switch browsers. just was curious as to how Mypal works with the "instances " page. am happy to see that this is a more friendly board compared to the upstream one. and a big thanks to roytam1 for maintaining New Moon and other weekly builds. did not mean any disrespect. regards.
  31. 1 point
  32. 1 point
    @VistaLover Regarding broken download manager in latest NM28 - after applying your omnia.ja file, everything is back to normal. Thank You!
  33. 1 point
    Looks a lot like W7, which is cool. This is my current theme: Only missing Glass8 to add transparency w/ blur and live reflections from Vista.
  34. 1 point
    (_HOWTO_ modern ciphers for old browsers for Windows98, Win98, Win9X, ME, forks, TLS1.2, ...) YES - again It was starting to become a real killer prob 1-3 years ago, half the web broken, even with basic KernelEx, but thankfully roytam1 appeared, and has posted a bunch of updated OLD browser forks! Adding modern TLS1.2 CIPHERS, and he also backported a few browsers to work on older systems again. That stuff is just shattered around here and there, a bit everywhere... For VANILLA Win98 there's mainly Retrozilla (project of dev rn10950), in various flavors, and roytam's recent fork of K-Meleon1.5.4+TLS1.2, with modern ciphers added. There exists also a roytam-fork of Firefox2, which is also called Retrozilla, with now an rzbrowser.exe inside. Its older version still had a firefox.exe inside. Yes it's a bit confusing... RETROZILLA (ancient Seamonkey, era Firefox2, but with modern CIPHERS): guess this exists now in 3-4 flavors, but am rather confused, since initially, when I found and used it for awhile as fallback browser, had no clue yet there exist 2 RZ-builders with completely independant forks, using even same version numbers, and different engines inside! Had completely lost overview in that chaos and given up when not needing RZ myself anymore, but finally did some more research now: The official Retrozilla is a fork of an ancient Seamonkey version, by rn10950, hosted at github, and he started the msfn topic here in 2016: https://msfn.org/board/topic/174987-retrozilla-an-updated-version-of-mozilla-for-windows-95-and-nt4-22-released/ Not long ago he posted an update to version 2.2, containing modern CIPHERS and other stuff. But independant of this version, roytam had already made some own RZ-forks too, before and after the official RZ update, and partly used other engines inside too, and also called them version 2.2. Guess there exist now 1) RZ-ori-SeamonkeySuite, and 2) RT-RZ-SeamonkeySuite, and 3) an RT-"RZbrowser" with Firefox2 engine inside, which is even more confusing, because: I happened to stumble upon this "RZbrowser" first, so used it, unaware of any other builds/forks/variations, and at the time it was the older version yet, v2.1 from 20180504. Was completely confused that it didn't identify itself as RZ, but instead as "Firefox2 Community Edition", and was started by a firefox.exe, and it also stored its Profiles in AppData/Firefox/. When I finally got it that this really is FF2, roytam posted an update to "Retrozilla v2.2". Now I was AGAIN completely confused: this update looked completely different as my "previous version 2.1"! And it was started with a "retrozilla.exe" and stored profiles in appdata retrozilla folder. Finally learned that there are two branches: "rz-suite", based on Seamonkey, and "rzbrowser", based on Firefox2. Awhile later, an update of this Firefox version followed: rzbrowser-tls12-20200127.7z. And AGAIN completely confusing: now this update identified itself as RZ too, in the startup page! And it gets now started with "rzbrowser.exe". So, no Firefox inside anymore? Then again, the exe properties still claimed to be FF2. And the toolbars still looked like Firefox too. After starting noticed the next surprise, it created completely new profiles in a completely new path: "AppData/Retrozilla/BROWSER/Profiles" (note that RZ-Seamonkey SUITE uses "AppData/Retrozilla/Profiles", and "retrozilla.exe") Uff, what a chaos... But what I mainly wanted to know: can this new version still run normal FIREFOX addons? And luckily, after a quick test: Yes! My test addon Read Easily installed quite normal. So it really is still a Firefox towards addons. Just was confused again for a moment that the new button wasn't visible, until realizing it must first be unhidden, by right-click on a toolbar and "customize". There it was hiding! Ouf.... So, this was the older and "pure" RZbrowser-Firefox2 version I used myself a few months as fallback, simply because it was the first RZ I ever saw: https://msfn.org/board/topic/174987-retrozilla-an-updated-version-of-mozilla-for-windows-95-and-nt4-22-released/?do=findComment&comment=1150700 HTTP or https://o.rths.cf/gpc/files1.rt/rzbrowser-tls12-20180504.7z And this is the newer RZbrowser-Firefox2-wrappedRetrozilla Mixup: http://rtfreesoft.blogspot.com/2020/01/other-browser-binaries-20190131.html http or https://o.rths.ml/gpc/files1.rt/rzbrowser-tls12-20200127.7z And here is the original "complete" Retrozilla version, based on Seamonkey, containing a retrozilla.exe, by dev rn10950, but downloads hosted at Github (=now BLOCKED for old native Win98 browsers, thanks Microsoft!) https://msfn.org/board/topic/174987-retrozilla-an-updated-version-of-mozilla-for-windows-95-and-nt4-22-released/ https://github.com/rn10950/RetroZilla/releases/latest Perhaps direct links are better for future... retrozilla-2.2.en-US.win32.installer.exe 12.5 MB retrozilla-2.2.en-US.win32.zip 11.4 MB Source code (zip) And roytams forked version of "complete" Retrozilla SM suite: http://rtfreesoft.blogspot.com/2020/01/other-browser-binaries-20190131.html HTTP or https://o.rths.ml/gpc/files1.rt/retrozilla-suite-tls12-20200131.7z The main differences between RZ-Seamonkey and (RZ???) Firefox2, as vaguely as I understand them, is that SM is a suite and comes with an email tool and chat etc build in, while Firefox2 is "only" a browser, but for it are still many more addons available, in wayback machine. Incl. crucial ones like CustomButtons and "Read Easily" (toggle styles off permanently, with button). While addons for SM are still found on Mozilla's official AMO site or guess an official split of it, among Thunderbird addons. Now, not sure which Retrozilla version you tried, if you found it so bad, perhaps on old one. Of course, all engines inside all versions ARE stone age, around Firefox2 era! Just updated with modern CIPHERS to restore access to HTTPS sites. And the original version probably yet more updates. Then again, you mentioned too many CRASHES, but crashing is a whole different prob in itself, sadly more and more frequent now. KM is heavily affected too, old versions and newer ones. I hear even medium aged browsers like current KMG76.3 (based on PaleMoon26+Updates) and running on modern systems have started crashing here and there roytam's K-Meleon154+TLS1.2 ciphers is here HTTP or https://o.rths.ml/gpc/files1.rt/K-Meleon1.5.4en-US.tls12.7z (3 files missing: profile.ini for portable mode, msvcp71.dll+msvcr71.dll, if not in system folder already. See below) KernelEx NOT needed on Win98, but if you run it in a kernelex system anyway, set the compat to "disabled" to avoid a bug. Anyway, if KernelEx is installed, choices get much better: For example roytam's version of Firefox3.6+TLS1.2 ciphers, build for NT-systems. Perhaps runs on vanilla ME too? But have heard not on all, so suppose Win98 still needs KernelEx? HTTP or https://o.rths.ml/gpc/files1.rt/fx36vc71-20171108_newnss.7z Incidentally this also contains the 2 mscv files missing in KM1.5.4 above. For portable use it can be started with the contained bat file. And for KM-fans. A tiny step in numbers, but huge step in functions: K-Meleon 1.6+TLS1.2 You don't happen to still have an old community updated version of KM1.6beta2.6 lying around? Downloads of the time are long since broken too. Only the outdated official 1.6beta2 on sourceforge still available in repo, but lots of fixes and updates missing: K-Meleon 1.6.0 Beta2 (Dec.2010) Win98 needs KernelEx452 with compat=XP HTTP-SF or https://netcologne.dl.sourceforge.net/project/kmeleon/k-meleon-dev/1.6.0Beta/K-Meleon1.6.0_Beta2_en-US.exe HTTP or https://master.dl.sourceforge.net/project/kmeleon/k-meleon-dev/1.6.0Beta/K-Meleon1.6.0_Beta2_en-US.7z Important Update packages: (but sadly only the most crucial updated files. There were more in old times, but download long since broken): 2012 +Beta2-3: http://kmeleonbrowser.org/files/KMeleon1.6.7z (by Dorian) (2012 Gecko updates by forum members, beta2.6 by JamesD, download broken) 2020 +TLS1.2 ciphers: HTTP or https://o.rths.ml/gpc/files1.rt/ns9-nss-update.7z (by roytam1) Attention: For KM REMOVE sqlite3.dll from nss-7z, KM must keep its original version KM1.6+TLS1.2 topic http://kmeleonbrowser.org/forum/read.php?2,151536 And for CometBird9+11, Firefox10, Netscape9: Some little NSS-update packages by roytam1, adding modern TLS1.2 CIPHERS: https://msfn.org/board/topic/178283-how-you-really-browse-the-web-on-98me-in-2019/?do=findComment&comment=1178208 HTTP or https://o.rths.ml/gpc/files1.rt/CometBird-9.0.1-new-nss.7z HTTP or https://o.rths.ml/gpc/files1.rt/CometBird_11.0-new-nss.7z HTTP or https://o.rths.ml/gpc/files1.rt/Firefox10-new-nss.7z HTTP or https://o.rths.ml/gpc/files1.rt/ns9-nss-update.7z If anyone has Win98+modern KernelEx2016: roytam also forked a special K-Meleon74 build (based on an old KM74-fork by Naruman), backported it for vanilla Win2000 (=Kex compat) and added modern TLS1.2 ciphers. In Win98 this one is far too buggy+crashy for real use, but sometimes the only chance. Perhaps it runs better in ME? He also fixed 2 old KM74-bugs, native site-useragents and macro stuff (injectJS-return). HTTP or https://o.rths.ml/gpc/files1.rt/KM74-g22-20180718.win2000.7z (files inside from 2020-01-09. If only minor (?) updates like a few more ciphers, RT often insists to keep old date in name, sigh) With VERY modern KernelEx2019 (and perhaps ME, not Win98? not sure) someone even reported that RT-KM76g starts in his system, but also rather buggy of course... Since 2-3 years roytam1 updates the engine inside his Goanna3-fork almost weekly. For example, at the moment the last version is here: http or https://o.rths.ml/kmeleon/KM76.3.1-Goanna-20200926.7z Lots of packages, but very far from "simple". And when I finally dared to try updating last year, hoping to get RT-KM74 running, it nearly ruined my system. For an expert no prob of course, but for me, having no clue of system stuff, so decided to leave it at a semi-updated state and not daring to touch it anymore since. Killer prob is, my 2016 version is also rather buggy, not possible anymore to disable Kex completely on an app, killing some old native 98 apps By the way, when using a BRANDNEW profile and getting this ERROR on all HTTPS sites: "Could not initialize the browser's security component" that's also a KernelEx bug, but luckily can be worked around. HOWTO: NEW profiles must first create 3 personal key files for HTTPS (key3.db, cert8.db, secmod.db) - either copy over those 3 files from an older, existing profile of a similar Mozilla browser - or produce new files with a native Win98 browser, then copy those 3 new files over into your younger browser (from Firefox2, K-Meleon1.5.4, Retrozilla? etc, into Firefox3.5/3.6/9, K-Meleon1.6/7/74 etc.) For example, if using for this key-creation roytam's updated fork of K-Meleon1.5.4, in Win98 with KernelEx: right-click on "k-meleonW9x.exe", open file properties, set KernelEx compat to "disabled", start this exe, and visit a httpS website, like msfn. If it works now, the browser has created those files in current profile folder. From there you can copy them into other browser profiles, of younger engines. General info for vanilla Win98 users: If UNZIPPING of roytam1 browsers doesn't work, update to 7-ZIP 9.20, last Win98-version: HTTP-SF or https://netcologne.dl.sourceforge.net/project/sevenzip/7-Zip/9.20/7z920.exe or http://sourceforge.mirrorservice.org/s/se/sevenzip/7-Zip/9.20/7z920.exe For running K-Meleon1.6, 1.7, Firefox3.x etc. on Win98, you need at least good old basic KERNELEX 4.5.2 for Windows 98: HTTP-SF or https://iweb.dl.sourceforge.net/project/kernelex/KernelEx/4.5.2/README.txt http or https://netix.dl.sourceforge.net/project/kernelex/KernelEx/4.5.2/KernelEx-4.5.2.exe Ouf... what a novel, sigh. .
  35. 1 point
    AdBlock Latitude 5.0.8, as mentioned by @Sampei.Nihira, and NoScript 5.1.9. Both are working fine with the latest release of NM27. kind regards soggi
  36. 1 point
    It seems that the native downloads popup page is also broken. Downward arrow in the toolbar (showing "Display the progress..." after mouse hover) does not respond to the mouse click to open current or previous downloads. In addition, menu item "Downloads Ctr+J" shows empty downloads page in the opened Library.
  37. 1 point
    Starting last August, the WSUSscsn2.cab file is being signed by M$ ONLY with a SHA-2 code-signature, high chances are it won't work with WUMT under XP ; it certainly chokes here under Vista SP2:
  38. 1 point
    You need extended Core , XP usb drivers and MTP Driver from google. @win32 if Microsoft open source it, it will be a boon to reactos. I believe they should as it is hard to put genie back into bottle once it is out.
  39. 1 point
    Who the hell cares, its a few £/$ via Paypal, your not buying house or a car.
  40. 1 point
    Believe it or not, I've just been offered two updates for Office 2010 through Automatic Updates, with a yellow shield in the system tray, after weeks of it repeatedly saying in the Event Log that it can't connect! I immediately went to the Microsoft Update website, and it successfully scanned for them and installed them, so it's not quite dead yet!
  41. 1 point
    Thanks to a Discord user, I now have the January 4th, 2019 Steam client, and I've released it for everyone to use. It's probably the best client we can use on XP/Vista currently.
  42. 1 point
    Hello, IXOYE.. I rolled back to build id: 20200904161558 and it hasn't happened since...go figure?! We'll see, perhaps the next build will take care of the issue. Have a good one!
  43. 1 point
  44. 1 point
    New regular/weekly KM-Goanna release: https://o.rths.ml/kmeleon/KM76.3-Goanna-20200919.7z Changelog: Out-of-tree changes: * update Goanna3 to git 500383702..aebd9e464: - import changes from `dev' branch of rmottola/Arctic-Fox: - Bug 1194905 - Build libvpx neon code without -mthumb and -mfloat-abi=softfp. r=mshal (24098bdb7) - Remove spurious commandline.css from AF tree. (49cf2bb5c) - Bug 969914 - Make developer toolbar match the light devtools theme when applied;r=jwalker,r=pbrosset (4047862bd) - Bug 1152304 - Add displaying of block notes to dis() in the JS shell. (r=jimb) (9c1d7fa30) - Bug 1126987 - Fix _lastEventSize initialization in stack.js. r=vporof (2083cb437) - Bug 1140569 - Show async stacks attached to timeline markers. r=vporof (f05e1b60c) - Bug 1141553 - Give function name the devtools-monospace class in the profiler r=vporof (0ca698ea2) - Bug 1150112 - Markers overview should react to theme change, and other marker views now use CSS to automatically use theme change. r=vporof (6f72cde25) - Bug 1050500 - Add entry reason to timeline marker. r=jsantell, r=smaug (db9cf8191) - Bug 922221 - implement console.timeStamp(label) to create profile timeline markers. r=khuey (73e513562) - Bug 1059908 - Merge FunctionType and FunctionSyntaxKind. r=efaust (2d765bde5) - Bug 1059908 - Introduce a CONSTRUCTOR flag and make getter/setter/method non-constructable. r=efaust (fddb15f13) - Bug 1162310 - Do not use nonexistent macro when XGILL_PLUGIN is defined, r=bhackett (57a5c2861) - pointer style (55ec84b3b) - Bug 1164602 - Replace js::NullPtr and JS::NullPtr with nullptr_t; r=sfink (9ae473e29) - pointer style (7d735a2b9) - pointer style (987c0128b) - Bug 1135629 - Rename Register::code to Register::encoding for Assembler functions. r=jandem (cf915c814) - pointer style (ac97f0d0b) - Bug 1150337 - OdinMonkey: Optimize the full range of immediate offsets on x64. r=luke (fffb82aa6) - fix typos (511e17002) - pointer style (c1b54384c) - Bug 1135707 - Fix interaction between Arm NOP fill and calculation of IonCache rejoin label r=jandem (306365ec4) - pointer style (a8fe90ade) - Bug 1166809 - Remove DispatchIonCache and RepatchIonCache. r=bhackett (9b8b02bf1) - Bug 1147403 part 3 - Make IonSpewer work during off-thread compilation. r=h4writer - Bug 1147403 part 3.1 - Replace newly added IonSpewPass after KeepAlive transform. r=KWierso (01bd66aa3) - Bug 1147403 part 4 - Extract the printer from the serializer. r=h4writer (290a8887e) - pointer style (fc70e6a1a) - Bug 1147403 part 0 - Replace contextual information of dispatchHook by lambdas. r=shu (e177990e5) - Bug 1065657 - Allow multiple Debuggers to track allocations at the same time. r=shu (66b5a3ba9) - pointer style (bb317bb87) - Bug 1147403 part 5 - Add Debugger::onIonCompilation hook. r=shu (c14a28de1) - Bug 1147403 part 6 - Remove GetJitContext from serializing functions. r=h4writer (6d3d605a5) - pointer style (b2ec50945) - Bug 1147403 part 7 - Fix inIon, only reset the counter when the function is executed. r=jandem (cb6c180ef) - Bug 1165392, Bug 1165463 - Various unboxed array fixes and optimizations, r=jandem. (28ec85004) (d43d81d5a) - import changes from `dev' branch of rmottola/Arctic-Fox: - pointer style (db52d9c32) - Bug 1158407 - Stop using this one weird allocation fallback for MCreateThisWithTemplate. (r=terrence) (5b489cd5d) - Bug 1170124 - Remove unnecessary type monitoring in jit::InvokeFunction. r=bhackett (1603ee063) - Bug 1141865 - Part 2: Plumb new.target on the stack and make it accessible to JSNatives. (r=jorendorff, r=jandem, r=shu) (25cfa92ec) - Bug 1129795 - Convert rest of docshell/ to Gecko style. r=mccr8 (20acc2d82) - Bug 1162309 - Part 1: Remove instances of #ifdef PR_LOGGING in uriloader. r=froydnj (8768f60c0) - Bug 1162309 - Part 2: Remove instances of #ifdef PR_LOGGING in docshell. r=froydnj (e9de046f3) - Bug 1096908 - forward network security messages to the content process; r=hurley (69b38e624) - Bug 1156493 - e10s: move .cacheKey to nsICacheInfoChannel so child channels can get/set it, r=jduell (507efbe2b) - Bug 1017758 - Use infallible getters for appId/isInBrowserElement/unknownAppId; r=bz (8021f0ae8) (39a4e30ae) - import certdata changes from NSS upstream: - Bug 1651211 - Remove EE Certification Centre Root CA root cert. r=KathleenWilson,jcj - Bug 1653092 - Disable server trust bit for OISTE WISeKey Global Root GA CA root cert. r=KathleenWilson,jcj - Bug 1656077 - Remove Taiwan Government Root Certification Authority root cert. r=KathleenWilson,jcj - Bug 1663049 - Add SecureTrust's Trustwave Global root certificates to NSS. r=KathleenWilson,jcj - Bug 1663049 - September 2020 batch of root changes, NSS_BUILTINS_LIBRARY_VERSION 2.44. r=jcj (52d97533c) - import change from tenfourfox: - fix overzealous assertion (M1531906) (af9a8236e) (ec64c2198) - import change from tenfourfox: - #618: EV now from ESR78, update TLDs, pins, HSTS (cb0f39c2f) (d836a27cc) - partly import change from tenfourfox: - #622: M1660537 M1641487(modified) M1645492 (291688840) (558e8c786) - import changes from tenfourfox: - #622: update brotli to 1.0.9, woff2 to tip (7c24b77e7) - #622: actually add new brotli files (fc50954e6) (aebd9e464) * Notice: the changelog above may not always applicable to XULRunner code which K-Meleon uses. A goanna3 source tree that has kmeleon adaption patch applied is available here: https://github.com/roytam1/palemoon27/tree/kmeleon76
  45. 1 point
    One year ago today... Rudy, you are sorely missed!
  46. 1 point
    Well, as RainyShadow already mentioned, after 11 pages it's a bit late to suddenly convert a general topic into a very restricted one: From "old browsers" to: - only Firefox and Chrome - only on XP - AND only their LATEST version for XP that's neglecting "XP" again, and "latest version".... .
  47. 1 point
    But why? Did you thought these 11 pages were written to support only you? You should've said so in the OP...
  48. 1 point
    With all due respect, probably because the older software still performs perfectly and is licensed for life, while an upgrade would require a new and expensive license just for show purposes, since it adds nothing really needed. Do you think people are made of money? Moreover, you yourself told he's gotten his clinic renovated... for normal human beings, there's only so much money (more so in times of covid-19, on top of it)!
  49. 1 point
    Lavfilters for XP 0.74.1 (Fork of the latest stable release): https://github.com/3dyd/LAVFiltersXP/releases Haven't tested it on XP but it seems to run fine on ME + KernelEx with Zoom Player so should be OK on its intended target system too I guess.
  50. 1 point
    what good SSD can we purchase now for XP ?? do we have to purchase 5 years old SSD's that will be hard to find ?? now a 120GB SSD does cost less than a 64GB USB memory stick so it's a good time to get some. I have checked all mainstream SSD manufacturers websites and downloaded their SSD optimizing tool but it doesn't run on XP. they don't even have a link for the legacy versions the Kingston website says that its tool works from W8 and up however I installed it with no issues Kingston is not my first priority nor am I sure their utility with a vintage looking has support for TRIM I know there are some after market tools for SSD but I think they will not be as good as the original one from the SSD manufacturer
×
×
  • Create New...