Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


All Activity

This stream auto-updates     

  1. Past hour
  2. I installed the jumper updates for KernelEx. I've got 98SE installed on a laptop and I'd like to use it for downloading files. uGet is not a "pretty" app, but it starts and completes more downloads than all the other managers, including IDM (Internet Download Manager). The uGet GUI is really the "front-end" for a powerful command line app called aria2c.exe. When downloads complete, you can add a custom script that will do anything you want. I've tried using the portable uGet with KernelEx. When missing DLL error messages appear I add the files, but uGet will not run. If it's possible to run uGet with KernelEx, tell me how. If not, can you recommend a similar app that is more compatible with KernelEx? (I don't know if there is another app similar to uGet.)
  3. Today
  4. Mailnews 2019-11-16 is contantly phoning palemoon: IP Server: 209.222.17.76. I have it blocked in my firewall, but it fills my log of garbage. Just sayin
  5. because there is conflict between their changes and my changes. the only change I created is in line 52 and 62 for reenabling the disabled adobe primetime installation as introduced in https://github.com/roytam1/UXP/commit/e30598c
  6. Most unfortunately, I can reproduce ; and it isn't only the Adobe Primetime CDM affected, as reported by @dencorso, but also the Widevine CDM too, which is installed and visible under Vista+; Widevine CDM v1.4.9.1088 is currently broken since August 13th 2019, due to Google changes - effort is underway by MCP to restore Widevine support in official Basilisk ( see here ), which is currently hitting a deadend, but any success won't benefit Vista users of Serpent, as updated Widevine DLLs don't run on Vista and require Win7+; still, having a working implementation of WV on Serpent would certainly benefit St users on Win7+ I normally don't have Adobe Primetime CDM (APCDM) installed in my Serpent 52 profile, but to humour @dencorso I did correctly install it (v17) and made sure I disabled the other h264/aac decoders: media.wmf.enabled;false (Vista's native WMF decoder) media.ffvpx.enabled;false (Serpent's bundled FFmpeg decoder) while I made sure media.gmp.decoder.enabled;true (APCDM's decoder) Widevine CDM (WVCDM) v1.4.9.1088 is also correctly installed. Extended testing reveals that: A. 2019-11-15 Serpent win32 build is the last good build where: 1. WVCDM appears installed in both "about:addons => Plugins" and about:plugins : 2. APCDM's decoder properly works for MP4 HTML5 video; e.g., first test clip on https://tekeye.uk/html/html5-video-test-page (1: HTML5 MPEG Video Test) B. By simply updating to the next Serpent 52 build, 2019-11-22, one discovers that it's the first bad one, since: 1. WVCDM magically vanishes from both "about:addons => Plugins" and about:plugins : 2. APCDM, while still present in both "about:addons => Plugins" and about:plugins, simply quits functioning as a h264/aac decoder (as reported by dencorso): @Mathwiz : Could you be so kind as to confirm my tests, preferably on Win7 where Widevine CDM is visible (thanks in advance ) ? ====================================== Now, examining more closely related code, MCP did remove APCDM support in official Basilisk in UXP #1259 ; the bulk of the patches would have landed in the 2019-11-15 build, as per but you did revert those (more accurately, did not apply at all in your custom branch), as per ... furthermore, the "reverting" has been successful, as the 2019-11-15 build is, according to my analysis above, the LAST GOOD one The MCP devs did not revisit issue #1259, except for https://github.com/MoonchildProductions/UXP/pull/1293 (Adjust Widewine strings after removing Adobe Primetime support) and thus https://github.com/MoonchildProductions/UXP/commit/36c81a9 This would have normally landed in the 2019-11-22 build of Serpent 52: while you did not technically revert that, you added your own version with a slightly modified code: https://github.com/roytam1/UXP/commit/e50e93c Since I'm not a code wizard by any stretch of the imagination, I can't be certain that the culprit for the issues reported here lies within that commit of yours... What is absolutely certain is the offending changeset(s) lives inside the changelog (in your custom UXP branch) between Serpent build 2019-11-15 and build 2019-11-22 ; please, at your discretion, investigate further ... Because, while you took the extra effort to keep APCDM support inside Serpent 52 alive (against MCP's agenda), not only did we end up with a crippled APCDM installation, but also Widevine took an unexpected hit and did a disappearing act... Thanks for your time reading this long report, hopefully you'll get it sorted out! Many thanks, as ever, for providing your forks to the community! Best regards
  7. do you updated your XP? and do you have enough memory? 256MB is minimal requirement.
  8. Thanks to your link and related wiki articles, I learned that cmov instruction is introduced *before* SSE. As my CPU Intel Core2 Duo T8100 support both of them, the two builds should both work. Anyway I have downloaded IA32 build so I give it a try, and it crashed upon opening (I closed normal build first, then opened IA32 build that I extracted to another directory, so they shared the same profile and opened the same web page): I don't know if it helps, for I am not the targeted user of the build. Just FYI.
  9. Why not push a lot harder and try newer SeaMonkey builds with KernelEx updates? I know, I know, the topic is about vanilla Windows 98, and as much as I appreciate the effort (believe me, I have tried that for some non-sleep nights before, too) the OS will not survive past 2019 without some "performance tweaks". BTW, the KernelEx updates need to be a lot more organized. It's very complicated as of now to get it right. I gave up on Windows 98 eventually, to go for Windows 2000 Professional and BlackWingCat's kernel extenders. For that I updated it to SP4 along with Windows Update downloads, and used an ISO file that I found last weekend, with a very straightforward install of rollup updates for Windows 2000 plus BWC Kex. So far so good, it was faster to set up than Windows 98, and I am using latest SeaMonkey there with no issues as of now (I know there is Firefox 52.9.x ESR, but I dislike the newer Firefox UI), but I still want Windows 98...
  10. Yesterday
  11. Which browser do you want to patch?
  12. Yes KEX users should be aware of this. Talking more about last post, I wiped out a week's worth of system saves thinking I had a bad registry. I am not totally sure of the XP setting I mentioned about FFDSHOW so I just loaded system restore of 2/11/2019, it showed FFDSHOW was NT40 at this time. I was working on this fault for some time as it crept into two separate builds and finally I found out, it was after reinstalling FFDSHOW after LAV that had caused the blackout with two conflicting KEX settings. Blackout also occurred when trying to run CometBird9.
  13. @Wunderbar98 There might be a misunderstanding, but I'm not using this Dillo browser, know zero about it nor have it installed, nor ever seen anywhere except in your posts. Only meanwhile realized it's a Linux app, which for me is the same as "from outer space, can't use". When I'm forced to use a fallback browser, necessary for modern TLS, there's already Roytam's Retrozilla version and his Firefox3.6 (both work in vanilla98) and K-Meleon-Goanna74 (KernelEx2016), all with familiar gecko engine at least. Would not recommend you to consider seriously ancient KM1.5.4 in your vanilla 98. It's engine is much older as in KM1.6 with KernelEx, with crucial features missing, and of course TLS extremely broken too. If you want to use an ancient browser with those TLS probs anyway, you're better off sticking to your own favorite browser, as I do too. It just makes no sense to replace one broken browser with another broken one. As fallback for vanilla98 I'd recommand roytam's Firefox 3.6, since it has a much better engine as FF2: http://o.rths.ml/gpc/files1.rt/fx36vc71-20171108.7z Regarding google, would try killing css-styles. For me that often helps to get blocked or hidden stuff working (for example the Edit-button here ;-) (PS: meanwhile figured out that my old system has only SSE, not SSE2 as wrongly guessed recently)
  14. Am afraid no-one else but you can answer that question ... Only you know the exact configuration of your OS/system and your browsers - the rest of us here trying to help are not clairvoyants; and, as you can imagine, all have our personal issues in both digital (!) and real life... So, when asking for help, be extremely precise about your CPU/OS and browser; and in the case of browser, type/version/architecture/EXTENSIONS/user-modified prefs are of high importance! Then, of course, there are cases where manifested issues are due to factors beyond your control, e.g. hick-ups at your ISP or server-specific outages... Many things can go wrong (but, thankfully, few do at the same time...) ! You have proclaimed your "love" for using Proxies, VPNs and privacy related tools; a shot in the wild, but maybe one of these is the cause for your issues? And I'll emphasise once again that the first troubleshooting step when it comes to browser problems is to START WITH A BRAND NEW (CLEAN) PROFILE (no extensions, default "GUI" and "hidden" settings), using your DIRECT ISP connection - if you can't reproduce the problem there, then you know it's caused by something YOU did... FWIW, all images load fine here: FWIW, plays fine here (Serpent 52.9.0): This is only used within a WebRTC context (not supported in New Moon, but is supported in Serpent 52/55); if you're on Windows XP (with SP3 I presume, fully updated until the EOS MS updates), then by default New Moon 28/Serpent 52.9.0/Serpent 55.0.0 will come with a bundled h264/aac decoder (in the form of a custom ffvpx library - make sure media.ffvpx.enabled (in about:config) is in its default value, true); so you shouldn't have MP4 video playback issues...
  15. > When manually updating KEX reg settings Reg setting are only read when updated via Sheet and when the driver loads (boot and restart). So manual changes require a restart/reboot.
  16. The head on my favorite laptop's internal CD drive will move inward, but not outward (or unpark?). With the tray open, I have to manually pull it outward before setting each new disc in the tray. Then it works again!
  17. When manually updating KEX reg settings like %WINDIR%\SYSTEM\*.AX = NT40 for example, care must be taken to make sure there are no other KEX settings for other registered AX files in the System folder. Best to do a search check. I found out the hard way as FFDSHOW was still registered as XP setting. After LAV was installed FFDSHOW did not work so I reinstalled FFDSHOW this had the effect of blacking out my video whenever NotePad3.exe was started, (no video output) whether it was from clicking on an ini or txt, whatever started up NotePad3. A frustrating error but solved now.
  18. > getting KEX settings correct is not easy Agreed! I'm hoping to add an "Auto" mode setting that allows Kex to analyse each module and use the mode it deems best. Updates for Sheet and Ktree are on the way. Also, a new property sheet handler named pshExports (derived from Sheet).
  19. Ah, yeah. I'm not that into it. And hope I won't need.
  20. Hmm... so my question is: why direct Tek Eye tests doesn't work here, and by WaybackMachine are working? Maybe this same problem to me on Forbes link to test: NO pictures in all RoyTam1's browsers (but works on RoyTam1's Borealis only...): https://www.forbes.com/sites/startswithabang/2017/07/24/sorry-internet-some-of-your-favorite-space-pictures-are-fakes/ Another test - this Twitter video: "The media could not be played" (but play on original website): https://twitter.com/metpoliceuk/status/1176527283563245569 OpenH264 Video Codec provided by Cisco Systems, Inc - I've disabled in plugins here. My mistake somewhere in about:config is possible ... PS. Antutu HTML5 tests (click Test button): https://www.antutu.com/html5/ - I've little window: "parent.RankDataLists is undefined." My result: 12141 points ...(in Serpent 55). HTML5 Demos and Examples: https://bestvpn.org/html5demos/
  21. requires NET 4.5 but it's compatible with XP. LOL https://nvglabs.com/#download
  22. Gotcha...I use wimlib to capture my stuff so that makes sense.
  23. Edited first post, it should now be clear. - Supports all Intel USB 3.1 XHCI controllers (7, 8, 9, 100, 200 and 300 series, maybe even HEDT chipsets).
  24. What Os and what version of PS are you using? How exactly are you calling 7zip? As earlier said, Povwershell 2.0 had some quirks when running external commands, and some were solved or worked around (workarounded?) in later versions. Too many possible root causes to guess.
  25. The LIVE (i.e. non-archived) edition of the Tek Eye test page loads and works fine here (Serpent 52.9.0) : So, whatever issues you're having must be at your end...
  26. Same deprecable and unprofessional attitude on SWRare Iron: Can't believe someone claims Chromium 78.0.4050 eligible for XP. They're better at selling pots or smoke without roast!
  27. Hard to say. I had to add a VBScript to Outlook manually expand all the IMAP root folders, since that's the only way to refresh the inbox counts (which is just dumb). When I did that, folders expanded, and I got an infinite message in the lower right hand corner. I forget what it was, but I documented it on the Outlook setup guide. That made Outlook unusable. Launching outlook.exe /safe prevented that, and I could use Outlook as before, but I could not remove the VBScript macro. Visual Basic editor just did not respond. So I basically had to restore back at that point. Also, there were several other reliability problems, namely crashing all the time, I did decide to give MailNews a go. Actually, it's fairly decent, considering that it's not Outlook. It's much more stable than Outlook of course. There are things I prefer about Outlook and things I prefer about MailNews. It is very similar to the Thunderbird that I tried, although it's significantly leaner. The last time I used TB, it used so much memory, maybe 6 or 7 times as much as Outlook. Then again, that might have been because I connected all my accounts to it - but I also did that with Outlook. I only connected 4 accounts to MailNews to test it out, but it's decent. A lot of settings need to be changed, so I took the time to make a setup guide for MailNews on W2K as well. Since neither Outlook 2007 nor MailNews supports Exchange in practice, there's less of a disadvantage to using MailNews than otherwise. I can import my calendar as an ICS in both that auto-refreshes anyways, and I need to import my contacts either way. In this case, although I much prefer the Outlook interface, even 2007, I might use MailNews as a main client because of its stability. I can't put up with all the Outlook crashes. Also, because the VBScript isn't quite working for me (or at least causes another Outlook issue), I can't get updated inbox counts with manually clicking on them all. With 9 accounts, I refuse to do that. I do want it working though, as I could use it just for the calendar maybe. And as an alternative client. Anyways, huge tangents, but good to know. MailNews is much better than TB, even though most of its annoyances are the same since it's basically the same thing. It does have the older feel too. EDIT: I think the version.dll swap MAY have broken something. In all past restores, Outlook would start working again. I did do the version.dll swap, and I just set up an Outlook account, and it prompts for the password forever again. So version.dll didn't fix anything with encryption, and it broke Outlook completely. Well, hopefully that means it won't be too hard to shimmy W2K into doing more things it wasn't designed to do! I'm hopeful there's a fix. I'd say this is really the last major issue left to be tackled. Outlook 2007 is working about as good as it will ever work, or could be expected to work (Outlook 2010 on XP, a support configuration, is more stable or useful, really, apart from a nicer interface). So, as soon as I can edit and save encrypted Word and Excel documents, that means I can pretty much fully switch to W2K. There's nothing else I do on a daily basis that I can't do in W2K; last night, we didn't some testing, and I can even run emulators and VoIP softphones in W2K, which I didn't think would work!
  28. Same here; IMHO, I don't think that would be cause for any breakage... I checked AniView specifically: Update checks are made via the CodeDead.UpdateManager.dll file; in https://github.com/CodeDead/AniView/commit/2e9cb99 it appears it is accessing the following URI: https://codedead.com/Software/AniView/update.xml That one correctly loads in Serpent 52.9.0 through TLS v1.2: <Update> <MajorVersion>1</MajorVersion> <MinorVersion>5</MinorVersion> <BuildVersion>3</BuildVersion> <RevisionVersion>0</RevisionVersion> <UpdateUrl>https://codedead.com/Software/AniView/AV_setup.exe</UpdateUrl> <InfoUrl>https://codedead.com/?p=2217</InfoUrl> <UpdateInfo> Version 1.5.3 is now available! Please click the download button to download this version. </UpdateInfo> </Update> ... but DOESN'T LOAD in IE9 (TLS v1.2 enabled) https://www.ssllabs.com/ssltest/analyze.html?d=codedead.com&s=185.94.230.248&latest shows that the server is configured to ONLY connect through TLS v1.2 with only 4 cipher suites: TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (0xc030) ECDH secp256r1 (eq. 3072 bits RSA) FS 256 TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (0xc02f) ECDH secp256r1 (eq. 3072 bits RSA) FS 128 TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384 (0xc028) ECDH secp256r1 (eq. 3072 bits RSA) FS WEAK 256 TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256 (0xc027) ECDH secp256r1 (eq. 3072 bits RSA) FS WEAK 128 ... NONE of which are supported in IE9 "CodeDead.UpdateManager.dll" loads system network+crypto resources to access that URI (dependency walker reveals it loads, among many others, crypt32.dll, wininet.dll, secure32.dll, cryptui.dll, ieui.dll, ncrypt.dll, bcrypt.dll), so it appears it can't establish the secure connection that way and aborts... As per my analysis above. at least AniView.exe+CodeDead.UpdateManager.dll require just TLS v1.2; as for more testing, I'd be curious to know whether its "Update Check" feature works OK with .NET FW 4.8 on Win7+; if not, the developer should be made aware... Best regards
  1. Load more activity
×
×
  • Create New...