Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


All Activity

This stream auto-updates     

  1. Past hour
  2. Did you download from the "version 9.2.6" or "version 11.8.3" link? Download version 9.2.6. It will give you options for Office 2007 and 2003. Yeah, probably not. That version doesn't even work natively on XP - it targets Vista and up. 3.8.0 is the last XP compatible version; maybe that could work with the APIs you do have. And I'm actually not sure if I had 7zip 19 installed before extended kernel. But v16 isn't radically different.
  3. Doesn't work. Office tab is only 2013 and 2016 and "legacy Office" only has 2010. 2007 does not appear anywhere. I guess I need all the updates from SP3, hence the tool? An unofficial SP4 for Office 2007 might be nice. Come to think of it, a service pack released from MSFT right whenever extended support ends, for all those continuing to use the OS. Okay, I'll give that a try and see if MKVs work. I think 1.1 just didn't have MKV support. The link on the page says it didn't work though (from MSFN). I'm not sure if I have those checkboxes specified enabled, probably not if that's not the default. I tried it and it didn't work. By tried, I mean I tested each of the portable installs down and down until one worked, and then I installed the full software. I did that for a few different programs, including 7Zip. They claimed to still support 2K but it didn't seem like the very latest one did. Oops, well as long as it's about W2K! I do need to fix the encryption issues though. Any thoughts on what I should try now, esp. since WSUS offline doesn't work? In theory, since there are no more updates to O2K7, all the updates are somewhere and could be manually downloaded. At least the relevant ones, but I'm not sure where. MSFT is pretty good at hiding and deleting stuff once they no longer like it.
  4. I was downloading POSReady2009 updates manually. WSUS offline didn't work for my use-case. Didn't try windows update mini tool so I don't know if it works. If you need them in one installer, someone needs to wrap them for you into one package.
  5. @Dylan Cruz Try WSUS Offline Update ESR version (http://download.wsusoffline.net/) to download/install your Office updates. The Windows 2000 High Encryption Pack provides 128-bit encryption to Internet Explorer and similar MS applications I believe; necessary for online banking. It doesn't have any bearing on the encryption techniques used in newer versions of Office; especially since WPS doesn't mind opening it. The "high encryption pack" for Office mentioned in that error message doesn't seem to exist, or it was probably only released to certain corporate customers. VLC 3.0.6 and up are broken on win2k presently (can't play videos), but 3.0.0 and maybe a few newer than that are functional. And this basically says that FileZilla 3.25.1 works, and maybe even a newer release since that was posted 2.5 years ago. 7zip 19 continues to work on vanilla win2k. I just realized that we steered badly off-topic, then went back on-topic for a bit, just to derail it again.
  6. Yesterday
  7. I've never been able to get Windows Update to work. I can finally load a page, but it just redirects to something saying your browser is not supported, all wonky formatting and everything. Well, I ought to have it then and it ought to work, but it doesn't. Weird. I've tried a number of codec packs, including that one. None of them worked, and they all turned out to be more like bloatware/adware/crapware/malware than legitimate software. In fact, one of them screwed things up so badly I had to completely restore Windows. Terrible experience! VLC 3? Wow. I only tried 1.1 on vanilla W2K and it didn't work. These are the latest versions for vanilla W2K: Adobe Reader 9.5 7Zip 16.04 PuTTY 0.67 FileZilla 3.0.11.1 VideoLan VLC 1.1 So VLC can be upgraded past 1.1 with KernelEx, even all the way to the very latest release (3.0.8)? What would really be nice is a newer FileZilla. 3.0.11.1 lacks support for synchronized browsing, which makes server transfers a real pain. Ditto for PuTTY, since KiTTY was forked off a version of PuTTY that had dropped W2K support.
  8. You probably saved the document in Word 2010 or newer, which effectively made the encrypted document incompatible with 2007. Installing all updates to EOS for Office 2007 may help though. I think Microsoft Update still works and if not, there is WSUS Offline Update. The high encryption pack is integrated into the OS with SP2 and above. Before that, it was supplied on a floppy disk separate from the OS due to the U.S. cryptography export laws. The HFSLIP files. I believe that the new version can work, with one of the conditions I mentioned above, but otherwise it's a little ropey. I don't have any mkv files to test though, but I remember doing so in VLC 3.0.x at one time. Have you tried the K-Lite Codec Pack 13.8.5? That claims to better support MKV than VLC, and it works with WMP on W2K.
  9. New build of Firefox 45ESR: Test binary: SSE https://o.rths.ml/gpc/files1.rt/firefox-45.9.18-20191207-082eb5b14-win32-sse.7z IA32 https://o.rths.ml/gpc/files1.rt/firefox-45.9.18-20191207-082eb5b14-win32-ia32.7z repo: https://github.com/roytam1/mozilla45esr Changes since my last build: - import changes from tenfourfox: - #578: M1322864 M1585106 M1597043 (7758ebb12) - #578: M1579060 M1586176 (f3f295615) (5a4e033f1) - import UXP change: - [NSS] Bug 1508776 - Remove unneeded refcounting from SFTKSession (836e72e96) (082eb5b14)
  10. New build of BOC/UXP for XP! Test binary: MailNews Win32 https://o.rths.ml/boc-uxp/mailnews.win32-20191207-dcb628c2-uxp-2529b2ede-xpmod.7z Browser-only Suite Win32 https://o.rths.ml/boc-uxp/bnavigator.win32-20191207-dcb628c2-uxp-2529b2ede-xpmod.7z source patch (excluding UXP): https://o.rths.ml/boc-uxp/boc-uxp-src-xpmod-20191123.7z Official repo changes since my last build: - [UXP] Update branch commit pointer (09652b30) - Stop leeching off Pale Moon for emoji font as it is now in toolkit (097c59d1) - Remove extraneous subst (a4f7be09) - Stop leeching off Pale Moon's searchplugins (1f572f64) - [Navigator] Remove local search engines (c69988a8) - Remove Submodule (428b986a) - Change the MOZILLA_DIR path (726bbcba) - Add submodule (81f26254) - [Mail] Update wordmark (3b02cc2b) - Update version2k to work with any version length and use an a1 suffix on generated msbuild stamps (2f39aed7) - Use version2k for navigator (376ed48c) - Add command to version2k to JUST get YYYYMMDD (ca746757) - Access version2k from fake mach (344876fb) - Use MOZ_PKG_SPECIAL to append MOZ_WIDGET_TOOLKIT to the end of the package name (e11b29ea) - Update platform commit pointer (f1a2c83a) - Update fake-mach to properly init the submodule (c2045698) - Revert "Use MOZ_PKG_SPECIAL to append MOZ_WIDGET_TOOLKIT to the end of the package name" (11c60055) - [Navigator] Remove about:rights (53e06224) - Part 2 (c911ab2c) - [Navigator] Conform official branding to unofficial (8cbab84e) - [Navigator] Remove unused files from official branding (5fbedf22) - [Navigator] Add real official branding (1e9340e5) - [Navigator] Add mac icons (a009838b) - [Navigator] Make the throbber dependant on application branding (f7f5004c) - [Navigator] Put the throbber back on the toolbar by default (6f1f3e1e) - [Navigator] Allow the print toolbar button (796df9df) - [Navigator] Use brandFullName for main window title (23750538) - [Navigator] Fix official throbbers using forbidden Moonchild powers (dcb628c2) For UXP changes please see above.
  11. New build of Serpent/UXP for XP! Test binary: Win32 https://o.rths.ml/basilisk/basilisk52-g4.4.win32-git-20191207-2529b2ede-xpmod.7z Win64 https://o.rths.ml/basilisk/basilisk52-g4.4.win64-git-20191207-2529b2ede-xpmod.7z source code that is comparable to my current working tree is available here: https://github.com/roytam1/UXP/commits/custom IA32 Win32 https://o.rths.ml/basilisk/basilisk52-g4.4.win32-git-20191207-2529b2ede-xpmod-ia32.7z source code that is comparable to my current working tree is available here: https://github.com/roytam1/UXP/commits/ia32 NM28XP build: Win32 https://o.rths.ml/palemoon/palemoon-28.8.0a1.win32-git-20191207-2529b2ede-xpmod.7z Win64 https://o.rths.ml/palemoon/palemoon-28.8.0a1.win64-git-20191207-2529b2ede-xpmod.7z Official repo changes since my last build: - Remove unnecessary calls to ReparentFloatsForInlineChild in nsInlineFrame. (6ea8e51aa) - Issue #1302 followup - Add spec-compliance checks/errors (d88f471cb) - No issue - Clean up libxul mozbuild a little (a2a84fcb2) - Issue #1307 - Part 1: Remove MALLOC_VALIDATE (a7878bacf) - Issue #1307 - Part 2: Remove disabled code blocks (388073a03) - Issue #1306 - Move bundled fonts to toolkit (5102aa579) - Issue #1307 - Part 3: Assume MOZ_MEMORY is always enabled. (a954e19ea) - Issue #1307 - Part 4: Stop using variable-length arrays. (b4b589a11) - Issue #1307 - Part 5: Remove allocation tracing. (90508a464) - Issue #1307 - Part 6: Remove dead code behind PTHREAD_MMAP_UNALIGNED_TSD (3b361d830) - Issue #1307 - Part 7: Add missing MALLOC_STATS (75c7e4749) - No Issue - Don't use a hard coded path for win_srcdir in comm-style configurations (f6fb48d08) - Issue #1308 - Create nsDisplayTableBackgroundColor to avoid display list collisions when processing the background color of a table. (0f001155a) - Issue #1309 - Fix handling of display rows where the elements are not forming a monotonically increasing sequence (e.g. with position:sticky) (cb65f6d10) - Merge branch 'master' of https://github.com/MoonchildProductions/UXP (2554b96d6) - No Issue - Add checking in platform/ for clobber.py because it can only know hardcoded values in comm-style configurations (c8d03b9fe) - Issue #1307 - Part 8: Remove deprecated sysctl.h inclusion. (fcc84d7b9) - Merge pull request #1310 from MoonchildProductions/jemalloc_cleanup (b8a16acae) - Issue #1313 - Bump Firefox compatMode version to 68.9 (246bf49b0) - Properly detect failure in receiving plugin NPObjects. (74f15fb2d) - Use mutex in PACResolver when accessing mRequest from multiple threads. (d8282a0da) - Check if we're already at the end of the frame's content. (44967b330) - Update identifier map entries and notify if they get removed. (5d4c82e09) - Fix incorrect values for saving ordered lists as text. (e287979b3) - Initialize all fields of GdkEvents in nsClipboard.cpp (d558cf664) - [NSS] Bug 1508776 - Remove unneeded refcounting from SFTKSession (836e72e96) - Check return value of PeerConnectionImpl::GetFingerprint. (9811aa2e1) - [NSS] Bug 1586176 - EncryptUpdate should use maxout not block size. (d927df43e) - Add missing call to WaitForIsDebuggerRegistered (c0ab25726) - Update NSS version. (2529b2ede) My changes since my last build: - keep using upstream NSS-3.44.3, with NSS Bug 1508776 applied.
  12. Can't be. I've used this same Word document since 2012. It's successfully openable on Word 2010, Word 2013, Word 2016, Word 2019, and Office 365 Word (basically Word 2019). I also want to say I could open it when I tried this on XP, but I'm not positive. Maybe I didn't try it. But it seems it did change between 2007 and 2007 SP3 or 2010, but not since then. Any idea where to get the encryption pack (High Encryption Pack)? When I look it up, the first result is "Windows 2000 High Encryption Pack - Free download" from cnet, but that looks sketchy. This site also confused things by saying I already have it, which also doesn't make sense: https://www.petri.com/download_w2k_high_encryption_pack Wait, you mean the good copy of riched20.dll from the original ISO files or the HFSLIP files? So basically, KernelEx replaces the good DLL with a bad DLL, and it has to be changed back? Odd that it does that... The broken DLL is a lot larger than the good one, too. Also, can you play MKV files in your W2K? VLC always gave me some kind of error, is a codec needed?
  13. OK, I made an encrypted document in Word 2016 and got the same message as you did when I tried to open it in 2007. I think it has to do with the fact that encryption methods change with almost every Office version. WPS Office 2016 did open that file though. And on another note @Dylan Cruz, you don't need to download USP 5.1, as you can obtain a good copy of riched20.dll from the slipstreamed install media. Installing the extended kernel twice with DX10 option unchecked (with it checked, it was only necessary to install once) will (usually) allow for the "Windows 2000 Power Pack" start menu folder to appear with fcwin2k, NNN4NT5 etc. Apparently if it's installed thrice it will eliminate riched20.dll's VC++ 2008 dependency issue, but I've yet to test it.
  14. Guys, how hard can you make this? Facebook will nag you if it sees you're running FF 45. I recommend going into about:config, creating a new string preference called general.useragent.override.facebook.com, and setting it to Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0. @roytam1's FF 45 builds support SSUAOs of this kind, so this will tell Facebook you're running FF 57 on Win 7, and it won't nag you anymore. No need to install any browser add-ons. Please don't do this! It's not required and will only disable the above setting, ensuring you get nagged by FB to update your browser. As explained earlier, FF 45 doesn't have built-in support for h.264 video. You need to add something.... Since those browsers run on your PC, you have an sse2 processor; therefore, you could install the Adobe Primetime CDM using the instructions at the first post of @mixit's thread. I've confirmed that Primetime works with @roytam1's FF 45 builds. However, most FF 45 users probably don't have sse2 processors. Those users should instead download the @roytam1 LAV filters for their architecture (links are in the first post of his original thread), and unpack them into the same folder as firefox.exe. Either method will let FF 45 play videos. I believe other possible methods (e.g., Flash, Silverlight) are no longer supported by FB, but I may be wrong about that.
  15. What? My SP3 installer exe is only 351 MB. How large was yours? That's what I found too. SP3 is greyed out for change/remove. I haven't tried that, but I'm referring to open document not encrypted on this PC. If you encrypt it in a newer version of Word and try to open it there, does it work for you? Also, based off of your suggestions and what we've tried, we put this guide together: https://w2k.phreaknet.org/guide/ Not 100% comprehensive yet, because I need to figure out what is up with encryption and I haven't even opened Outlook yet... I'm dreading that. What do you think? The goal was to make it as comprehensive as possible, so if anyone wants to do this in the future, nothing is left to guesswork and it's all laid out. Hopefully, more people will be able to use Windows 2000 then, especially as people are led to believe they need to stop using Windows 7 soon.
  16. That's also weird. I just installed SP3 (which needs 1.5 GB of HDD space by the way). It's greyed out in add/remove programs, but Office 2007 itself is not. It was specified as such in the "about" box; I was able to use several features introduced in SP2/3, including PDF exportation. I also created an encrypted Word document, which I was able to open successfully afterwards.
  17. the updates of WSUS tool are all named as embedded (116 in total) how do you download POSR 2009 updates and install them all offline with a single click ?
  18. Is it time for "mom I am Hungary" joke? Sorry I had to Welcome anyway
  19. Windows XP Embedded and POSReady 2009 are two variants of the same system. They based on the same XP core, so most updates are interchangable. If you updated your system with a bunch of XP Embedded updates, their variants for other XP flavours will not be visible, as this patch is already installed. Until 2016 (Windows embedded End of Support), M$ published patches for both Embedded and POSReady as the very same file, see here for example. After 2016, Embedded was no longer supported, so they are named POSReady 2009 patches in the catalogue :) tl;dr this is expected behaviour.
  20. This is MSFN, we're all interested! The vogons forums is also a great place to post your wonderful discovery! What version of SMP Player? I've tried running 0.98, but it's slidebar won't work at all.
  21. Malwarebytes Free 2.2.1.1043 is also known for a fact to be working online: I just updated to database v2019.12.06.08. However, for 5 months or more @Queroexperimentar has been inquiring about something for an XP system that is kept offline, and it sounds like Malwarebytes might not be the solution. Maybe try Avast 18.8 (or AVG 18.8, which is practically the same thing), but I have not investigated offline updates.
  22. I managed to test the WOW Animal "So Sad!" video on Firefox 45.9.18 ESR (11232019), and was able to play the video as long as I didn't have a useragent override (general.useragent.override) setting in place. I also set general.useragent.site_specific_overrides to false. It seems as if both of those conditions have to be met before the video will play.
  23. It's an independent aplication, a compiled AutoHotkey script that runs as any other application and captures the Clipboard operations. When anything is copied to the Clipboard it analyzes the contents and if it matches any of the predetermined patterns it processes it and copies the result back to the Clipboard so the user can simply paste the processed result to a browser's address bar, a text file or wherever they want. That's precisely why I mentioned them. Older versions of those add-ons may be found to work with 9x-compatible browsers or newer versions could be modified for 9x compatibility. Either way, some people may just want to find out about them regardless of their OS version, as they are really useful IMHO.
  24. Uh, as soon as I did that, this dialog popped up that said: Windows File Protection Files that are required for Windows to run properly have been replaced by unrecognized versions. To maintain system stability, Windows must restore the original version of these files. Insert your Service Pack 4 CD now. Uh, thanks Microsoft, but no thanks. The options are "Retry", "More Information", and "Cancel". Thankfully, I could click cancel. Not like Windows 10, where the only options are "OK" and "OK!" Good news! This did it! I can now type in the dialog. I activated Office and proceeded to open a file (no barriers when opening Word, it's awesome!) I happened to choose an encrypted file and got this: You might receive this message if you attempt to open an encrypted document that was created with releases beginning with the 2007 Microsoft Office suite Service Pack 2. Installing the latest service pack will allow the document to be opened in most cases. If you have installed the latest service pack and still cannot open the file, this document has been encrypted using an encryption type not installed on this computer. To open this document, a matching cryptographic service provider must be installed on your computer, even if you typed the correct password. If installing the latest service pack does not resolve the problem, try one of the following: Contact the author of the document, determine the encryption type used to encrypt the document, and then install the matching provider on this computer. Contact the author of the document, and then request that the encryption type be changed to one available on this computer. Request a copy of the document that has not been encrypted. This is not a recommended alternative. Considering I DO have SP3, this makes no sense. It says the encryption type is not available. More encryption types are available using the High Encryption Pack (C:\...\Content.MSO\AE2CFA84.docx) Any ideas on how to fix this, either getting the High Encryption Pack or, more mysteriously, why it somehow thinks I don't have SP3 when I do have SP3? Also, in Control Panel, the Change/Remove button for SP3 is not clickable. This isn't the end of the world, because I suppose I could re-encrypt the file, but I'd rather fix the actual issue since this is not my only encrypted file. What's mysterious is this Word document dates back to 2012, and it was created using Office 2007. Probably with SP3, but I have SP3, so... Yup, I think it was... On another note of weirdness: I just installed the RDP client for W2K. It wouldn't install because it thought it was already installed, so I changed the variable back to 2000 SP4 and then it worked. Just to see, I opened up Word, then Excel - they work just fine now, even though it doesn't think it's XP anymore. I guess that's how yours is set up, so it's not as strange as it might be otherwise.
  25. Yeah, New Moon's UI is the same as Pale Moon. That msvcr90.dll dialog can be fixed by replacing riched20.dll in system32 with the one from your Windows 2000 ISO (which will appear there as riched20.dl_; extract with 7zip). I think that should help you with your product key situation, given that riched20.dll is the backbone of the OS' Rich Text Format engine. That's used to display EULAs in Windows installers, so I wouldn't be surprised if it had something to do with product keys as well. I've never seen the "DDE Server" window though. It's probably linked to the riched20.dll/msvcr90.dll issues.
  1. Load more activity
×
×
  • Create New...