Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

All Activity

This stream auto-updates     

  1. Past hour
  2. StartisBack++ 2.6.3 not supporting RS5

  3. Today
  4. VirtualBox is not ideal for Windows 9x emulation. It never was. You would be MUCH better off using 86Box. It properly emulates variety of old hardware, including old CPUs, GPUs and of course sound cards, including SB16, AWE32, Roland MT-32, Gravis Ultrasound, AudioPCI and some more. With it, you just use the original drivers, just as you would have the original hardware. https://github.com/86Box/86Box You need to download the ROMs first, create a blank hard drive image first, and best option is to use the latest available motherboards they have on offer. Older ones are better for Win95/Win3.1/DOS 6.22. Have fun!
  5. Beta channel for Adobe Flash Player has been updated. Version was released May 24, 2018. Tested and working on Windows 2000. Internet Explorer ActiveX: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player_ax.exe Mozilla Firefox NPAPI: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player.exe Old version uninstaller: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/uninstall_flash_player.exe You can also always find the latest versions in my flash_beta directory.
  6. Newest Adobe Flash and Shockwave, and Java, too!

    Beta channel for Adobe Flash Player has been updated. Version was released May 24, 2018. Tested and working on Windows XP. Internet Explorer ActiveX: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player_ax.exe Mozilla Firefox NPAPI, and NPAPI for Google Chrome 44 and older: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player.exe Google Chrome 45 to 49 PPAPI: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/install_flash_player_ppapi.exe Old version uninstaller: https://fpdownload.macromedia.com/pub/labs/flashruntimes/flashplayer/uninstall_flash_player.exe You can also always find the latest versions in my flash_beta directory.
  7. while finding directions about rz-dev, I heard that classilla ported newer JS engine to Clecko(gecko) 1.3.1. I pushed their releases to my tracking repo: https://github.com/roytam1/classilla and even fixing it for win32 and put phoenix-0.5 front-end on it, binary: http://o.rthost.cf/gpc/files1.rt/phoenix-0.5-cl933.7z hope I can have time to port it to rz.
  8. New build of basilisk/UXP for XP! Test binary: Win32 http://o.rthost.cf/basilisk/basilisk52-g4.1.win32-git-20180526-8f354e52d-xpmod.7z Win64 http://o.rthost.cf/basilisk/basilisk52-g4.1.win64-git-20180526-8f354e52d-xpmod.7z diff: http://o.rthost.cf/basilisk/UXP-xp-gitdiff-20180409.7z Official repo changes since my last build: - [MSE] Add a missing comma in validBoxes (91825ae7f) - Update libhyphen's glue code to include overloads for fgetc() and feof(). (a2c339417) - Merge pull request #375 from trav90/media-work (5aafe792b) - Remove gfxCrashReporterUtils. (fc001cc5b) - Remove gfxCrashReporterUtils leftover. (1309bdb54) - Remove GMP, Plugin and IPC crash reporter hooks. (fbdd52ea5) - Remove stubbed IPC CrashReporter(Parent/Child) (a3e8c9f82) - Remove IPC CrashReporterClient/Host (612459488) - [PALEMOON] [frontend vs backend] Places - fix: adding a livemark doesn't work correctly (30cbf0b5a) - Remove the Dark Matter Detector (DMD) Memeory debugger component. (fcd7ee3c8) - Merge pull request #379 from janekptacijarabaci/pm_places_livemark_add_1 (542da56e2) - Remove the jprof profiler. (94988a2b4) - Remove CrashReporterParent leftover. (c8b38a180) - Remove SPS profiler. (ac25827a8) - Remove IPC profile functions. (19334fd5a) - Remove CrashReporterParent leftover. (b565e2c22) - Remove the Social API (3a9d1b535) - Remove MOZ_SOCIAL. (f786134c4) - [MSE] Correct ADTS frame size calculation (e2464b139) - Merge pull request #383 from trav90/media-work (b43a5fbed) - Perform null check earlier in OggCodecState.cpp (43470083d) - Null check the right pointer in RecvReadback (6ca361bd5) - Revoke MediaDataDecoder callback after RemoteVideoDecoder has been shut down (f2d541d3e) - Merge pull request #385 from trav90/media-work (edccc615f) - Merge pull request #381 from Ascrod/master (d5459982f) - Revert "Remove the Social API" (72bab89cf) - Merge pull request #386 from MoonchildProductions/revert-381-master (8f354e52d) PM28XP *sneak peek* x86 build: https://o.rthost.cf/palemoon/pm28xp-sneak-peek-win32-20180526-8f354e52d.7z Disclaimer: This sneak peek build is ONLY for previewing next major version. It may contain bugs and/or missing functionality and is NOT ready for daily use. DO NOT use it in production.
  9. New Palemoon 27 Build! 32bit https://o.rthost.cf/palemoon/palemoon-27.9.1a1.win32-git-20180526-23668d3d5-xpmod.7z 32bit noSSE https://o.rthost.cf/palemoon/palemoon-27.9.1a1.win32-git-20180526-23668d3d5-xpmod-ia32.7z 64bit https://o.rthost.cf/palemoon/palemoon-27.9.1a1.win64-git-20180526-23668d3d5-xpmod.7z My changes since my last build: - Update NSS to 3.36.2
  10. New regular/weekly KM-Goanna release: https://o.rthost.cf/kmeleon/KM-Goanna-20180526.7z Changelog: Out-of-tree changes: * My changes since my last build: - Update NSS to 3.36.2 - Updated es-ES locale In-tree changes: * fix CanCopy2() when handling framesets (888e6d5) * Notice: the changelog above may not always applicable to XULRunner code which K-Meleon uses.
  11. Win10 x64 forcing Administrator in Explorer

    Thanks. That IS good information, and I thank you. I tried running it against the explorer.exe file in c:\windows\syswow64 but I got a "Handle is invalid" error message. Unsure why, I am doing this in a command prompt window running as Administrator, using my user account in Windows 10 which is the ONLY account on the system and which IS an Administrator account. Either icacls cannot run against system files or there's some step I'm missing. I have a call in to Microsoft tech support which will HOPEFULLY shed some light on this, but I don't know. I did find out through their AI system (A: = "Almost Intelligent" ) about a glitch where the latest update to Windows 10 can force Internet Explorer into permanent Administrator mode, but I don't know if that applies to my situation as well. Something worth pursuing with the tech when he comes on the phone. (I was supposed to have a call with tech support at 1900 today, and the call came in at 1945 but he apparently couldn't hear me when I answered the phone because he was only there for a moment and then hung up. Bummer.) //S//
  12. While in the process of setting up a Windows 98 Second Edition virtual machine on VirtualBox, I've been trying to find an AC97 sound driver because, at the moment, I can't get any sound at all regardless of seemingly any audio controller I give it. So far, I've tried two drivers and both of them got me nowhere. Realtek is what I tried first after seeing some forum posts mentioning this while googling for research. After that didn't work, I tried SiS 7012 after seeing a mention of it and it too wouldn't work. I know I would use Soundblaster 16 as an alternative but I prefer GM Wavetable synth as it sounds better to me. I have been back and forth switching between .ISOs and performing countless VM reboots to install drivers and at the moment, progress has come to a halt when trying to get an audio driver to work. Any recommendations of missing solutions or alternatives are appreciated.
  13. Feature requests

    Use virtual desktops, move the window there, ???, profit?
  14. Feature requests

    I second foe's request. I'd like to see the watermark removed on the beta builds if we've paid for the product & have the donation.key. It does take quite a long time for the beta versions to become official builds. Also, it'd be nice if something could be done with the DWM command window. It's easy enough to minimize, but it keeps popping back up, sometimes multiple times, when launching certain apps. This gets in the way & is very annoying. I wish there was a way that it can just log this information without the window always having to be present. Again, especially for the paid members that have the donation.key
  15. Yesterday
  16. A bit late to the party. But anyway, for future users. Yeah everyone now thinks "Who cares for ancient FF2 probs today? Long since obsolete." But not true! This is important for much younger Gecko engines too: there's a whole settings-family which is extremely handy yet extremely unknown. Mozilla hides them away so well that they don't even appear on aboutconfig! Although they WORK, and great. This GLOBAL pref blocks frames+iframes: permissions.default.subdocument 0/1 = allow all / 2=block / 3=same domain Handy: blocking 3rd-party iframes helps to get rid of lots annoying stuff, e.g. social media The best thing is, there are lots more types available for PERMISSIONS:DEFAULT.XXXXX And another best thing, for some types are black/whitelist exceptions possible, which are stored in profile/permissions.sqlite (Just be aware exceptions work bottom-up not as expected top-down!) An xpi-addon for handling the global prefs is "Block Content" An xpi-addon for site-exceptions is ExExceptions. Both addons handly only some types not all, but manually toggling other types is easy. Type "subdocument" really works already in FF2 too. Just tested on the given testpage above with roytam1's updated Retrozilla build of FF2 (with TLS1.2) Of course for newer Firefox versions there are more types available as for older ones, but don't know which for what. Just try. In my trusty old K-Meleon1.6 (sibling of FF3.5) am using a whole bunch daily, with buttons for global toggling of stylesheets, script files, XHR, media, embedded plugin stuff, etc. For **modern** Firefox-versions there's a very long list of permissions.default.xxxx types: https://dxr.mozilla.org/mozilla-beta/source/extensions/cookie/nsPermissionManager.cpp "other", "script", "image", "stylesheet", "object", "document", "subdocument", "refresh", "xbl", "ping", "xmlhttprequest", "objectsubrequest", "dtd", "font", "media", (==> for HTML5 video!) "websocket", "csp_report", "xslt", "beacon", "fetch", "image", "manifest", "speculative",
  17. Hi, I'd like to replace .dll file in a .cab. My understanding so far is that files inside .cab reflects an .inf when compiled. Its said this inf file isn't usually available to end user, however, some instructions on the net imply otherwise: I followed these steps and a new .cab is output, however when the cab is used by installer, install halts half way; 'eg.dll file missing. To be clear the supposed missing file isn't the one that was 'patched'. Are these instructions correct? I can provide files. Guidance would be greatly enjoyed.
  18. Hi shorterxp, Thank you for your donation of $10.00. We look forward to improving the forums and stay online with your donation. Thanks MSFN
  19. KernelEx for Win2000

    Thanks for your reply. I need to write a HTTPS proxy service now.
  20. KernelEx for Win2000

    1.) Way I understand it, that's not something stunnel can do for you, as it requires one specific local socket for each server you want to connect to. This is especially problematic with HTTPS due to the branching nature of HTML. Say you set up an unencrypted listen socket localhost:4000 with stunnel, mapping that port to securewebserver.com:443. That would make your initial HTTP connection secure (http://localhost:4000, which would be redirected to securewebserver.com:443). However, your webbrowser now downloads HTML, which will have lots of <a href="someurl.com"> inside, plus JavaScript which does god knows what. Your stunnel is unaware of the contents of that HTML and your webbrowser is unaware that its initial connection was being tunneled. So your browser will just parse all those hyperlinks and try to open up connections to them directly, thus bypassing your stunnel. As you can see, this can never work for outbound connections of this kind. Plus there is no way to just "catch" all those connections and wrap them up in HTTPS - this would have to happen at the kernel level, inside the TCP/IP stack (I believe). I know of no such approach ever having been pursued. Either it's single connections to single servers that you can create a local listen socket for specifically in the stunnel configuration, like this... [SuperSecureServer] client = yes accept = connect = securewebserver.com:443 verifyChain = yes CAfile = ca-certs.pem checkHost = securewebserver.com OCSPaia = yes ...or stunnel is the wrong tool for the job. It's much more useful for securing servers rather than clients. I assume the software to use here would rather be a modern enough web proxy server, that accepts HTTP within the LAN, but attempts (secure) HTTPS to the outside world whenever possible. I'm not knowledgeable about proxy servers though. Plus, the user wouldn't really see when a connection is encrypted, like we do know with the "lock" icon etc., because the client would be talking to the proxy in plain HTTP. 2.) I'm sorry, but I'm not sure what that question means. You mean ca-certs.pem? @DanR20: Nice to know!
  21. Win10 x64 forcing Administrator in Explorer

    https://msdn.microsoft.com/en-us/library/bb625960.aspx more info
  22. Win10 x64 forcing Administrator in Explorer

    I had to do some looking because I had never heard of the icacls command. I'm still unclear of exactly what it does or how to use it, so I'm wary of proceeding from this point. Perhaps you could elaborate? Thanks.
  23. Win10 x64 forcing Administrator in Explorer

    That was the first thing I looked at. No such property settings exist. I made no such changes, and I checked just now and no settings of that sort exist in the file properties.
  24. TLS 1.1 and 1.2

    Today I tested a site that I used to open using Firefox 'cause Chromium didn't manage to load it, but after I added all the registry keys and rebooted, it actually worked fine on Chromium. I also loaded a TLS tester website and it worked fine on Chromium. So it seems that Microsoft really did it for client usage as well and not for IIS etc only. Check it out:
  25. Win10 x64 forcing Administrator in Explorer

    with icacls /setintegritylevel
  26. Win10 x64 forcing Administrator in Explorer

    Check and see if explorer.exe properties has it set to always run as admin.
  27. My build of New Moon (temp. name) a.k.a. Pale Moon for XP

    Just happened to make an icon. I dunno if anyone cares for it, but I'll post it anyway.
  1. Load more activity