Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


All Activity

This stream auto-updates     

  1. Past hour
  2. https://o.rths.cf/boc-uxp/ BNAV Browser (RT) https://msfn.org/board/topic/177125-my-build-of-new-moon-temp-name-aka-pale-moon-fork-targetting-xp/page/101/?tab=comments#comment-1158936 BNAV Browser (RT) -- Supports LANGUAGE PACKS via modification of XPI file at URL above. https://www.seamonkey-project.org/releases/#langpacks There is a POLISH Language Pack available. https://archive.mozilla.org/pub/seamonkey/releases/2.49.4/langpack/seamonkey-2.49.4.pl.langpack.xpi I have NO IDEA if that the 'BNAV Browser (RT)' supports ALL that you need it, specifically *.SWF files. LEGACY Extensions supported: uBLOCK Origin -- User Agent Switcher -- (And More LEGACY SM Extensions)
  3. Today
  4. When I installed it from the official page. I expected to find the Google account login option, but it prompted me to the 360 account instead. This way it's impossible for me to sync my bookmarks, autofill and passwords across browsers and since I have no intention to install 360 on my mobile as well nor to register for an account, I'm not gonna use it.
  5. @Dave-H I found the cause of why when FF launches it kept asking me to install a addon again in the profile there was a extention folder with extentionds in, these were what i was being asked to install again I removed that it seems now they stick, and I don't get asked again Hoping lol
  6. I don't have an 360 Account and was never asked to create one.. When does it ask for it?
  7. Guys, I found an application that requires .NET Framework 4.7.2 - dnSpy is .NET debugger and assembly editor. https://github.com/0xd4d/dnSpy And yes, it works on Vista! Unfortunately, I'm not yet so cool to use it. Portable application. Does not require installation.
  8. Very first post: These prefs don't really matter when running FF 52.9 on WinXP, since it's been coded to block e10s on XP unless browser.tabs.remote.force-enable is set to true - in which case e10s is enabled irrespective of these other prefs. These prefs do matter on later Windows versions (and are the preferred method of enabling e10s) but let's stick with FF 52.9 on XP for now. Once e10s is enabled, this controls how many additional processes you can have. There's one "core" process plus one process per open tab up to the limit set by this pref. Personally, I set dom.ipc.processCount to 2. The default of 1 gives me little benefit, but larger values just waste RAM while providing little additional benefit, at least in my experience. But as usual, YMMV.
  9. Yesterday
  10. I have all files and all those mentioned are loaded into memory on startup from RPCSS.EXE. DIGEST 6.0.2900.5512; MSAPSSPC 6.0.0.7755; MSNSSPC 6.1.1825; RPCSS.EXE and IEXPLORE.EXE uses DIGEST NEGOTIAT MSAPSSPC and MSNSSPC. KMPLAYER.EXE uses NORMALIZ 6.00.5441.0 I have no preference to which file is chosen except consideration could be shown to memory impact. Kexbasen nearly always gets shifted in memory because of clashing with my Msvcrt could Kexbasen base memory address be shifted up a little bit? AdvSplash.dll was in the temp folder after the file check extracted the install files.
  11. Well, the title of this thread (in the form of a question) is a tad misleading ; if the real question was Can you establish TLS 1.3 connections under Windows XP? then the answer, of course, is YES . Both UXP browsers (New Moon 28, Serpent 52.9.0), the Moebius fork (Serpent 55.0.0), the Tycho fork (New Moon 27) and probably other @roytam1's forks all support the final TLS 1.3 draft (RFC8446), as well as all three cipher suites associated with TLS 1.3: TLS_AES_128_GCM_SHA256 (0x1301) TLS_AES_256_GCM_SHA384 (0x1302) TLS_CHACHA20_POLY1305_SHA256 (0x1303) ; you can test TLS 1.3 support of these browsers with https://tls13.pinterjann.is/ https://swifttls.org/ https://cert-test.sandbox.google.com/ (and a few other test URLs...). BTW, the NSS library in these browsers was recently downgraded from v3.44 Beta to v3.43 stable release; perhaps @roytam1 could share a word (or two ...) why that was necessary ... Additionally, I was recently informed that the excellent project ProxHTTPSProxy by @heinoganda has indeed achieved TLS 1.3 support under XP for the type of browsers (IE8, Google Chrome 49 and, possibly, earlier) that don't come with their own TLS support but rely upon system libraries for secure connections; so TLS 1.3 in itself shouldn't be an issue... But what is indeed specific is the configuration of linked test server, https://tls13.1d.pw/ It is no coincidence that a Russian member of this forum brought this up, because, it turns out that, the administrator of said test server is a Russian guy, Александр Венедюхин ! In fact, he maintains a blog where he documents this project and the TLS 1.3 test configuration of the server; original articles can be found at: https://dxdt.ru/2018/08/05/8597/ https://dxdt.ru/2019/01/26/8672/ As I'm not at all fluent in Russian (), I had to enlist the help of (evil ) Google, but what the heck... : https://translate.google.com/translate?hl=en&sl=ru&tl=en&u=https://dxdt.ru/2018/08/05/8597/ https://translate.google.com/translate?hl=en&sl=ru&tl=en&u=https://dxdt.ru/2018/08/05/8597/ I don't consider myself proficient in the field of cryptography and/or secure connections, but what I gathered from the translated text was that the server is configured to send a special HelloRetryRequest response to force a renegotiation of connection parameters; the implementation of Encrypted Server Name Indication (ESNI) along with non-ECDH manifested a bug in Mozilla's NSS library, so that is probably why the Firefox forks won't connect currently to that specific test server! (they yield a SSL_ERROR_RX_MALFORMED_SERVER_HELLO error code ). Hopefully, the reported bug will be fixed in a future NSS version, if/when that is applied to UXP, we'll have successful connection in the UXP forks... Frankly, TLS 1.2 is still predominant, but with 1.3 steadily gaining ground; this specific connection test is but a margin case where 1.3 is involved, so I won't be losing any sleep over it...
  12. I contacted him and he replied. Please note that his very first release release is expected to run on Windows 7 and above as it's just a test, so it will not on XP and Vista as there are many missing kernel calls. Even by linking it to our modified kernel there are still QueryThreadCycleTime, SHGetKnownFolderPath, SetProcessDPIAware, and an API API-MS-WIN-CORE-SYNCH-L1-1-0.DLL which makes use of OpenProcess which will prevent it to run on XP. I sent to him our code stored on GitHub and some of our compiled binaries, although I didn't send the compiled version of Chromium yet, but he'll be able to access it soon as I'm gonna add him to the Windows XP Forever group. C'mon guys, let's make this flipping browser run! EDIT: On an unrelated note, I'm trying Chrome 360, but it's asking me for a 360 Account. Can't I just log in with my google account? Is there a way to link those two? EDIT: Some messages about the CPU and other stuff are still in Chinese. Is there a way to get them in English?
  13. Well has the May update fixed it? Did anyone else using VMware (or perhaps Avast) encounter problems after installing the April updates, and have your problems been resolved now?
  14. An experiment at another forum suggests that you would still be able to get definition updates for Windows Defender, but this update would not be helpful at all immediately after reinstalling Vista. None of the updates posted May 11 have yet been replaced by newer file versions.
  15. Thanks for finding that. That is the version 1 that they kept tucked away nicely enough that DDG didn't index it.
  16. I use both MS Office 2003 (with compatibility pack installed) and MS Office 2010, with all updates installed, on the same system (Win7/Win10) without any problem. The next test with both Office will be on WinXP. For everyday use, I use Office 2003 According to microsoft, the FileFormatConverters (Version 1) is compatible with Windows 2000 sp4.
  17. Good. Meanwhile, 360 Chrome is working OK, and actually can display correctly things well beyond Serpent 52. Even if not perfectly compatible with Chromium 69, it sure is way beyond Google Chrome 49, and that's pretty useful as it is.
  18. I would like to use this opportunity to say that only the very first version (no SP) of the compatibility pack is compatible with Windows 2000 (vanilla; haven't tried later ones with the extended kernel). This version is no longer available from Microsoft though. So I wouldn't bother with updates in that case.
  19. For what it's worth, I had OFfice 2003 installed for years and kept on top of the compatibility pack updates... One day, one of the updates broke Office and I said to heck with it and moved on to 2010 with a classic menu add-on.
  20. > I finally got to look at debugging. There is no errors with DW for AdvSplash.dll or any other file. How did you determine that SetLayeredWindowAttributes not exported from User32.dll and stubbed? by KEX was the problem? AdvSplash.dll can't be profiled directly in DW, it must be done indirectly by profiling KMPlayer.exe. Method 1 directly identifies SetLayeredWindowAttributes. SECUR32.DLL is missing some functions; Kexbasen forwards them to Unicows.dll, but some are just stubs. They seems to be present in DIGEST.DLL, MSAPSSPC.DLL, and MSNSSPC.DLL. Does everyone have all of these DLL's? Which DLL should we use and what functions should we forward to it? KTree and DW can be used for this investigation.
  21. hopefully this is the right thread Can someone help , when I have Netflix going I get 2 instances of pluging in container, sure I only use to have the one this seems to be since i did a New profile is there a way of only having the one, OR does silverlight have its own seperate one ? should this be dom.ipc.plugins.enabled true or false Also I have the exact same settings (or sure I have) in prefs in my other XP SP3 PC, yet when I try to use Netflix I get plugingin container and sliverlight then disappears and get a DRM error, ............... is there a componet I could be missing / need or something I need to get DRM working or be looking for something missing deffo got all 6 blue ticks in the youtube/html webite i have Primetime on both XP SP3 PC's works fine on youtube fine on both have exactly same Silverlight version on both, have all the same plugins and files (even checked the WMP DRM files) If I go here http://html5test.com/ my other PC scores better than this one yet the other refuses to play Netflix but this one does
  22. Well, wouldn't you know: TryAcquireSRWLockExclusive requires Win 7. Sounds like he's way ahead of you....
  23. Any news about this project? I have just found it and it seems really exciting! Especially the fact that you're even considering making an api wrapper for NT 3.51. An Windows version looking like 3.11 but actually running newer software.. That's amazing! I can't wait for some news and updates. Any success with getting Chrome to work on NT 4.0?
  24. whats the point in compatibilitypacksp3-kb2526297-fullfile-en-us.exe ? what does it add / do?
  25. It doesn't seem to work on Windows Vista. "The procedure entry point TryAcquireSRWLockExclusive could not be located in the dynamic link library KERNEL32.dll." followed by an "Chromium XP has stopped working". Perhaps @FranceBB could contact the developers of this Chrome 76 project because his project at least didn't give an error in Vista (only the "Chromium XP has stopped working" appeared). This way they could combine their ideas and solutions and maybe, just maybe get Chrome 76 up and running.
  26. AcquireSRWLockExclusive was introduced in Vista, so perhaps it will at least run in Vista? As for converting to run on XP, perhaps it and related SRWLock calls could be replaced with a mutex or critical section, at the expense of performance.
  27. Zmultimedia, I assume you mean wxHexEditor. Download vs 0.23 as vs 0.24 has the errors as I explained which make it unworkable.
  1. Load more activity
×
×
  • Create New...